Phone rooted but not really

Last Updated:

  1. arnold22

    arnold22 Well-Known Member

    I rooted my phone a couple of days ago using SuperOneClick and then followed by RootExplorer and everything seem to install without any issues. The SuperUser icon appears in application and I am able to browse the the OS (Android 2.1) system file. When I tried to delete native apps such as Map.apk or voicedialer.apk it appears to work until I exit RootExplorer and re-open it again just to see the app was back.

    I tired un-rooting and re-rooting the phone again and rebooting the system with no success. I decided to try z4root to root the phone and got the same results. After getting frustrated with with the apps not appearing to work I open a shell and did it manually with command lines. I was able to get root access with SU and browse the system files but when trying to delete/remove one of the above apps I get "read-only file system".

    Are there different root access levels with Android or is it possible my service provided (Telus) further locked the phone making rooting permission limited?


  2. barqers

    barqers Well-Known Member

    Kris, try going into terminal and trying this:

    Get root
    check your root, should return uid=0
    Now remount your system:
  3. arnold22

    arnold22 Well-Known Member

    That seems to have worked. I had tried that same command but did not put and "," after remount.

    Thanks for the help Barquers
  4. arnold22

    arnold22 Well-Known Member

    It seems like I have to remount with terminal every time I restart my phone. I a little bit of a pain but at least it work.
  5. barqers

    barqers Well-Known Member

    I'm glad it's at least working for you. That's weird though, root explorer should remount your system for you. Try reinstalling root explorer or installing a different version and let me know if that fixes it!
  6. arnold22

    arnold22 Well-Known Member

    I already uninstall RootExplorer a couple of time and even got the lastest version I could find v2.7 and still had the same issue. Maybe I'll try to find another app but for the time being it will work.

    Does anyone have a "safe" list for native app which can be removed? I pretty much know most of them but wanted something to compare.

  7. barqers

    barqers Well-Known Member

    Hm, what i've removed is all the samsung apps and tw**** that i don't use.

    Also, snsaccount and snsprovider (facebook) unless you use facebook.

    DRMservice you can remove unless you have itunes music or amazon purchased music.
  8. arnold22

    arnold22 Well-Known Member

    Does anyone know if the apps below are useful or required to correctly run Android?
    Mobile Tracker
    Pico TTS
    Samsung Account
  9. barqers

    barqers Well-Known Member

    I know for sure Samsung Account isn't

    Pico TTS is for using Talk-To-Text. So if you use voice dialer, or voice texting then leave that.

    Badge provider is needed to authenticate with Google.

    I'm not sure about mobile tracker and mtpapplication though, it will require some googling :)
  10. arnold22

    arnold22 Well-Known Member

    After some research found out that MtpApplication (Media Transfer Protocol application) which seems to be used with Kies when you phone is connected to your PC. Could not find much more other then the many crash and issues with the app.

    Mobile Tracker is an app which you can register your phone and account with the Samsung online website to "track" your phone if it is stolen or lost by deleting personal data or sending text remotely.
    barqers likes this.
  11. barqers

    barqers Well-Known Member

    So basically i can remove both those apks now.

    Thank you ardnold22 :)
  12. arnold22

    arnold22 Well-Known Member

    I have renamed them just to test for a few days and see if I have any issue come up. If by Monday there is nothing, they are both gone.
  13. barqers

    barqers Well-Known Member

    K let me know. But even if you rename them, trying to name them back won't always work as a reinstall option. If it fails you have to give the apps root power.

    Look here:
    UnumMundum: Can't reinstall APKs? Easy Fix

Share This Page