"Phone storage is full!" but it's notSupport


Last Updated:

  1. gutted

    gutted Well-Known Member

    I found one other thread semi related to this... but not quite.

    Every now and then (it's happening more frequently lately) my phone will give me the "Phone storage is full!" Please delete files message when I open up a text message. When it happens obviously I cannot respond to a text. My phone's memory is NOT full. The first time it happened I cleaned out a ton of texts and it didn't solve it. I reboot the phone and then everything is fine.

    Does this happen to anyone else? It's more of an annoyance than a big problem - but it shouldn't happen. Anyone got any ideas? I read on one post that you could try to clear the cache on the phone. But I wonder if that person couldn't send a text even after a reboot. I'd think if a cache clear would fix it, that a reboot wouldn't.

    Advertisement
  2. savoxis

    savoxis Well-Known Member Developer

    Download/Open a terminal emulator and type

    df

    This will show you all your partitions and how much is on them.

    If you are running a rom with busybox (like any custom rom) you can type

    busybox df -h

    which will give you results in a more reader-friendly format
  3. gutted

    gutted Well-Known Member

    Isn't that only if you are rooted?
  4. savoxis

    savoxis Well-Known Member Developer

    No, there are a good amount of cli commands you can run without root
  5. d3310n

    d3310n Well-Known Member


    Yes it happenals to me its quite annoying i install 1 app and it freaks out
  6. gutted

    gutted Well-Known Member

    This happens to me without any app installs. When I download updates I run out of space occasionally (the main fault with the Ally to me is the woeful phone storage), but that's it.
  7. BillyStyle

    BillyStyle New Member

    savoxis, it seems as though you described how to verify that the phone's memory is or isn't full. Unless checking the partitions will tell you something to prevent the problem, I don't see what good that would do.

    I have the same problem. Last time I got that message and couldn't send a text, I checked and my internal phone storage available was over 14 mb. That should be plenty for text messages. Also, like gutted said, a reboot fixes the problem, so it acts more like a bug than an actual storage problem.

    savoxis do you know any other fixes for this problem?
  8. savoxis

    savoxis Well-Known Member Developer

    Though I am 95% sure txt messages are stored on data, it is very possible that it is in cache where a temporary copy is created prior to it sending, which is not part of your "internal phone storage" as reported by the UI. Your cache being full will make it so you cannot download applications from the market or content from the web as the temp download locations are in cache.

    Although, if someone could provide me a logcat of whats going on during one of these errors all mystery would be revealed (you can run apps like alogcat without root)
  9. RideZeLitenin

    RideZeLitenin Well-Known Member

    There happens to be a bug with the LG Ally that makes it so that every single time the internal memory goes beneath 15MB that it says "Internal Memory Low, etc." and it won't allow you to relieve texts. Very annoying, I know.
  10. BillyStyle

    BillyStyle New Member

    Alright. Well it will probably happen soon. I'll download alogcat and wait for it to happen again.

    Also RideZeLitenin, that bug seems to be what I'm getting. The phone memory is usually at about 13-14 mb when I get the error.
  11. themessenger

    themessenger Well-Known Member

    Yep, today mine said my text message memory was full, and I had a whopping total of 23 texts saved. I had just reflashed my ROM.
  12. Scorpion34

    Scorpion34 Well-Known Member

    I just updated several of my apps today & this came up. What I don't understand is that the majority of those apps were on my SD card, so why is it taking up the internal memory?

    I tried a reboot & it was still there. Has anyone found a fix for this? It gets really annoying anytime I wanna update an app.
  13. dragoness0722

    dragoness0722 New Member

    Rebooting did not resolve my problem of not being able to text. Like others said, if phone storage is under 15 mb then I get a message that says phone is full, delete...etc. The only thing that helps me is what my husb showed me: Go to Settings, click on manage applications (not ones on SD card) and delete the data. I wish there was a way to delete apps I do not use which Verizon automatically puts in. That possibly would take care of the problem.
  14. gittypops

    gittypops New Member

    There is a way to delete the preinstalled Verizon apps. You need to have the phone rooted. I had it done and couldn't be happier. I was able to delete, City ID, LG Social, Skype, and every other app that I have never used but is constantly running and I am paying data charges for.
  15. animatedroid

    animatedroid New Member

    same here on my D3. just did a factory reset, spent a whole day restoring apps to my phone and now Im trying to edit my alarm and it wont let me because it says "device storage is ful"

    **using TitaniumBackup, report are as follows
    I have 87MB is system ROM
    over 2GB in internal Memory
    over 12GB in Internal "SD"
    and over 15GBs in external SD.

    when i click the notif alert, it takes me to my App management screen, as if suggesting I uninstall some apps.

    This is a BUG of some sort. not an actual low on memory issue.
    I've rebooted, cleared cache, cleared dalvik cache.. no fix.

    w...t....f...
  16. animatedroid

    animatedroid New Member

    amidst my trial and errors,
    I decided to use ROM Manager's "Fix Permissions" and then rebooted.
    this seems to have fixed the false "low memory" issue.

    for everyone else, please note, this method is NOT going to fix the legitimate issue of having low memory alerts when you go below 25MBs of system memory.
  17. Paige2010

    Paige2010 New Member

    can you please tell me how to delete the unwanted apps verizon already put on my phone. my storage is running out more often and i have deleted everything!
  18. mermee66

    mermee66 New Member

    Mine does this CONTINUALLY, in fact, the replacement does it continually too! SO Frustrating. It's not full, full or phone memory. Verizon store said it was a software glitch and they can only "hard reset"... what a pain.

    So I downloaded the thing you said, Android "Terminal Emulator" and typed in df... and WOW what a long list... but I'm not sure what to do with this list. I was gonna try to root the phone and pull the ridiculous "blaotware" off, but my friend said, since I'm inexperienced that I can break the phone. I LOVE my Ally, but this software continual glitch is making me want to throw it across the room!

    Isn't there anything I can do, without a hard reset every week or getting a new phone? I'm not computer brilliant, but if you give me steps, (Lame-ons terms) I can follow them. Thanks!!!
  19. kwmusiclover

    kwmusiclover New Member

    My phone is doing this but i have a my-touch 3g and none of the posts have helped me.. how am i supposed to clear all of my memory stuff :-/
  20. Einsteindks

    Einsteindks Well-Known Member

    Go ahead and root your Ally, get CWM ROM manager, flash alternate recovery, install Among RA version 3.0.6 from recovery, then install Velocity 1.2.2. Of course, read up on all the directions for each before installing. Your Ally will be at optimal performance, many programs can install on SD (but not all). Without any accounts, my Ally still holds out on memory in the area of high 50s MB. You are well out of warranty and manufacturer software updates, so you need not worry about staying stock for either. Good luck!
    jmar likes this.
  21. Psylock7

    Psylock7 New Member

    Einsteindks, can you describe a little more how that long list of software gets the Ally to optimal performance? Are you deleting the applications that came standard on your phone, or are you just installing software that makes each application run more efficiently (if that's possible).

    I'm also looking to fix this bug, because clearing the browser data cache and others every week is getting old. It's also seeming to work less and less. I've moved apps to the SD card, cleared the cache, deleted unecessary apps... I'm still plagued by a full internal storage card.

    I'm wondering if all the updates to the standard applications (maps, Amazon, My Verizon, etc.) are taking up more space than the phone was originally designed for.

    Thanks.
  22. jmar

    jmar Nexican VIP Member

    Hey there. The Ally was my first Android phone. Let me see if I can help.

    You are rooted, yes?

    Good. You need to flash recovery. The easiest way is to download ROM Manager, open it, give it root permission, scroll to the bottom, as flash AmonRa Recovery. Next, download Velocity 1.2.2. It can be found in the All Things Root section of this forum.

    Now, boot into recovery. This can be done using as app called QuickBoot.

    Once in recovery, using volume buttons to scroll and the power button to select, choose Backup/Restore. Now choose Backup. This will create an snapshot of your phone before we wipe it and flash Velocity. That way, if you don't like Velocity or whatever the case may be, you can always go back where you were.

    Once the backup is made, Wipe data, wipe cache and in the advanced menu wipe dalvik cache. Once that is handled, choose flash zip from SD card. Navigate to the zip and select it to flash.

    When that is all done, reboot and sign in to your gmail account to regain all your contacts and emails, etc. You will notice that Velocity has less bloatware apps and some useful apps to enhance your experience.

    Hope this helps.

    jmar

    Velocity: use open beta 18. It is the last version this ROM: http://androidforums.com/showthread.php?p=3777099

    This is a helpful place if I forgot to mention something. http://androidforums.com/showthread.php?p=1483320
  23. cantonaist77

    cantonaist77 New Member

    my phone can't download terminal emulator.. "application cannot be installed in the default install location"

    i think because is memory is full..any other solving problem?

Share This Page