Phone stuck in headset mode.Support


Last Updated:

  1. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    Today I plugged my phone into my car stereo to listen to pandora. When I unplugged it the headphone icon turned into a headset icon. I have no headset and now it's stuck in headset mode. I cannot hear anyone who calls me, or talk to them. I did a quick search for this problem and found some response that suggested it had to do with the hearing aid function in call setting, but when I went into call setting, the hearing aid option was turned off. I've tried powering down and restarting but that did nothing. Please Help!

    I'm running a rooted version of 2.1, i don't remember which one but it based on the last leaked version of 2.1.

     

    Advertisement
  2. LED

    LED Well-Known Member

    Joined:
    Apr 5, 2010
    Messages:
    405
    Likes Received:
    65
    This happens to me sometimes. Just plug headphones in for a second, then remove it. This should correct the situation.
     
  3. dragonbro

    dragonbro Well-Known Member

    Joined:
    Dec 9, 2009
    Messages:
    262
    Likes Received:
    25
    Pull Battery, wait, reinstall battery. See if that helps.
     
  4. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    I've tried pulling the battery, no luck. Plugging headphones in and unplugging them does nothing either.
     
  5. xx_bishop_xx

    xx_bishop_xx Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    1,311
    Likes Received:
    172
    I don't know if this applies, but I had a co-worker here that had this same issue. It turned out that lint/debris of some sort had gotten pressed into the jack pretty well from being in his pocket. A carefully inserted paper clip, and some compressed air did the trick.

    *Edit* I'm resonably sure a factory reset would help this (seeing as though the battery pull didnt), as a last resort of course. Is this the first time you have used the headset jack/option? Perhaps a damaged jack?
     
    jchb and endrialb like this.
  6. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    I don't have a can of compressed air. I'm in a hotel right now, I can't even seem to find a paperclip around me right now, LOL. I'll try is when I can, in the mean time, any more suggestions?
     
  7. xx_bishop_xx

    xx_bishop_xx Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    1,311
    Likes Received:
    172
    Can you see anything in the jack? First time using it?
     
  8. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    Can't see anything in the jack, it looks clean. No this isn't my first time using it, I play pandora through my car stereo all the time using the headphone jack as well as using it for hands free calling through the stereo when in the car, this just randomly happened yesterday.
     
  9. rick311

    rick311 Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    673
    Likes Received:
    44
    this would happen with my old phone. i would have to put the headphones back in and SLOWLY remove it from the jack. i would have to do this a few times before it took.
     
    schrodingercat likes this.
  10. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    ^^^
    I've been trying this for the last several minutes. I've tried everything from pulling it out as slowly as possible to as quickly as possible, no luck. :(
     
  11. schrodingercat

    schrodingercat Member

    Joined:
    Jun 9, 2010
    Messages:
    7
    Likes Received:
    0
    This same thing just happened to me and pulling the headphone jack out slowly worked.
     
  12. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    I've been trying that. I'm pulling it out as slowly as i possibly can, it's not working.
     
  13. Hiroshika

    Hiroshika Well-Known Member

    Joined:
    May 30, 2010
    Messages:
    166
    Likes Received:
    24
    Looks like factory reset may be in order... Or a nandroid backup? Since your rooted?
     
  14. OUScooby

    OUScooby Well-Known Member This Topic's Starter

    Joined:
    Apr 18, 2010
    Messages:
    67
    Likes Received:
    2
    I'm starting to think it's a hardware problem, not a software issue. I going to go to verizon and get a replacement, maybe even complain my way to an upgrade. I've got to unroot first, having trouble figuring out how to do that.
     
  15. suffocater

    suffocater Member

    Joined:
    Sep 8, 2011
    Messages:
    8
    Likes Received:
    0
    same thing, this headset icon annoys me
     
  16. Mamfi

    Mamfi New Member

    Joined:
    Jan 23, 2012
    Messages:
    1
    Likes Received:
    0
    Hi! I had the same problem and it REALLY annoyed me. After reading this thread iI stuck a steel wire and played it around for a bit. Then I blew in it and hooked a jack in, and when I removed it the headphone icon went away :)
     
  17. maxtic

    maxtic New Member

    Joined:
    Feb 29, 2012
    Messages:
    4
    Likes Received:
    0
    My HTC is away show icon headphone and it can't talk. I found solution for fix it call app in market "HTC Headphone Fix"

    ======================================================
    If your HTC the headphones and mic icon showed up onscreen and can't turn it off...even though nothing's plugged. Your HTC it stuck headset icon.
    So you can't talk with normal mic on your phone , Only use with smalltalk. This widget can fixes problems with the 3.5mm headphone/headset fix jack HTC on android
    - Fix HTC the headphone jack that now it thinks there is headphone plugged in at all times
    - Automatic fix HTC to default mic/speaker phone output
    - Allows manual or automatic toggle of the headphones connector output. So you can manual routing to the headphones output
    After installing, press Menu button at the home screen, then add "HeadSet Fix" to widget
    ======================================================

    Now my HTC is normal talk ,No cost fixed , I happy with this app.
     
  18. saminbama

    saminbama Active Member

    Joined:
    Aug 9, 2010
    Messages:
    39
    Likes Received:
    1
    I have Galaxy S 1st gen (Sprint Epic 4g).
     
  19. the majestic

    the majestic New Member

    Joined:
    Oct 7, 2012
    Messages:
    1
    Likes Received:
    0
    that trick worked on my wifes phone thanks man
     
  20. Stave Rich

    Stave Rich New Member

    Joined:
    May 10, 2012
    Messages:
    1
    Likes Received:
    0
    htc sensation headphone icon stuck on
     
  21. MLH711

    MLH711 New Member

    Joined:
    Sep 20, 2013
    Messages:
    1
    Likes Received:
    0
    I had the problem of "stuck in headset mode" used a blow dryer on the phone for 30-45 seconds....problem solved....
     
  22. oluwagbayi

    oluwagbayi New Member

    Joined:
    Jan 5, 2014
    Messages:
    1
    Likes Received:
    1
     
    guardianx likes this.
  23. remusvisan

    remusvisan New Member

    Joined:
    Mar 9, 2014
    Messages:
    1
    Likes Received:
    0
    had the same problem, I stuck a toothpick in the jack really hard, pulled the tooth pick out and problem solved:)
     
  24. tomikagonzalez

    tomikagonzalez New Member

    Joined:
    Jul 25, 2014
    Messages:
    1
    Likes Received:
    0
    Thank u so much.... Pulling it out slow worked.
     
  25. Trenarenea

    Trenarenea New Member

    Joined:
    Aug 30, 2014
    Messages:
    1
    Likes Received:
    0
    I had the EXACT same issue as OUScooby; I tried in and out slowly, didn't want to stick anything in it...eventually I blew in it and it was fine.
    Thanks
     
  26. tg63

    tg63 New Member

    Joined:
    Apr 14, 2015
    Messages:
    1
    Likes Received:
    1
    Best Answer
    My wife's LG had the same issue. I think putting in the headphone jack and taking it over loosened the lint up but didn't fix it. No compressed air so I put my lips to the jack and gave it a quick bit of suction that way. Instant fix. Occurred to me after that I was lucky it wasn't a bug :-D
     
    Harri McG likes this.

Share This Page

Loading...