Phone stuck in Roaming after flashing MIUI Rom


Last Updated:

  1. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    Last night I flashed a MIUI Rom for the vs920...i dont know what it did but it must have changed my apn or vn or something but i tried flashing the cab, cm10.1 and cm9 with no luck. I have no service at all...any help would be greatly appreciated.!!!!
     

    Advertisement
  2. bones420la

    bones420la Well-Known Member

    Joined:
    Mar 29, 2012
    Messages:
    518
    Likes Received:
    82
    I'm not 100 percent sure. But I think the file you need to look at is /system/etc/apns-conf.xml
    Check that file with a root explorer and make sure it says vzw in it that ROM is setup for Chinese carriers. By tonight I should have a patched up version posted on here. No 4g. But I got data working properly
     
  3. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    I replaced that file with one from cm10.1, but everything since then has been no roaming
     
  4. MrB206

    MrB206 Well-Known Member

    Joined:
    Mar 4, 2012
    Messages:
    1,879
    Likes Received:
    254
    Under Phone > Testing the network type should be LTE/CDMA auto (PRL). Anything else will put you into roaming or cut off your data all together.

    You can't access that menu from stock, but you can if you use the PimpMyRom app in stock (I think... so they claim). Otherwise, you can access it in AOKP or CM10.

    I'd look there first to see what you have set.
     
  5. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    I have pimp my rom and its set to LTE/CDMA auto (PRL), but it still says its roaming.
     
  6. MrB206

    MrB206 Well-Known Member

    Joined:
    Mar 4, 2012
    Messages:
    1,879
    Likes Received:
    254
    Odd. What's your sim card setting?
     
  7. legmando33

    legmando33 Well-Known Member

    Joined:
    Jun 24, 2012
    Messages:
    639
    Likes Received:
    365
    For 4g also replace apn.xml in framework-res.apk :p that SHOULD get it to work.
     
  8. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    i've tried everything i've seen with the roms...it has to be a problem with the phone some settings have changed within or something
     
  9. MrB206

    MrB206 Well-Known Member

    Joined:
    Mar 4, 2012
    Messages:
    1,879
    Likes Received:
    254
    That's why I asked what your sim card settings show as. I had a rom change my sim setting and it prevented me from connecting to lte/cdma .
     
  10. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    mybad how do i check it?
     
  11. MrB206

    MrB206 Well-Known Member

    Joined:
    Mar 4, 2012
    Messages:
    1,879
    Likes Received:
    254
    No worries.

    Settings... More... Then mobile network.

    Simon should be this:

    uploadfromtaptalk1366952183695.jpg
     
  12. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    yes mine is set to that
     
  13. beddybeezy

    beddybeezy Well-Known Member This Topic's Starter

    Joined:
    Feb 11, 2013
    Messages:
    86
    Likes Received:
    6
    [SOLVED] I went into settings and factory reset and WALAAA when i rebooted my 4g was back on...I didnt have to use stock, i used cm10.1
     
  14. MrB206

    MrB206 Well-Known Member

    Joined:
    Mar 4, 2012
    Messages:
    1,879
    Likes Received:
    254
    lol. Crazy how some things will fix a problem, when everything else didn't.
     
  15. breadnatty08

    breadnatty08 pain rustique VIP Member

    Joined:
    Nov 8, 2009
    Messages:
    19,891
    Likes Received:
    6,119
    Moved to root subforum. :)
     

Share This Page

Loading...