Phone thinks it's charging when it is not.Support


  1. blu3phox

    blu3phox New Member

    As of two days ago, my phone randomly thinks it's charging when it is not. It goes on and off at random. It appears to also be causing a battery drain. It does charge while in the charger but it just always thinks its charging. Is there a way to resolve this or even an app that may fix this?

    Advertisement
    :
  2. rotusz82

    rotusz82 Well-Known Member

    blu3phox,

    I have the same issue on my phone as well. I've done some searching and seems this is an issue that randomly pops up. Some people have even sent their phones back to Samsung for repairs, but they never do fix the issue. I've tried everything from factory reset to deleting the Dalvik cache, even downloaded a battery calibration app to see if that would kick it into working correctly again. No luck though. It just started this about 4 days or so ago. I've got the latest Shabby mod on my phone as well as a few other items but none of which caused the issue. I did even try to flash the origional rom back onto it and that didn't change anything. Hopefully someone will be able to find the answer
  3. allan808

    allan808 New Member

    i got same problem too...would like to know whats going on..
  4. allan808

    allan808 New Member

    ok here it is,this is what i done to fix it.get the smallest flathead screwdriver you can find then get a clothe with 90% alcohol and clean the contacts inside the mini usb plug but be carefull you dont break the plug!my buddy thats a electronics geek told me the iphone had the same issue when they first came out,the cause was that when people put the phone in there pocket the lint and dust would get in the plug and cause a bridge where when you pull the plug out, the phone wouldnt recognise that it has been unpluged and thus the constant charging issues!! after cleaning my cloth i used to clean was black n brown with dust n lint...make sure battery is out and it is dry before you power up..so far my phone has been working perfect for 3 hours ive plugged in and disconected numerous time with no charging issues at all..hope this works for everyone else and thanks to my buddy (arron crossley) for this info!!
  5. rotusz82

    rotusz82 Well-Known Member

    Thanks for the info Allan.

    I had thought that thats what it was but wasn't sure. Does this explain why it shows going all the way to 100% on charging all the time as well?
  6. J6Remy

    J6Remy Well-Known Member

    It could be a number of things.. I'm thinking the battery has a malfunction, which you can go to just about any store..Best Buy, Boost Mobile shop..etc. and have the battery tested or just buy another one..and do the whole process of elimination.. Also the Prevail has a fail/safe.. once the battery gets hot at a certain temperature it will shut itself off..
  7. rotusz82

    rotusz82 Well-Known Member

    I haven't tried this yet but will later on. I have tried blowing into the port and that seems to stop it a bit as well. Of course thats a temp fix and i can see in there it needs to be cleaned out.
  8. justinswinston

    justinswinston New Member

    So, I had this problem with my last prevail and sent it back to the insurance company and received a new one today. Went through all the updates, upgraded everything, and had a perfectly working prevail. Happy right? Wrong. The problem came back after the 2nd day of use. This means it is probably not the battery (just received a new one) and also not the lint collecting in the plug (2 days old - no dirt in there yet). It actually started after I plugged it into my computer for the first time - when I unplugged it there was the charge signal on again without the phone being connected. I think this has something to do with firmware interacting with USB ports on W7 comps....not sure what else it might be at this point since the fact that it is 2 days old really puts everything else off the suspect list.
  9. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    OR, you used the SAME usb cord and whatever was stuck inside it when this happened the first time it's also now in the new charging port.

    ;)
Loading...

Share This Page