Phone will not charge completely.


Last Updated:

  1. brianvillage5

    brianvillage5 Well-Known Member This Topic's Starter

    Joined:
    Mar 16, 2011
    Messages:
    209
    Likes Received:
    150
    Running decks reloaded. 15 rc4 SBC fso Mason. Put my phone on charge last night at 33% woke up and it was the same. When I went to battery usage it showed that it was charging all night and was rising but only like two percent even though it didn't change. So I turned my phone off and kept it on charge for a half hour turned it back on and it was at 58%, usually if I just reboot while on charge it will blast up to almost full from almost empty in a matter of minutes. I have three extra batteries so I popped another on in and it doesn't seem to wanna charge either. Think its the kernel and I should revert to rc3? Or something else because cm7.2 rc3 gave me no problem with this kernel that I was aware of. Thanks for any input.
     

    Advertisement
  2. MizzouBrent

    MizzouBrent Well-Known Member

    Joined:
    Feb 13, 2011
    Messages:
    2,853
    Likes Received:
    2,519
    Sounds like maybe a bad cable. Hopefully it's not the port going bad
     
  3. bigbear6708

    bigbear6708 Well-Known Member

    Joined:
    Feb 11, 2012
    Messages:
    470
    Likes Received:
    224
    I dont want to blame anything on the kernel, because I know this kernel is AWESOME and solid...but I am having similar problems on rc4 w/ decks reloaded...My battery does charge to full, but I am having problems when it comes to properly reporting my battery life..like my phone was at 75% yesterday..did a reboot, down to 40%..it also does not update the % "in real time"..phone will say 4 hrs on battery, but only report 2 hrs..until it catches up..maybe your port is going bad..but I didnt seem to have these problems on rc3 or even .14.
     
  4. brianvillage5

    brianvillage5 Well-Known Member This Topic's Starter

    Joined:
    Mar 16, 2011
    Messages:
    209
    Likes Received:
    150
    Well its charging, So I don't think its a cable if I turn off my screen it will charge quicker but not completely. If I could get it to a hundred percent I would calibrate it. But I was Thinking mabye my surge protector, but it seems to do it no matter if I use it or not. I was really thinking it might be that rc4 Mason kernel because it started doing it when I switched to it. Mabye after work today ill revert to rc3 and see I'd that fixes it.
     
  5. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,861
    Likes Received:
    13,055
    Charge it with the phone completely off. This will negate any possible issues with the kernel and should charge it to 100% if your cable, charging port, and battery are Ok.

    I would also recommend wiping battery stats in recovery.
     
    dustwun77 and biker57 like this.
  6. brianvillage5

    brianvillage5 Well-Known Member This Topic's Starter

    Joined:
    Mar 16, 2011
    Messages:
    209
    Likes Received:
    150
    I charged it with the phone just now for over an qhour, after I reverted to rc3 and it only gained ten percent. You think it might be my port? It can't be the cable because I also tried with a couple different cable and a car charger. Same results.

    Thanks for your time, this is why I love AF.
    It does charge though, it says it is charging and about battery shows it is gaining it just doesn't gain a lot, like the slope goes up three percent over ten hours(while I sleep). So there is a connection. And I also tried a couple different batteries.
     
  7. tube517

    tube517 Well-Known Member Contributor

    Joined:
    Jun 7, 2010
    Messages:
    3,067
    Likes Received:
    1,329
    Sounds like a port issue. If you have tried different cables and different batteries then it is probably the port
     
  8. brianvillage5

    brianvillage5 Well-Known Member This Topic's Starter

    Joined:
    Mar 16, 2011
    Messages:
    209
    Likes Received:
    150
    I turned off my screen last night while charging and it fully charged. I have screen will never sleep while charging selected, but I never had that problem before. Btw I went back to rc4 and things are looking good again I just have to turn my screen off to allow it to charge all the way.
     
    dustwun77 likes this.

Share This Page

Loading...