Phone will not start


  1. juliangs

    juliangs Member

    I am running the following versions:

    Android 2.2
    Baseband 32.48.00.32u_5.10.05.30
    Kernel 2.6.32.15-g29e526b
    Build 2.17.61.3.CL274424release-keys
    Software 2.17.61.3

    I have unlocked the bootloader via the HTCDev instructions, no problems
    The phone still shows S-ON while in bootloader mode
    i have tried to run <fastboot flash recovery recovery.img> as directed by one of the blogs from 4ext but it will not run....i get image update error
    By mistake i ran <fastboot flash boot boot.img> from the Sandvold Beta ICS zip file which now means i get the picture of a phone and the red triangle with the exclamation mark when trying to start the phone

    I kind of want to break this into chunks.....What do i have to do to undo what i have done?

    Advertisement
  2. Tyseyh

    Tyseyh Well-Known Member

    Can't you run a RUU?
    you would lose everything though.
  3. juliangs

    juliangs Member

    i managed to find a stock RUU but can't seem to get anything across to the phone while in bootloader/fastboot made. I have got an SD card reader so i can see the contents of the card, i tried to track down the boot.img that i transfered but that must be held in memory on the phone as it is not a file on the sd card
  4. Hadron

    Hadron Well-Known Member Contributor

    So you put the phone in fastboot mode, connect it, run the RUU, and what happens?

    Truth is I have a bad feeling that I know the answer: that wretched official bootloader unlock "upgrades" your hboot, and the RUU won't run because it finds a newer version already there (it's an "upgrade" utility). I'm not sure how well the old "downgrader" tricks work with this (I've never actually tried it).

    You could try the following:
    * find an RUU as close as possible to your phone's software version
    * extract the ROM from the RUU into a .zip file, as described in this post
    * unzip the ROM .zip
    * fastboot flash the boot.img from the .zip file
    juliangs likes this.
  5. juliangs

    juliangs Member

    Hi Hadron,

    Couple of things....

    1. i have not been able to root the phone, not sure if that alters the approach?
    2. i have got the rom.zip and have copied it to the SD card and renamed it PB99IMG
    3. however when i try to open the rom in explorer, once copied, i get an error from windows telling me the file is invalid!

    Any ideas?
  6. juliangs

    juliangs Member

    this is doing my brain in, please someone help! There is so much information using different approaches and different apps/commands etc after a while you lose track of what you have done and what you need to do. i'm organised but this is proving to be very hard, my son wants his phone back.....please help. I can update in next quote if i get a response...thanks
  7. CJ0206

    CJ0206 Active Member

    Hey Juliangs

    I'm guessing you know how to use fastboot, if not just say and I'll give you a step by step. With the ROM you extracted from the RUU you should be able to open it with WinZIP and you will find the phones original boot.img there.

    Run fastboot and you can "fastboot flash boot C:\boot.img" If you can not find how to extract the boot.img I can email it over to you.
  8. walspara

    walspara Member

    ciao a tutti sono nuovo...volevo farvi una domanda...sempre se sono nella discussione giusta..io possiedo un HTC DESIRE a8181 lo comprato tramite un mio amico che aveva messo la room ... .allora ho pensato di mettere la ROOM originale , ma mi e andata male perch
  9. breadnatty08

    breadnatty08 pain rustique VIP Member

  10. Hadron

    Hadron Well-Known Member Contributor

    Hi walspara, and welcome to AF :)

    As Dread says, this really belongs in the Desire All Things Root forum, but I can tell you straight away what you did wrong: before running the RUU you should have flashed either the alpharev "downgrader" hboot or the "bravo stock" one ("downgrader" if you wish to remove S-Off and go completely to stock software, "bravo stock" if you wish to remain S-Off). The problem is that the "CM7 r2" hboot gives you a system partition that is too small for the stock ROM to fit, so the phone cannot boot. It has also removed your custom recovery.

    If your English is limited, the simplest might be to ask your friend to change the hboot, the run the RUU again. Otherwise, here are the steps:

    * You need to install "fastboot" on your computer. If you use Windows, there are instructions here: http://androidforums.com/desire-all...boot-windows-updated-1st-june-2011-a.html#”2”

    * Download the hboot img from alpharev.nl

    * pull the battery out. Reinsert, then boot the phone while pressing the "volume down" key down. This will get you a white screen with a menu on it. Select "fastboot" on the menu and press the power key.

    * when it says "fastboot" on the phone screen, connect to your computer via usb. It should now say "fastboot usb" on the screen.

    * test fastboot on the computer by sending the command "fastboot devices". If it returns your phone's serial number then it's working.

    * If it is, use the command "fastboot flash hboot <hboot-name>.img" to change the hboot

    * then "fastboot reboot-bootloader"

    * now with your new hboot, put the phone back into fastboot mode (if it isn't already) and run the RUU again. This time it should work.

    As I say, your friend will have had to do this already (to install the CM7 r2 hboot), so it might be best if he can do this for you if you are new to it.

    If you can't get fastboot working on your computer, you can download the hboot as a zip file from alpharev.nl. Copy this to your sd card (not in a folder, just the top of the card), rename it to PB99IMG.zip (exactly that, case-sensitive) and boot while pressing the volume down key. The bootloader will ask you whether you want to apply the update - confirm that you do. Then reboot, enter fastboot mode as described above (from the hboot menu), connect to PC and run the RUU.

    Good luck
  11. walspara

    walspara Member

    grazie grazie......provo e poi ti faccio sapere
  12. walspara

    walspara Member

    ciao....mi dovete scusare ....ho un problema il cellulare non si accende col volume (-) si accende solo con lo start sopra ,,,,, ho provato a fare vari combinazioni ma niente si accende solo col pulsante start e mi appare una schermata nera con scritta HTC in mezzo e 4 triangoli nei lato.....ho sbagliato qualcosa ????
  13. Hadron

    Hadron Well-Known Member Contributor

    Black screen with 4 triangles is something that happens when an RUU fails.

    Have you managed to change the hboot? If not, try this:

    * Download this file: alpharev.nl/PB99IMG_stock.zip. Rename it PB99IMG.zip and copy it to your sd card (replacing any other file with that name). Boot the phone to the hboot screen - the one that says:

    AlphaRev CM7 r2
    BRAVO PVT4 SHIP S-OFF
    HBOOT-6.93.1002

    The phone should ask whether you want to apply the update, then say yes. This is the same as how you tried to apply the RUU update.

    If that works, reboot the phone, then try the RUU again.

    If it doesn't let you update this way you'll need to use fastboot on a computer to fix this. Let us know if that's the case.
  14. Hadron

    Hadron Well-Known Member Contributor

    Do those images mean that the hboot would not run the PB99IMG.zip? If you have not tried that, try it first.

    If it will not work, then you need to install "fastboot" on your computer. If you use Windows, there are some instructions here: http://androidforums.com/desire-all-things-root/337356-faq-adb-fastboot-windows-updated-1st-june-2011-a.html#%E2%80%9D2%E2%80%9D

    Then download the bravo_stock hboot image: bravo_alphaspl.img.

    Then connect your phone to the computer using usb, and use the command "fastboot flash hboot bravo_alphaspl.img" to install the hboot image.

    Once that is done, reboot the phone. Then download the RUU you want to use as a Windows .exe file (not a PB99IMG.zip), connect the phone to a PC via usb and run the RUU .exe. That should fix it. Which RUU do you need (what network, for example)?

    Given that we're communicating via google translate, it really would be best if your friend who originally modified this phone could help you.

Share This Page