Phone won't chargeSupport


  1. mgdeftones

    mgdeftones Active Member

    I woke up this morning to only 66% battery life left, even though my phone had been charging overnight. When I got to work I put it on a charger again. I just checked it and I was down to 25%. The battery icon had the lightning bolt indicating that it was charging, but it obviously was not.

    If I plug it in with the phone off, I don't get the battery icon, so it's obviously not charging. It's frustrating because the phone says its charging when it's turned on. Any ideas?

    Advertisement
  2. mgdeftones

    mgdeftones Active Member

    Also forgot to mention, I got the newest version of Google Wallet to install, even though I am on a stock vzw Gnex, do you think that could be causing a problem? I haven't actually tried to use it yet, but it installed and runs.
  3. trophynuts

    trophynuts Well-Known Member

    try removing and replacing the battery yet?
  4. BamaTide

    BamaTide Member

    I started having the exact same issue about a week ago, but I'm rooted running JBS. I have factory reset twice and nothing. Mine only charges when the phone is off though, and won't charge when the phone is on. Also, when I charge it while off and then turn it back on it still shows the charging symbol even after unplugging it.

    I finally just called and filed a warranty claim with Verizon.

    RMFT!
  5. mgdeftones

    mgdeftones Active Member

    I pulled the battery several times. Did the same as above and just filed a claim. Was surprised how fast I got it. Put in the claim online last night at about 6:30, phone arrived today.
  6. Tim K

    Tim K Well-Known Member

    I think the USB ports on this phone are a little flimsy....
  7. teddyearp

    teddyearp A guide with guides Guide

    I will suggest what I always suggest. Buy an extra battery and battery only charger. I have found my batteries last much much longer both overall and for each charge than charging them in the phone. Been doing this for almost ten years now with all my phones.

    Besides, that port is too valuable for hacking and such, why wear it out just having to charge the durn thing?
  8. SensationalRob

    SensationalRob Active Member

    Same problem, same time frame here....I wonder if its a software issue. Mine also had the charging icon and says it is charging when it is not plugged in....additionally I had it on my car charger and I pulled the charger out of the socket and the light that indicates the charger is plugged in stayed on...so the power was running backwards out of the phone at that point maybe?

    I think it's a software issue...I can get mine to work but it's hit or miss, some chargers that worked last week don't work at all, some work once in a while, none work 100% of the time. All chargers work correctly with other phones.

    Done all kinds of battery gyrations....none seem to work.

    Weird.
  9. tube517

    tube517 Well-Known Member

    Ditto.

    I did this with my EVO 4G and now my Gnex. It saves alot of wear and tear off the USB charging ports on both phones. And my batteries do last longer than charging directly in the phone
    teddyearp likes this.
  10. Gekko

    Gekko Well-Known Member

    try a different charger. and make sure it is newer and of high quality. sometimes the charging ends (microUSB side) of chargers get bent and loose over time and fail to charge.

    good luck.

Share This Page