Phone wont give me USB connect optionsSupport


  1. Andeh

    Andeh Member

    Just recently, my phone doesn't give me the options anymore when i connect it via USB to the PC. I know the cable isn't at fault because it works with my tablet just fine.

    It was working ok the other day and i came to download some pictures from my phone and it doesn't seem to want to give me the options anymore in the taskbar to use it as a disk drive.

    The phone charges, the LED indicator lights up and the battery icon is going up and up and Windows shows a greyed out removable disk but when i click it it tells me to "Please insert a disk into (F: ) Removable Disk"

    I'm running ARHD 6.5.1. I also want to update it to the latest version of this ROM but for reasons above, i can't get the files on my phone.

    Any ideas!?

    Advertisement
  2. huy_lonewolf

    huy_lonewolf Well-Known Member

    Have you tried setting the default connection type to "Disk Drive"?
    If you want to copy files to your phone, why not just remove the SD card and plug it in your laptop? It is practically the same thing as using USB mode.
  3. johncf

    johncf Well-Known Member

    Yes change the connection type, goto settings connect to pc, and you
    can choose there what you would like it to do
  4. Andeh

    Andeh Member

    I have tried that but it doesn't do anything.

    As for taking the SD card out and plugging it into my laptop, my laptop doesn't have a microSD card slot on it and i don't have a microSD to adapter to put it in the standard SD sized slot.
  5. Andeh

    Andeh Member

    I have solved the problem.

    Yesterday i accidentally dropped my phone in the sink which was full of water at the time. :eek: After a night drying out it all seems to be working ok.

    I don't recommend this fix to anyone but it worked for me.


    Stupid technology!

Share This Page