1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Phone won't read SD card


  1. oOMavrikOo

    oOMavrikOo Well-Known Member

    I'm running the latest aospCMod with firats at 100 18. I use an app called Cache Cleaner NG because it cleans the internal memoery and the SD memory. I've Bennett using it for about 6 months with no issues. I was using the app and for some reason it was taking way too long to clean the cache. I pressed the home button because back wouldn't work at the time. Afterwards my phone was very laggy. I noticed that the cache cleaner was still running in the background also. I tried wiping the data on the cache cleaner but kept getting force closes on Titanium Backup. So I booted into recovery and wiped cached and dalvik cache. The phone rebooted fine, but not it will not read the SD card at all. When I check storage settings it says unavailable. I've tried taking the card out and pitting it back in several times with many reboots, nothing's working. I've read online that a possible fix is to do a factory reset on the phone. Is this the only option?

    Forgive the lack of paragraphs. I'm on the phone typing this and am in a hurry and can't see where to break the lines. Thanks for album help guys.

    Advertisement
  2. LBPHeretic

    LBPHeretic Well-Known Member

    Sounds like you might have corrupted your microSD card. Perhaps you canceled the process by rebooting while it was in the middle of writing something.

    Are you able to read the card using a microSD card reader? You may have to format your microSD card.
  3. oOMavrikOo

    oOMavrikOo Well-Known Member

    I don't have a SD card reader. Is a factory reset from the phone settings the same thing as wiping data from recovery? I think the answer is no but I just wanna make sure.
  4. LBPHeretic

    LBPHeretic Well-Known Member

    If you plug your handset in with a USB cable, can you mount it and see the contents of your microSD card on your computer? If not, then it is probably hosed and either needs to be formatted or replaced.

    I hosed an SD card in a digital camera when it was writing to it after taking a video. I stupidly shut it off before it was done writing the data. You can try wiping data, which is technically a factory reset. If I were you, I would put an alternate microSD card in and do a Nandroid backup first.
  5. oOMavrikOo

    oOMavrikOo Well-Known Member


    I'll have to try using the CPU when I get home later. I also want to correct myself from earlier. It doesn't say it can't read it. It says its not mounted. That there is no external storage. Is that the same thing?
  6. LBPHeretic

    LBPHeretic Well-Known Member

    Go into Settings, then SD & Phone Storage, and there you can mount it. That might solve your issue.

    Let us know if that helped. Cheers.
  7. oOMavrikOo

    oOMavrikOo Well-Known Member

    Just plugged into the cpu, not even showing usb mass storage options. I've also tried a different sd card and that's not working either. I'm gonna try a factory reset from the settings and see what that does...

    Edit: Factory reset fixed it. Still sucks that I gotta set everything up again.
  8. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Sorry I was busy yesterday, I don't think you needed to do a FR, you could of tried it with a reader first, then you could of also used the media scanner in the phone and try it again
  9. oOMavrikOo

    oOMavrikOo Well-Known Member


    It's ok. After restoring with TB, fixing the settings, and adding some widgets, I'm back up and running.
  10. LBPHeretic

    LBPHeretic Well-Known Member

    Did you ever try mounting it like I said above? Sometimes, in very rare cases, it will just show as unmounted.

    In that case you have to remount it yourself. You could have potentially saved yourself some trouble.
  11. oOMavrikOo

    oOMavrikOo Well-Known Member


    Yeah I tried that. It didn't work.
  12. oOMavrikOo

    oOMavrikOo Well-Known Member

    Ever since this happened to my phone, Facebook wont load the profile pics in my contacts. I can see all of my friends, just not their profile pics. I normally join my phone contacts with my Facebook contacts in order to use the pics for each contact. I've had Facebook synced since early this morning. Maybe I've just never paid any attention, but does it normally take more than an hour or so to fully sync with Facebook?

Share This Page