Phone won't stop restarting after reassemblySupport


Last Updated:

  1. thexinferno

    thexinferno New Member This Topic's Starter

    Joined:
    Feb 12, 2013
    Messages:
    1
    Likes Received:
    0
    I bought a new digitizer for my phone and tried putting it in today. After reassembling my phone four times i found that the new digitzer wasn't working, so I reassembled my phone with the old one.

    But now my phone keeps on showing the black and white SAMSUNG splash for a few seconds, shutting off and then doing it again. Is there some sort of hardware issue at play? I thought it was the ribbon cable going from the digitizer into the motherboard but that seemed like it was connected properly, and all the other cables seemed to be connected properly too. Does anyone have any ideas?

    My phone isn't rooted or anything either.

    Thanks!

    edit: I tried pluggin the phone in, it keeps restarting the battery charging animation when it's plugged in. I also tried putting it on download mode but it shut off and restarted in around the same amount of time as it does when it's showing the battery charge or SAMSUNG splash...
     

    Advertisement
  2. skrapmetal

    skrapmetal Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    377
    Likes Received:
    44
    If it wasn't doing it before, it's obviously something that happened during reassembly. The connector pins are TINY, if i were you, i would take it apart once more and go over every single connector with a magnifying glass and check for bent pins, reassemble slowly, double check everything. Look for bent pins, torn ribbon cables, and anything that looks out of the ordinary.
     
  3. Madbat

    Madbat Guides Guide

    Joined:
    Feb 9, 2012
    Messages:
    2,558
    Likes Received:
    973
    I had this too. Turned out the power button was faulty. It was stuck pressed in internally.
     
  4. Tokenpoke

    Tokenpoke Well-Known Member

    Joined:
    Feb 10, 2011
    Messages:
    3,110
    Likes Received:
    1,155
    When doing the job did you make sure you weren't carrying a static charge? I do all my stuff in a wooden chair on a tile floor and discharge static in my person by touching my window frame before picking up my screwdriver.
     

Share This Page

Loading...