Phone won't turn on

Last Updated:

  1. hr999

    hr999 New Member

    Hi everybody,
    i am new user to android and i was trying to root my phone which is samsung galaxy s .odin3 showed that it failed and after that i unpluged the usb cable from phone and now the phone is not turning on. i tried to remove the sim card, sd card and battery but it is still not turning on. please help me with this matter.

  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Hello hr999, welcome to Android Forums.

    It sounds like you've replaced the bootloader during the Odin process, and the failure issues cause it to abort prior to completion. Now you may have a classic "bricked" device.

    I've placed your query here in the All Things Root Galaxy S sub-forum, so others who've seen this can chime in with some advice. I suspect it'll have to do with an attempt at flashing the stock software into the device again.

    Let's see how it goes.
    hr999 likes this.
  3. Shine.

    Shine. Well-Known Member

    Yes, your going to have to put your phone through the odin process again(assuming you still have download mode, Vol down+power+home)!
    Download your stock firmware from here: Samsung I9000 Galaxy S Firmwares.

    Once its downloaded extract it to your desktop(easier to work with this way)

    Now run odin, And add the pit file you have on your desktop. Make sure you TICK re-partition.Proceed to add the PHONE and CSC also located on your desktop.

    Now put your phone into download mode(volume down+power+home) and once you see the android digging in the yellow triangle plug it in to your computer.

    Odin will recgonize that you have plugged it in and respond by lighting up a box yellow and saying added in the white progress box. Now Click start and let odin work its magic: )
    hr999 likes this.
  4. hr999

    hr999 New Member

    thats my whole problem. Phone won't turn on .. not even for download mode.. i even tried to charge phone that is not happening either.
  5. Shine.

    Shine. Well-Known Member

    Well..I think that classifies as a true brick:mad:
    The phone is completly un responsive? Try a new battery? Try putting in on charge then putting in the battery? Im stumped! just shooting ideas.I hope you make out ok:(
    hr999 likes this.
  6. hr999

    hr999 New Member

    Thanks, i hope someone can give me some suggestion. I bought phone on full price and no contract n it's brand new :(. so it would be a big loss for me...
  7. Shine.

    Shine. Well-Known Member

    Hey man, any updates on the phone? Try any new ways to start it? I was thinking maybe a download mode jig would bring it back?
    I got two form ebay a couple of weeks ago for $3.98( thats WITH tax and shipping):)
  8. hr999

    hr999 New Member

    well i went to this store and the guy said he doesn't know how to fix it. he can fix it if it will turn on :(.. n download mode jig is for soft bricked phones. and they turn on... mine doesn't. :(
  9. Shine.

    Shine. Well-Known Member

    This is stressing me right out, I am searching everyone to find a solution. If you have a friend with a galaxy s try using his battery. If that does not work put your battery in your phone and put it on charge for a night, it cant hurt! It might boot up, Ive heard of that working once! Best of luck, Ill keep my eye out for you:)
  10. GenesisNemesis

    GenesisNemesis Well-Known Member

    I bricked my Galaxy S through installing the wrong firmware with odin. Could not get past boot image with no recovery or download mode.

    However I bought]this and it worked like a charm. It took about three seconds to go into download mode so I plugged it into odin and installed the correct firmware from

    Now I have installed cyanogenrom 7.1.0 and the phone works perfectly.
  11. Frank8517

    Frank8517 New Member

    I have a T-mobile Galaxy S 4G and recently tried to root the phone to ICS and ended up bricking the phone. I already purchased a new phone but would still like to try to fix the phone if possible so I could have a decent backup phone. I have tried some tips from forums to unbrick the phone but none were successful (using a jig and various sequences for putting the sim card and battery and pressing the download mode buttons). Does anyone know of any proven methods to unbrick a the phone? My other (probably bad) idea was is there a part that can be replaced inside the phone to make it work again? Any ideas would be great.
  12. Rash

    Rash Well-Known Member

    If you seriously have tried all options of download mode, recovery & using jig then you probably a real dead phone check this

Share This Page