Phone's wifi connected but no data downloadSupport

Last Updated:

  1. gingerbreadguy

    gingerbreadguy New Member

    Okay, so my mini has a big wifi problem. I have a siemens SE568 router and my mini is running the arab version of the mini ( Build no: FROYO.JPKA3). So my problem is not the connection. I type in the security passphrase (WPA-PSK-AES) and it connects with the proper IP address and all.I even checked the router gateway and it says my phone is connected properly But when i go to the browser or any app that requires an internet connection. Nothing opens up!...Trust me im no noob when it comes to android phones..ive tryed everything(resetting router changing channels, levels of security WPA to WEP to no security, switching MAC filtering on/off, changing the bands from b/g to only g (N is not supported by my router which may be a problem but i dont have the money to buy a new one), etc etc. and on the phone side ive resetted the phone, factory erase, hard reset, forgetting the network and retyping the passphrase. everything. Ive tryed most of the stuff one the internet pull the battery when the phone is on....But the best ive got was a few pages then back to nothing...Please help me or atleast tell me ur facing a similar problem with a similar router.

    OH YEA: ive tryed changing it to static IP as well but no luck :(

  2. mitra_jit2005

    mitra_jit2005 Active Member

    Try reinstalling the wlan driver using *#*#526#*#*


    try this in terminal..with superuser permission..

    # mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system

    # chmod 755 /system/etc/dhcpcd/dhcpcd-run-hooks
  3. gingerbreadguy

    gingerbreadguy New Member

    Tried it the first one and didnt work.
    I dont want to try the second one because i just got the phone 3 days ago and i dont want to root it already....ill wait till my warranty gets over
  4. mitra_jit2005

    mitra_jit2005 Active Member

    Does the same thing happen when you use internet from network services ? Like HSDPA or 3G ??
  5. gingerbreadguy

    gingerbreadguy New Member

    Nope...just the wifi....and also i checked the wifi at my friends place and it worked totally fine there....
  6. cevonne

    cevonne New Member

    I'm sorry since your expecting for a reply but I have a question similar to this. My Samsung Galaxy Mini can't seem to connect to public WiFi. When I switch my phone's WiFi it will connect but when I use an application or any application needing an internet connection a notice that says data cant be downloaded and so I can't use the WiFi. This includes WiFi from fast food chains like McDonald and such. Can someone tell me what to do? but please make the instruction as simple as possible because when it comes to phones and computers I'm kinda lost. Thanks.
  7. devnar2000

    devnar2000 Member

    I've galaxy mini in US. I've upgraded to 2.3.4. My experience is that Galaxy Mini can not handle WEP encryption for WIFI. I would be happy if someone can prove me wrong.
  8. wagdi

    wagdi New Member

    (cannot connect to server.please chick wifi network) o.p. is windows 7 android: galaxy mini it seemsthat the problem is in the phone......any suggestions?
  9. awgz17

    awgz17 Active Member

    I have a similar problem. My phone (Cricket Huawei Ascend Android 2.1) will connect to the Wi-Fi network but when I open an app like YouTube I receive the error "There is no network connection right now." If I try downloading an app from the market the download will start but then it pauses itself and wont ever finish downloading, not even one percent of it. But when I connect to my brother's Wi-Fi in his home it works just fine. Even weirder is that it used to work great months ago and now all of a sudden it doesn't

Share This Page