Photo Album- Sudden Issue!

Last Updated:

  1. The Dark Knight

    The Dark Knight Active Member This Topic's Starter

    Dec 1, 2009
    Likes Received:
    I dropped my Hero today, but fortunately I had the device itself contained within a snap-on plastic cover (Basically faceplates), and that in turn was within the thick leather case. After I picked it up however, the camera was acting funky (It wouldn't fully widen when I placed it in landscape mode). I restarted the phone, and then I received a "Damaged SD Card" warning. I received this the last time I dropped it in the very same manner, and so I took the assembly apart, removed the SD card, re-inserted it, and then rebooted my Hero.

    Now, the phone does work, and fortunately the card is being read (My files are all still on it), but I am having an issue with the "Camera Shots" album. When I open the "All Photos" album, containing my downloaded images, my videos, and the photos captured on my camera, the album itself opens fairly quickly (Meaning that the image thumbnails load pretty fast). However, when I open the "Camera Shots" album, it keeps lugging along forever, and ever, and ever, and ever. This is despite the fact this album has 2,000 fewer images than the "All Photos" album. My 300 strong "All Videos" album also opens quickly, and the videos play smoothly as well.

    So, what is the problem? Just a few days ago I had absolutely NO issues whatsoever with the "Camera Shots" album, and I also had 15 fewer MB of ram back then too!


Share This Page