Photo Location Problems - faulty hardware, or Android's fault?


Last Updated:

  1. GStadium

    GStadium Active Member

    I've had a series of problems with photos on my Motorola Xoom (now with Jelly Bean). These are mainly stored on a 32GB SD card, and the problems initially manifested themselves in images that showed as blanks in the standard Gallery app. I downloaded an app called SDrescan but it didn't seem to help. I've run another app called SDCardTester a few times and it shows no problems on my SD card.

    The number of photos in my subdirectories reported by the Gallery app seems to increase every time I rescan (I haven't added any recently) and bears no relation to the actual number. A directory called "New York 2012 1" reports 4041 images in Gallery but only 449 in QuickPic (the QuickPic count matches the one for the same folder on my Windows PC). In the Gallery app, I still have the blanks but also see a lot of the photos shown twice or more.

    What's worse, some photos seem to have disappeared altogether, which isn't helped by the fact that Gallery only shows the path when you select an individual photo and click "Details". I've tried to "unhide" a few photos from an app called KeepSafe and this worked when I first used the app but not now. I select the pics and click "Unhide" and confirm but then see a message saying "0 photos unlocked". Neither Gallery nor QuickPic seems to have any easily configurable list of directories (folders) to show, and I've lost track of where these "unhidden" photos should appear if they did unlock successfully. I've always found Unix-style path conventions (or the lack of them) frustrating. At least in Windows you can be reasonably confident that the default location for photos is in "Pictures" or "My Pictures" within the user folder - on Linux, Solaris and Android there seems to be any number of different places where they could live. (Is the default save location under the control of a non-"rooted" user?)

    I've seen the odd report online of people having similar problems, but nothing conclusive. Has anyone any idea of what's going wrong here? Have I got faulty hardware, or is it just that Android Ice Cream Sandwich and Jelly Bean both have serious bugs in file management? Thanks in advance for any hints or tips.

    Advertisement
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Have you mounted your SD Card to your PC and searched for it from there? Is there anything else on your card you seem to be missing?
    Using Astro, if I click on "Pictures", it agregates all my photos (screen shots, wallpapers etc) into one section even if they're stored in different locations (this is on my Nexus 7).
    I'm not familiar with the Xoom specifically, but they're both running stock Jelly Bean, so hopefully it's similar.
  3. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Personally, I would try clearing the cache of the gallery app. Then I would clear the data for that app too, although I'm not sure if you can do that without a factory reset if you're not rooted. Worst comes to worst, a factory reset is something you might have to try.

    I'm not really sure what you mean by hidden photos. That keepsafe app is for hiding photos, but you can't unhide photos you didn't deliberately hide yourself, if that makes sense. It isn't for troubleshooting missing photos.

    I know quickpic refers to hidden photos too, but that is referring to showing pictures from directories that are normally skipped over by quickpic. So for example, I see lots of app assets, music album art, podcast logos, etc, when I tell quickpic to unhide everything.

    You mentioned not being able to set which directories quickpic scans. If you go to Settings >> Browse and then pick 'included folders', only the directories you choose will be scanned for photos. So, if you put all of your images in the same folder on your sdcard (it doesn't matter where, so long as you know how to navigate there), and select that folder, quickpic should show you all of your images and nothing else.

    Then you can just add any new pictures to that same directory and they'll show up in quickpic too. Ensuring they end up in the right directory will depend on where those images are coming from.
  4. jmar

    jmar Nexican VIP Member

    If I was in your shoes, I would backup everything onto my computer, including sdcard contents.

    Then I would format the sdcard and factory reset to a clean install of Jelly Bean. Big Pain In the Arse but it is what I would do and have had to do with my GNex.

    Honestly though, I wish I could help more but this is the best I have for you.

    Let me know how it goes. Good luck.

    jmar
  5. GStadium

    GStadium Active Member

    Thanks for the suggestions.

    I've just connected the Xoom to my Windows PC and the directory view looks bizarre from a Windows viewpoint. (Unfortunately it looks as if I can't insert an image in this posting without uploading it to the web somewhere, and I don't have a suitable location.) I'll have to be content with describing it.

    At the top level, Computer > Xoom shows "SD card" with 25.1GB free of 29.7, which should be about right. When I click on this, the heading changes to Computer > Xoom > SD Card as expected. However, I then see what look like multiple copies of each directory, regardless of the view selected in Windows. I have Documents 12 times, LOST 11 times then LOST.DIR once, then Music and Pics each 12 times. I know Android is Linux based but I don't think duplicate directory names at the same level are any more valid in Linux than in Windows - are they? Does this mean my SD card is completely scrambled?

    Computer > Xoom > Internal Storage looks much more reassuring, with no duplicate names.
  6. GStadium

    GStadium Active Member

    Sorry, I wasn't clear there but these were photos I had hidden myself by putting them into the app's "safe". They can only be used by other apps when they're "unhidden" so I tried to do this prior to sending them to someone. I realise that it's not a disc repair tool.
  7. GStadium

    GStadium Active Member

    Thanks - I think I have established that my Mediastore database was corrupted and, with the help of an article on the Motorola forum, have fixed things, at least for now. In case anyone else might benefit from it, the link is https://forums.motorola.com/posts/cf07acdc3a

    Fingers crossed.
  8. GStadium

    GStadium Active Member

    Incidentally, the method described above does work (that is, it fixes the directory temporarily). It always goes again eventually, so I've had to do this several times over the period that I've owned the Xoom

Share This Page