Photos and Videos vanished from phone after linking usb to pc... Help!

Last Updated:

  1. jujuberry

    jujuberry New Member

    I wanted to free up some space on my HTC Desire so connected phone to my pc via usb and selected some photos to upload. Once finished I unplugged USB cord and every single photo and video has been deleted from my phone.
    Can anybody help?

  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!

    Did you remember to safely eject from your PC and then re-select for usb charging on your phone?

    Try pulling down notification bar, if it says you are disk drive mode, click that.

    If things are really scrambled, try first to cycle power, if that doesn't work, reconnect to your PC and try a file repair on the sd card.
    UnplugMe likes this.
  3. chanchan05

    chanchan05 The Doctor Guide

    Maybe he "moved" the photos to the PC instead of copying them?
    EarlyMon likes this.
  4. UnplugMe

    UnplugMe Well-Known Member

    I'm struggling with this as well, and if you google, you'll see it's a very common problem with Android phones across the board.

    The phone stops seeing the SD card files, can't pull them up directly, bluetooth transfers won't work, photos, music and ebook cover art can't be seen by the phone anymore.
    If I use Astro File Transfer to navigate the card, I can see the files. They are still there, they're just invisible to the phone. It's blind, deaf, and bluetooth disabled. (Object Push Profile receives a "false" response (or some such message which I'm quoting from memory).

    I've read a hundred times "it's your SD card, reformat." It doesn't work.
    My card is fine, it's a full retail Sandisk from Staples, and works elsewhere.
    It's something in Android that is the problem!

    I just read about something called a "fastboot" bug in Gingerbread and am wondering if it's related, but can't find much about it.

    I've tried the SD rescan app as well, it didn't work.

    My new phone was fine before turning it off.
    After hours of removing files, restoring them, reinstalling apps from the card, etc. I finally got it so it could see photos, mp3's and ebooks. I tested for a couple of hours, turned it off, left it to charge, booted up today and the photos and music were gone again.

    It's so frustrating!!!! It isn't just me, and it isn't the danged card. It's something wonky in the operating system. JMHO.

    By the way in my case the phone is a Sony Ericsson Xperia mini pro SK17a running Android 2.3.3.
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    OK, I believe you and I am not being condescending.

    But believe me when I say that I have a great track record helping people with SD card issues in Android - this is the largest and oldest Android user self-help forum there is, and I range across all Android handsets here.

    This is the first time I have heard that this is a grave and widespread Android problem.

    Please, go slowly and explain your observations here, let's solve this!
  6. UnplugMe

    UnplugMe Well-Known Member

    I would love for it to be solved. I appreciate the help.

    Do you want the short version or the long detailed one? I'll give you both to save time.


    Do a web search for "photos music disappear from android phone," (or substitute mp3 for music for other results) you'll see complaints from owners of Nexus 1, HTC Desire, Motorola Droid X, and more.

    If you search "bluetooth error object push profile false" and read them, you'll see many threads from people with different models of Android phones with very same problems.

    The reason I think they're related is they seem to happen about the same time. Last night I thought maybe the bluetooth was causing the photo/music problem. But now I think it's just the bluetooth can't see the card either, to send it files. But I'm no expert, not by a long shot. Just trying to use reasoning.


    In my case problems began when I tried to transfer free ebooks and free apps (Aldiko book reader, for example) from my HTC incredible to the new Xperia. Bluetooth was enabled, I was very careful to make them both discoverable with bluetooth on, etc.
    Bluetooth returned the OBEX "OPP" response "false" from the Xperia. Last time I encountered that problem it was between the Incredible and a G2. In that previous case, adding the app Bluetooth File Transfer fixed it. So I loaded Bluetooth File Transfer on the Xperia. Didn't work.

    I'd googled and seen many many cases of people with same problem, with different phone models.

    OKAY, separate problem begins:

    Noticed photos had disappeared from Gallery. Music disappeared from Music player.
    Spent hours trying to fix. In the process, googled "photos and music dissappear from phone," and the like. Problem is rampant.

    Replies to these complaints are usually "bad SD card, reformat, replace."

    However, the SD card in question works fine otherwise. It's a brand new Sandisk from Staples, retail package, not from ebay. I can see all the files when the phone is connected to the computer. I can also see them when using Astro File Manager on the phone. And the phone saw them for a little while. But after turning it off and on again, they disappeared.
    I did read in one thread that there is a "fastboot" bug in Gingerbread but can't find it again to link you. Could turn up nothing further about it.

    I've spent most of the last few days trying to fix this.
    I'm at my wit's end. The phone is for my mother, she's leaving for an overseas trip Monday, so I need a miracle or else it'll have to wait.

    Also I'm not capable of flashing roms or rooting, that's all way over my head.

    Phone with problem:
    Sony Ericsson Xperia mini pro SK17a, Android 2.3.3
    Was brand new in factory packaging
    Sandisk 4GB micro SDHC card, was brand new in packaging, purchased at Staples.
  7. sohguanh

    sohguanh Well-Known Member

    Hi I don't know if my experience is same as yours but I previously do the same as you and all my pictures/videos gone.

    I play around and discover whenever I plug in USB to the smart-phone, something appear on the Notification bar and then I pull down I see some option. Charge only, USB mass storage etc. It seems when I want to read files on my sdcard when I plug in USB cable, I must select the USB mass storage and then I can use my PC explorer to put files over to the sdcard directory.

    Now after copy finish, I must pull down from Notification bar and then select the Charge only. The USB disappear from my PC explorer. Only then I will pull out the USB cable. It is this step I did not do that wipe out all my files/videos.

    I am still puzzled as to how Android OS handle this USB mass storage thingy. I was thinking maybe those files are not deleted just not visible as I use ADB I see some MediaScanner working in background when I choose Charge only after files copied over. I was suspecting possibly whenever files are changed, Android built-in MediaScanner need to re-scan those files and do something to it such that later when we use the Gallery app we can see our pics and videos ?
    UnplugMe likes this.
  8. UnplugMe

    UnplugMe Well-Known Member

    One more search to check out:
    phone stops recognizing SD card

    I see LG Banter, Samsung Mythic, Galaxy S, AT&T forums, Samsung Rogue, Droid 2, Verizon LG Octane on the first page.
  9. sohguanh

    sohguanh Well-Known Member

    Hi thanks for the link so I think it has got something to do with Android OS itself instead of manufacturer problem.

    My gut feel is after we copy files to the sdcard. We need to trigger the Android OS to re-scan those newly added/updated files so internally it can do it's own job possibly indexing files etc. So if we pull USB cable out directly, that trigger is not activated and hence to Android OS those newly added/updated files do not exist ?

    Hmm... still trying to find some logical explanation.
  10. UnplugMe

    UnplugMe Well-Known Member

    THat sounds reasonable.
    With my HTC incredible, I'm used to selecting "mount as a disk drive" when I tether the phone, if I want to access the card. But with the Xperia, it does not give me that option.

    Also, before I disconnect, I always use the "safely remove hardware" tool from my computer's taskbar to remove the incredible. However, the Xperia does not show on the list.

    I can see it in Windows Explorer, it has a beautiful Xperia Phone icon, and inside it shows the SD card and its capacity. No problem seeing everything on the SD card or transferring files.

    I tried installing its built-in software as well, but there is no "safe removal" or "eject" tool included. I looked everywhere. So the only option is to pull it out.
  11. sohguanh

    sohguanh Well-Known Member

    I am not using HTC or Sony Ericssons so I cannot comment. But for my Motorola when I plug it in, something appear on the smartphone Notification bar which I can pull down and do some selection. One is to 'turn on' mass storage and the other is Charge only. I choose Mass Storage, the USB icon appear automatically in Windows explorer. Once I choose Charge only, the USB icon disppear automatically in Windows explorer.

    But I did install the Motorola provided USB drivers so I was thinking maybe this driver is offering such features ? No USB drivers the behavoir is different ? The mystery deepens now... hmm......
    UnplugMe likes this.
  12. UnplugMe

    UnplugMe Well-Known Member

    Found the comment about the "fastboot" or "fast boot" bug. It's in the comments of this page:
    SDrescan | AppBrain Android Market

    Here is a quote:
    I did try that SD Rescan app and it didn't work in my case, unless it takes a really long time and I didn't wait long enough.
    It went to a black screen and said it would rescan, but didn't seem to do anything after, so I closed it.
  13. sohguanh

    sohguanh Well-Known Member

    I am on 2.1 and I also experience the same thing so I believe this is not specific to Gingerbread fast boot bug.
  14. UnplugMe

    UnplugMe Well-Known Member


    I was able to fix the problem but I don't know for certain if it's permanent. I powered the phone on and off a few times and it seems to be.

    The problem is the directions for USB connectivity are not complete. In addition, on my particular model in order to read them one must have a data plan.
    The instructions are not copied to the new SD card when it's installed and prepared, so it tries to link to internet.

    Even so, the directions are not complete or accurate for the following reason.
    There's something called MTP which is enabled by default. When you connect the phone to the computer, it uses this to transfer files using a tool such as Windows Media Player. However, it does not provide an eject or removal tool if you use another method such as Windows Explorer, drag and drop.

    Changing the setting to mount as a disk drive allowed for safe removal, but I had trouble accessing the card. I don't know if that would be the case for everyone.

    So what i had to do (after reformatting the card by "erase," unmount, power off, power on, then it "prepared" the card with necessary phone files) was use the default MTP setting, copy and paste the files to the card via Windows Explorer, close Windows Explorer, go to the phone while still attached to the computer and pull down the dropdown menu, switch to the other mode (MSC), then it appeared on the safe removal tool. Only THEN I could safely remove the drive.

    I have also instructed Mom not to boot up the phone while it's plugged in to charge, just in case the "Fastboot Gingerbread bug" has anything to do with it.
    I was not about to undo all the work and test that.

    Thank you sohguanh, reading your post made me try again. Thanks also to the moderator EarlyMon for trying to help. Your post also mentions the dropdown menu notification bar, I just didn't fully understand.

    I hope this can help someone else.

    Why a Safe Removal Tool is not built-in to the MTP connectivity for drag and drop or Windows Explorer is beyond me. :cool:
    I'd notified Android development of this widespread problem, and have updated it. There are lots of us out here, non computer experts trying to do what should be a simple transfer.

    I have not tested bluetooth again, I feared it would screw up something.
  15. jrtwynam

    jrtwynam Member

    I've had that same issue, but the SDrescan app fixes it every time for me. But, I don't think the problem is limited to the SD cards. I've saved playlists of mp3s that I've created on my phone, and as far as I know those don't get saved to the SD card, yet they seem to randomly disappear. Now what I do is create a playlist on my computer, save it as an m3u file, and copy it to the SD card. It does still disappear now and then, but SDrescan finds it again.

    If anyone comes up with a solution to this, I'm sure we'd all appreciate hearing it. And I mean a solution that stops Android from losing the files in the first place, not a solution that helps us find them once Android loses them.

    I've had my Android phone for maybe 3 months now, and so far, this is my only complaint.
  16. sohguanh

    sohguanh Well-Known Member

    Do you know what is MTP ? Also when you say dropdown menu are you referring to the Notification aka Status Bar at the top of your Android screen and then you drag down a menu appear with options to choose ? I am referring to that actually in my earlier post.
  17. chanchan05

    chanchan05 The Doctor Guide

    My phone, Samsung Galaxy SL, has the controls for disconnecting and connecting to PC properly. It shows a splash screen when connected to PC and has a message at the bottom that says "Press home to stop MTP", or "Home". Then for USB connection there's a button that says "Turn Off USB". Your phones dont have that?
  18. UnplugMe

    UnplugMe Well-Known Member

    No, my phone (Sony Ericsson Xperia mini pro SK17a) does not have that.

    The computer's status bar will provide the safe removal tool in MSC mode, but in MTP it does not. I think they expect you to use Windows Media player to transfer files, and that has a built-in removal tool. But they don't provide one for that mode if transferring another way. I sent a letter to Sony asking them to add it, along with better more complete instructions that are available regardless of data connection.
  19. UnplugMe

    UnplugMe Well-Known Member

    Yes I meant Notification aka Status Bar. Sorry I confused you by using the wrong term.

    MTP is Media Transfer Protocol, there is a wikipedia page (linked), that's where I learned the difference between MTP and MSC.

Share This Page