Pictures deleted themselves...


Last Updated:

  1. nomnompie

    nomnompie Well-Known Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    176
    Likes Received:
    18
    Well, today I was using my phone, and I hooked it up to a PC to copy a file off the SD card. I turned off USB storage, unplugged it, and went to set a new wallpaper when I realized... some of them were missing... I checked other folders and sure enough, magically missing pictures..

    Now I have seen this happen where it won't see all my audio files, but eventually it kind of just fixes itself and sees them all, but I browsed the SD card, and I cannot even see the missing pictures.. I assume my SD card is corrupting and I should format it. Is this the kind of symptom you'd see when that happens? Or is the SD card physically bad?
     

    Advertisement
  2. lekky

    lekky Lover VIP Member

    Joined:
    Oct 29, 2009
    Messages:
    5,252
    Likes Received:
    1,266
    Restart your phone and see if they are still missing. Were only a few that you transferred missing, or all of them?
     
  3. nomnompie

    nomnompie Well-Known Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    176
    Likes Received:
    18
    I rebooted a few times, I went in and out of albums a couple times, when I first noticed pics missing and the numbers were changing each time, then they went down a good deal... Weird thing is, I wasn't even transferring pictures, I was transferring some drivers for a PC I was working on at work, that were in a folder on the SD card root, since I didn't have my flash drive with me.

    I was able to recover some of them using a free program called Recuva, but some were lost because they were "overwritten" by pics that already existed... somehow? :confused:
     
  4. lekky

    lekky Lover VIP Member

    Joined:
    Oct 29, 2009
    Messages:
    5,252
    Likes Received:
    1,266
    it does sound like a dodgy sdcard to me, i cant see why the phone would be doing this. Might be best to take a backup on your pc, then format the card.
     
  5. nomnompie

    nomnompie Well-Known Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    176
    Likes Received:
    18
    Doing that now. Moving 3gb of music back to the card, and the phone unmounted the card by itself twice, once 1/4 the way through, and once halfway through...

    Is it possible that the phone is turning off USB storage after being "Idle" for too long...? Or does this sound even sketchier?

    I've been periodically pressing the lock button and it hasn't happened since, but my transfer rate is gradually getting slower, but I'm on windows 7 and the same thing happened when I was trying to copy 4gb of music off of a DVD to my desktop.. so I think it might be a windows 7 bug. Not sure though.

    (EDIT) Well this is making me unhappy... I just formatted the card twice, copied some music and pics back on to my card and my phone can't see any of it, even rebooted the phone... I can however see it under USB.

    ........and now all of a sudden I unlocked my phone and it sees all of it... wth?
     
  6. lekky

    lekky Lover VIP Member

    Joined:
    Oct 29, 2009
    Messages:
    5,252
    Likes Received:
    1,266
    it wouldnt turn it off for being idle. Really sounds like a dodgy sdcard, have you got another one to try in your phone to make sure?
     
  7. mslisaj

    mslisaj Well-Known Member

    Joined:
    Feb 11, 2010
    Messages:
    367
    Likes Received:
    6
    I've lost a couple of photos like this too. I have done the reboot with taking the battery out and I got a couple of the pics back but did loose one. I figured I must have deleted it by mistake but reading this it makes me wonder. Just thought I would throw my 2 cents worth in. I have a 16gig Sandisk MicroSDHC card for information........
    The rest of the phone works perfectly but this is a weird part of the photo app I think. When I make separate folders for my pictures and move them there they don't show up in the picture album list until I shut the phone off and restart it. I keep my fingers crossed that 2.1 will correct these little anomalies and we can only hope........
     
  8. brykins

    brykins Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    647
    Likes Received:
    77
    One thing I found was that my USB kept getting unmounted and found that it was the USB port I was connecting to on the PC. I have two ports on front that seem to be connected to the motherboard and a further four that are connected via PCI. If I use the PCI ones then the phone won't stay mounted when transfering files, but if I use the front ones then it works perfectly.

    Might we worth trying a different port if you are still getting unmounting problems.
     
  9. nomnompie

    nomnompie Well-Known Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    176
    Likes Received:
    18
    Hm good to know guys. I didn't think to try another port. I do have another card but it has been ok since formatting. Come to think of it I never formatted the card when I took it out of my old phone so maybe it had some filesystem errors on it.

    I'll see if it happens again. If so I'm definitely getting a new one.

    I wonder too if it is a glitch that may be fixed in 2.1.

    Thanks. :)
     
  10. x1y2z2

    x1y2z2 New Member

    Joined:
    May 24, 2010
    Messages:
    3
    Likes Received:
    0
    I as well have this problem. I am using android 2.1 with milestone. (both phone and sd card is brand new) Pictures deleted themselves after a day. So what i am going to do? Format the sd card in windows?

    TIA
     
  11. chrismurren

    chrismurren New Member

    Joined:
    Jun 29, 2010
    Messages:
    1
    Likes Received:
    0
    I have a HTC Desire on 2.1 using a Sandisk 16GB MicroSDHC class 6 card. I have had this problem twice now using two separate memory cards, firstly the one that came with the phone and secondly the one above.

    It seemed to happen when mounting the sd card to my pc running XP to access files which were there during the copy process but the jpeg images have now disapeared leaving only a few jpegs on the card. It appeard to delete them regardless of what folder or directory they are in on the card. I would love to know why this is happening.

    To avoid losing photos taken on the phone i have begun uploading them to picasa using a free app from the market as a backup following the first catastrophe. Recovery programs also seem to struggle getting the jpegs back.
     
  12. James_Bond

    James_Bond Well-Known Member

    Joined:
    Dec 23, 2012
    Messages:
    150
    Likes Received:
    41
    I have seen this issue before. Sometimes it can be fixed sometimes it cannot be fixed. Lekky is right though, sometimes losing pictures can be the result of a
     

Share This Page

Loading...