Play Store not connecting to WifiSupport


  1. krudra

    krudra Active Member

    Hi everyone..

    I just got my first android phone HTC One X.. The model no is S720e. I have been using Nokia phones all the way till now so this is my android phone and i am very new to all the settings.

    The problem is that when i connect my phone to my Wi-fi at home, i can open internet, youtube and the google play store.

    But when i try downloading something from the play store, it just shows be the downloading bar but does not download. Now if i do the same with my mobile internet, the app downloads perfectly well. I thought this was a problem with my wi fi so i started a download at the same time on my HTC One X and my Nokia C7 from their respective stores.. My C7 download got done whereas the one on the HTC just kept showing the Downloading green bar with no percentage.. I even left a download for 2 hrs but to no success.

    Can someone please help.

    Thanks

    Advertisement
  2. gibbs1984

    gibbs1984 Well-Known Member

  3. krudra

    krudra Active Member

    Will do that.. The thing is i am able to download on my mobile internet but not through wifi even though the play store opens on wifi!!
  4. krudra

    krudra Active Member

    When i click on clear data for Google play store it says all app files will be permanently deleted from the phone.. Wont that remove Google Play from my phone??
  5. gibbs1984

    gibbs1984 Well-Known Member

    Clearing data should only delete your setting from the Play Store app, shouldn't effect any other app.

    It probably won't do anything if you're able to download from the Play Store through your data connection but it's worth starting with doing this.
  6. krudra

    krudra Active Member

    Just in case before i do this.. is there a way to download the play store if it gets deleted??
  7. gibbs1984

    gibbs1984 Well-Known Member

    Yes mate, it's easy.

    It won't do anything bad.
  8. Inn0vative1

    Inn0vative1 Member

    HTC One X has some known wifi issues where the device is unable to obtain or keep a wifi connection. You could be experiencing this issue. There's a hardware fix for it. Just search Google for "HTC One X wifi problem"...
    Should give some useful results.
  9. coos lick

    coos lick Well-Known Member


    Don't think it is this or there would be more than just an issue with the play store. This is almost certainly software.
  10. gibbs1984

    gibbs1984 Well-Known Member

    I don't know much about WiFi but you can reset your connection or change the frequency/channel or something can't you, maybe worth a go? (Could be talking rubbish here though :D)

    Did you clear your cache and data?

    Did you manage to download apps from the browser version of the Play Store?
  11. coos lick

    coos lick Well-Known Member

    You could try downloading another copy of the APK (programme) and installing it.
  12. krudra

    krudra Active Member

    Sorry for replying so late.. I have been very busy.. :(

    Well, i did clear the cache and data. After that when i open the play store i was able to download an app.. After it downloaded, the 2nd app again did not download on the wifi.. I had to again clear data and cache after which it downloaded.. When i tried the 3rd app, it did not download at all even after the clearing..

    All other apps including the tune in radio works perfectly with the wifi though i sometimes suddenly experience drops in the signals. To eliminate problems with my Wifi, i used my Nokia C7 which works perfectly with the Wifi..

    All this while apps download perfectly using the mobile internet.
  13. krudra

    krudra Active Member


    How do i do this?? My opening the playstore in the Phone's Internet Browser??
  14. krudra

    krudra Active Member


    I will try this also.. Could you kindly tell me how to do this??
  15. coos lick

    coos lick Well-Known Member

    Android Police has a copy of the latest store on their website -

    http://www.androidpolice.com/2012/07/28/download-latest-google-play-store-v3-7-15/

    You need to download it to your phone, and it should ask if you want to install it.
    You may get a warning about changing a system app, but you can choose to proceed.
    You may need to choose to allow installation of non-market apps before hand under settings/ security. You can take the tick off again once the play store has installed.
  16. gibbs1984

    gibbs1984 Well-Known Member

    Can do that or go to the Play Store on your computer and downloading directly from your web browser.

    Also, trying what coos lick says could help as there's been a couple of updates to the Play Store recently and one of them was a behind the scenes update so could fix your problem.
  17. krudra

    krudra Active Member

    Will try both out and update.. Thanks a lot guys!!
  18. krudra

    krudra Active Member

    Update: Issue got solved automatically without my doing anything!!!
  19. ankurgarg_11

    ankurgarg_11 New Member

    Hi everyone..

    I am using my first android phone Galaxy S II from past 10 months. Model no. is GT I9100.

    Now one problem come up from yesterday that when i connect my phone to my Wi-fi at home, i can open internet, youtube and the google play store.

    But when i try downloading something from the play store, it just shows be the downloading bar but does not download. Now if i do the same with my mobile internet, the app downloads perfectly well. However I am able to download anything on my laptop and my other Nokia mobile. Some of the persons suggested to clear data and cache of Google Play Store that I have done. Even I have also selected uninstall updates of Play store but the problem persists.

    Can someone please help.

    Thanks
  20. krudra

    krudra Active Member

    My issue (which was pretty much the same issue which you are having) got resolved on its own..

    This thread is in the HTC One X section.. I suggest you ask this in the Samsung Galaxy section and see if ppl with the same phone are having similar problems..
  21. Jase64

    Jase64 New Member

    i had samr problem with wifi ,went in the the router settings and ticked the cookies tab , solved all the issues ,hope this helps
    error 403 was what i was getting when trying to update or download apps,
    the cookies section was under the security section of my router settings,i have a linksys x2000 modem router,the iphone app store was the same could not connect to the app store thru wifi but 3g was all good,same with samsung g s3
  22. aj7414

    aj7414 New Member

    i had the same prob. but i also have a airave and the way sprint says to hook it up is before your router. so cable modem-airave-router which was using the airave as the router and the router as the gateway. so i just went cable modem-router-airave then all was good...
  23. northguy

    northguy New Member

    I tried all of the above and then some. after nothing worked, I suspected it was my older modem/router (supplied by my provider) - 2wire unit. I turned the unit into a modem only, and then added a new wireless router that can handle the new phones (and can open the ports google needs). Once I did the above, no issues using play store, google talk, etc on wireless network.

    Hope the easy stuff works for you but if not, likely need to investigate changing your router.
  24. cesee

    cesee New Member

    I have come upon this problem a few times now.

    The first time was with a Mac OS then Bada and then Android. The solution was changing the MTU Size (Maximum Transmission Unit) in the routers network settings or in the network settings on the device if it is accessible. I tried something like 1400 an it fixed my problem. It is a problem with old routers I guess.

    This problem can also happen only with the login process, so after I logged in using mobile data I could switch back to Wi Fi and continue working, but with android it didn't work at all.

    Hope that helps.
    yuvalshafriri likes this.
  25. yuvalshafriri

    yuvalshafriri New Member

    Only MTU change from 1492 to 1500 (maximum) solve it for me..
    thanks to the MTU TIP Man:)
Loading...

Share This Page