Play Store not working on 4G


  1. Corpse11

    Corpse11 Well-Known Member

    I haven't seen a thread about this yet, but is anyone else experiencing this right now? It seems Sprints 4G WiMax isn't "authenticated" anymore to use the Play Store. So when you download apps, you need to be on 3G or WiFi...making downloads super slow (for me atleast)

    I've seen some other websites saying its Google's problem, and some people saying its Sprints problem. So of course each company is blaming each other. So anyone find a fix for this yet?

    Advertisement
  2. marctronixx

    marctronixx Moderator Moderator

    Moved to Sprint forum since it sounds like its not specific to any handset.

    I just tried on the evo 4g lte on cellular (3G) and was able to go right up to finalizing a purchase. I went to the book store side.
  3. Bnice

    Bnice Guest

    Yes , you are not alone. I notice when I have updates it does not work on 4g but when i'm on wifi it updates just find.
  4. KitsapAndroid

    KitsapAndroid Well-Known Member

    This seems to be tied to the recent market update. I don't have reliable enough 4G service around me to be able to try it out. I can say that 3G works just fine, as does Wi-Fi, although the other day I did have some issues using Wi-Fi to update, but I was also trying to update about 15 apps, and it worked fine the next day. :dunno:
  5. Android_Ascend

    Android_Ascend Well-Known Member

    Yea I have the same issue with two different phones My EVO 3D and My EVO 4G both rooted, they were both up until a few days ago. And its really beggining to annoy me...
    marctronixx likes this.
  6. KOLIO

    KOLIO SERIAL AGNOANDROIDIST Guide

    No problems w/the PLAY STORE app on 4G WIMAX w/my PHOTON.

    My PLAY STORE APP is version 3.7.13.
  7. Android_Ascend

    Android_Ascend Well-Known Member


    Hey what's up KOLIO, I haven't heard from you since I dropped my Ascend haha
    I'm running that PLAY STORE APP version as well. A fellow 3VO mate told me to try another ROM and see if that works I might as well give it a try I think something is up with the ICS roms because its happened on two ICS ROMS...
  8. ymmie

    ymmie Well-Known Member

    Now not only does it wait for network constantly on 4G, but my list of installed apps is blank. Anyone else see this?
    marctronixx likes this.
  9. ymmie

    ymmie Well-Known Member

    I cleared cache and data for the play store app and my installed apps list is back, but 4G still is waiting for network.
    marctronixx likes this.
  10. ymmie

    ymmie Well-Known Member

    I found this on Google's tech support site

    Android Apps Known Issues
    Welcome to the Android Apps on Google Play Known Issues page - by clicking on an issue, you can see details. Use the Report this issue button to let us know if you're experiencing the problem.

    If you're experiencing an issue that is not listed here, please feel free to contact us.

    New Issues
    [#6789539] "Waiting on network" error over 4G
    We're aware that some users (in particular Sprint users) are receiving a "Waiting on network" error when downloading from Google Play over the 4G network.

    This issue is a problem with the configuration of your carrier network, but we're currently working with carriers to get it resolved, so thanks in advance for your patience.

    In the meantime, as a temporary workaround, please:

    Use 3G instead of 4G to download from Google Play or
    Use WiFi instead of a network connection
    Issue first reported on: July 9, 2012

    Last updated on: July 11,2012
    BenChase7, kct1975, falconey and 2 others like this.
  11. Rammsteinnener

    Rammsteinnener New Member

  12. JAJameson2010

    JAJameson2010 Well-Known Member

    When I download it it's not showing as a APK, the phone is saying it cannot open the file :(
  13. KitsapAndroid

    KitsapAndroid Well-Known Member

    The 4G and Play Store began working fine for me after the ICS update on my E4GT.
    BenChase7 likes this.
  14. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Did you make sure unknown sources was check marked on your phone.



  15. JAJameson2010

    JAJameson2010 Well-Known Member

    I'm pretty sure they are, but let me go check...
  16. JAJameson2010

    JAJameson2010 Well-Known Member

    yup it's checked. Just a bit bizarre! Guess I'll have to wait for the play store to update itself.
  17. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Go to the Play store and try to download an app called Easy installer, and then download that APK to your download folder and see if the easy installer instals it for you


  18. JAJameson2010

    JAJameson2010 Well-Known Member

    So I downloaded that app and it still didn't work. Just for giggles I used astro file manager to rename the file and add .apk at the end.... And it worked! LOL I never would have thought....
  19. Corpse11

    Corpse11 Well-Known Member

    yup, problem has been fixed with newest update the play store just got
  20. kct1975

    kct1975 Well-Known Member

    Ok...so I am having the same problems as everyone else.

    Since I am not all that tech savy with transfering programs from my computer to my phone, does anyone know if Google will be sending out an OTA update to fix the problem.
  21. Corpse11

    Corpse11 Well-Known Member

    That new Play Store that is listed above ^^^ came to my phone OTA. Open the Play Store and leave it open, but return to your home screen (open the Store and press Home button instead of Back button)

    I have not had the "Waiting For Network" problem since it updated (sometime last night)

Share This Page