Play store wifi issues on my Nexus 5General


  1. temporary101

    temporary101 Well-Known Member

    I am having terrible wifi issues on my new Nexus 5. When browsing the web, the play store and mostly everything it works great and is very fast, BUT when downloading or updating an app the wifi speed is practically nonexistant.
    Sometimes showing that it will take 25 hours to download a 25mb app :S
    This while my Galaxy Nexus on the same wifi network is as speedy as ever.

    I have tried factory resetting my Nexus 5, I have cleared the cache and data of the play services app and of the play store app, I have tried changing the wifi bands (from auto, to 5 to 2.4 and back to auto), I have turned off the wifi optimization, but none of those things helped. I even tried some DNS HSPC wifi settings thingy I read here
    That didn;t help either.
    I have unplugged my router and replugged it in but that didn't help either.

    I literally had to leave my brand new Nexus 5 downloading all night just so that it could install the apps I wanted on it. So far for playing around with the phone on day 1 :(

    What makes it even weirder is that occasionaly the wifi issues resolve itself and I can get good download speeds for several seconds or sometimes up to a few minutes, but then right after it is straight back to crap speeds. Some other reported that only while making a portion of the map available offline in Google Maps their app download speeds were great, but that didn't work for me either.

    I don't know what to do and if it is a hardware issue or a software issue. Please help me.
    Below some info that might be useful to helping me solve this.

    White Nexus 5 32GB
    Bought from US play store
    Shipped to and using it in the Netherlands
    Currently does not have a SIM card inside (that is still in my Galaxy Nexus till the wifi issues are resolved)
    Unrooted, only installed the mandatory update during the setup
    All apps downloaded are apps that are also on my Galaxy Nexus which works without a hitch

    :(

    Any and all suggestions/ideas/help are welcome

    Advertisement
  2. toiday

    toiday Well-Known Member

    Try Settings -> Wi-Fi -> Advance. Unchecked Wi-Fi Optimization.
  3. temporary101

    temporary101 Well-Known Member

    Tried that before. Didn't help :(
  4. Hook

    Hook Ever since DU... ;-) VIP Member

    It certainly is not typical of Nexus 5 behavior or KitKat performance. If everything except downloading from play store works well, it mostly rules out a hardware problem. If the Galaxy Nexus downloads at normal speeds, it rules out problems with the play server from where you are. If you have the problem after a factory reset it rules out other software creating problems. The only thing left that even occurs to me is whether your router is firewalling downloads for that particular device in some odd way.

    I'm just throwing stuff at the wall. I have no clue.
  5. temporary101

    temporary101 Well-Known Member

    I was thinking it was an issue with KitKat that prevents it from working optimally with specific routers (of which I happen to own one).
    Not sure if that makes sense, but it would explain why my GNexus (not on KK) runs fine, why the problem persists after a factory reset and why it is limited to just playstore downloads.

    But I might need to do some testing to see how other things download.
  6. zipred

    zipred Well-Known Member

    After carefully reading about the issue you're experiencing, I'm in agreement with your thoughts.

    My Nexus 5 is performing as it should, yet my brothers is acting _exactly_ like yours. Five of my fellow software engineers at work own Nexus 5's as well and all are fine which seems to indicate this as a very isolated situation.

    Despite the variables, I tend to feel it may be sensitive to certain Wi-Fi routers, just like I've experienced with certain laptops over the years. Yet without clear cut justification I cannot be absolutely certain. Tomorrow I'm planning to bring a few routers I have to my brothers, hopefully that will shed some light on this.

    Should I have success, I'll report back immediately in an effort to be of help to you.
  7. rparra14

    rparra14 Active Member

    I had a similar issue but it was because I had a static IP assigned on my GNEX wifi settings (which is stored by google) and when I got my Nexus 5 going it pulled my wifi settings from google and assigned the same static IP. So my gnex and nexus 5 had the same IP on the network, that is bad.

    -Ryan
  8. temporary101

    temporary101 Well-Known Member

    I am experiencing my issues on both my routers wifi and my model's wifi (2 separate networks)

    My Gnex and Nex5 use separate IP's so that is also not the issue. Currently setting up the nexus 5 with my sim inside (was lucky my standard sim could pop-out and turn into a micro sim, because I forgot about that)
    Might come back if I have any new findings in this new setup
Loading...

Share This Page