Playing 720p h.264 videos on EVO - does this work at all?


Last Updated:

  1. sarcasmic

    sarcasmic Active Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    40
    Likes Received:
    5
    I have tried to play several H.264 720p video samples on my EVO, and I get sound but no video. Two examples are the Simpsons trailer and the Fantastic Four trailer at

    H.264 Demo Clips | H264info.com

    I get no error, and I have tried the Android media player and several others (which are no doubt using the same API's underneath).

    Is it expected that video will not play for these files?
    Obviously the phone's screen would not be able to play them in full detail but I didn't expect that it could not play them at all. What is the point of having 720p resolution over HDMI when the phone can't play videos at that resolution? Or is it that it supports some particular type of H.264 and these videos aren't supported? Or is it actually trying to output directly through HDMI and I see nothing since I don't have it hooked up?

    UPDATE: I transcoded these sample trailers using Handbrake, and even when I end up with a LARGER file size they do play at 720p. But if I use the high quality preset, they do not work even at a low bitrate at 720p. So it's something about the "advanced options" that determines whether the EVO can play it or not.
     

    Advertisement
  2. NeoteriX

    NeoteriX Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    905
    Likes Received:
    734
  3. sarcasmic

    sarcasmic Active Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    40
    Likes Received:
    5
    That helps, but the biggest question I have is can the EVO play 720p video on its own screen (scaled to its lower native res of course)? Are the samples I am trying to play failing to play video on the EVO screen because it wants to only send them to HDMI, or is it because it doesn't support their video streams?

    I guess I'll try re-encoding one with Handbrake, keeping the 720p res and lowering the bitrate. VLC shows the bitrate moving up an down in the range of 4000kbps to 8000kbps, so it's possible that the average bitrate is > 6000kbps so maybe that's why they won't play.
     
  4. RickJ

    RickJ Well-Known Member

    Joined:
    Nov 19, 2009
    Messages:
    258
    Likes Received:
    64
  5. hamzax7x

    hamzax7x Member

    Joined:
    Mar 20, 2010
    Messages:
    20
    Likes Received:
    1
    Dude, i was watching a native 720p episode of LOST on here, 5000 kbps bitrate, frame rate was the same as source and it ran smooth like BUTTER, just convert to .mp4 using Cucusoft Video Converter or Handbrake at 1280x720, it looks amazing on the evos screen
     
    gatorchomp83 likes this.
  6. NeoteriX

    NeoteriX Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    905
    Likes Received:
    734
    Sorry, I should have been more clear -- if it can play over the HDMI out, it can definitely play on screen. My 720p movies play on screen just fine.

    A bitrate issue will usually result in dropped frames and slowness -- if the file doesn't play at all, it is most likely a profile issue. H.264 can be encoded in different profiles, baseline, normal, high. As far as I know, the Evo is only compatible with baseline so you must transcode to that in order to playback H.264 on the Evo.

    If I have time today, I'll try uploading some of my videos that I've confirmed to work on the Evo so that people can test their setup.
     
  7. skpd

    skpd Well-Known Member

    Joined:
    Apr 12, 2010
    Messages:
    321
    Likes Received:
    84
    as long as it is and .mp4 and the file is smalller then 2G, 720p should play just fine on EVO's screen and on through the HDMI out.
    The bitrate and frame rate should not play a big role, I believe, as long as you don't go crazy like 40Mps or something
     
  8. Connectz

    Connectz Well-Known Member

    Joined:
    Jul 21, 2010
    Messages:
    353
    Likes Received:
    33
    I'm getting ready to try this....
     
  9. Connectz

    Connectz Well-Known Member

    Joined:
    Jul 21, 2010
    Messages:
    353
    Likes Received:
    33
    With Rockplayer, FLV playback is hit and miss... MP4 converted from 720p mkv with handbrake plays but the video is stuttery and the sound goes in and out... This is using a Through The Wormhole trailer. mpg plays back perfectly as does avi.

    mkv plays but it is unwatchable as it stutters too much and the sound goes in and out...
     
  10. FrostyD

    FrostyD Active Member

    Joined:
    Jul 29, 2010
    Messages:
    31
    Likes Received:
    2
    I would think that playing something at the evo's native resolution would look far better (or atleast no worse) than full 720p. You're just adding pixels to the video that you can't display. I have a copy of Kick-ass on my evo at 800x336 and it easily looks better than the same film at 1280x536. It's great that the evo can play 720p, but if your creating video specifically to watch on it, your just making the file bigger than it needs to be.
     
    Connectz likes this.
  11. sarcasmic

    sarcasmic Active Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    40
    Likes Received:
    5
    It's nice to have 1 set of decent bitrate 720p files on the EVO which can then be played on the device screen or via hdmi out to a large television and still look good either way.
     

Share This Page

Loading...