Please Help! Accidentally formatted SD Card


Last Updated:

  1. ogdoc

    ogdoc Member

    Hi!

    I wanted to factory reset my phone so formatted everything, including the SD card. I am a noob at this and new to the post, so please go easy on me if i posted it in the wrong area. I'm also not that good with technology as you can tell from my problem. I have not backed up ANYTHING because I did not expect this to happen.
    I have a Evo 4g and now every time I run it it goes straight to the boot menu and displays

    Supersonic evt3 ship s-off
    HBOOT-2.10.0001
    MICROP
    TOUCH PANEL-ATMEL224_16ab
    RADIO-2.15.00.11.19
    Oct 15 2010

    FASTBOOT (<--Highlighted Red)

    <VOL UP>
    <VOL DOWN>
    <POWER>

    BOOTLOADER
    REBOOT
    REBOOT BOOTLOADER
    POWER DOWN

    I can still use the buttons. i have tried different roms by putting them on the sd card and going into recovery mode to install it, but unless i am flashing it wrong, it does not work. Also, i am running clockworkmod. Right now, all i have on my sd card is the rom, and my phone is completely cleared. Please help. If you need more information, i will try giving it to you.

    Advertisement
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    welcome to the forums!!!!!!!

    moved you to the rooting section.

    as long as you have recovery you are all good.

    what rom do you have on your card?

    go into recovery and wipe dalvik cache (found under advanced in clockwork mod) then wipe cache partition and data(factory) then flash the rom you have on the card.

    once you get the phone up and running i would read this guide: http://androidforums.com/evo-4g-all...ooting-dummies-guide-gingerbread-edition.html. just skip the rooting part and go to the after root section. it has a ton of info that you should know about.

    i would also suggest that you switch recoveries to amon ra 2.3. it is much better then clockwork mod which never wipes well. there is a section on how to do this in the guide.
    AARONONE and Rxpert83 like this.
  3. argedion

    argedion The TechnoFrog Moderator

    Get Amon Ra and next time you get the notion to do something how about come in here and ask! It will probably help you to not do something you don't want to do
    AARONONE likes this.
  4. andygu3

    andygu3 Well-Known Member

    The heck with Amon Ra, use Smelkus;) There's no reason to use an outdated recovery with little to no options
    MizzouBrent likes this.
  5. ogdoc

    ogdoc Member

    When I try wiping dalvik cache, i l click on it and a error appears "E:Can't mount /dev/block/mmcblk0p2 (File exists)." It still lets me click yes and says it wiped the dalvik cache. I tried installing the rom, which i got from themikmik.com and it goes straight to the recovery page after saying that it is opening the file.
  6. andygu3

    andygu3 Well-Known Member

    If you're still on clockworkmod, you need to change your recovery to Smelkus mod recovery. Believe me, you're life will be much simpler. As an added bonus, any nandroids you may have saved,you will be able to restore with Smelkus, just fyi;)
    AARONONE likes this.
  7. ogdoc

    ogdoc Member


    I tried downloading and using Smelkus and Amon RA but it shows

    Sd Checking...
    Loading... [PC36DIAG.zip]
    No Image!
    Loading... [PC36DIAG.nbh]
    No image or wrong image!
    Loading... [PC36IMG.zip] (<--I am guessing this is the Amon RA/Smelkus file that i tried using)
    parsing ...[PC36img.zip]"

    and nothing happens. i am stuck only using clockworkmod recovery.
  8. andygu3

    andygu3 Well-Known Member

    Ok, first you may have renamed it incorrectly. It must be renamed to PC36IMG.zip When you downloaded it did you do this?

    Here's the ics themed Smelkus v4.3 http//d-h.st/Hlg

    Download and rename to PC36IMG.zip Then make sure it's on the root of your sdcard(not in any folders) Then pull battery, put it back in, press power and the volume down button at the same time. The zip file will be read by the phone and then it will ask if you want to update, press the volume up button for yes. Then it will ask out you want to reboot, press volume down for no. Using the volume down, highlight recovery and press the power button. It will boot to your new recovery.
    AARONONE and MizzouBrent like this.
  9. andygu3

    andygu3 Well-Known Member

    AARONONE, MizzouBrent and ogdoc like this.
  10. ogdoc

    ogdoc Member

    Thanks for the link but i am still having trouble. The option for updating has never appeared. it goes through the sd checking part and back to the HBOOT page. I named the file correctly. Also, i tried redoing clockworkmod recovery the same way (by naming it PC36IMG.zip) and now i have a file on my sd card called clockworkmod. After i got the clockworkmod file, i don't get an error when wiping dalvik cache, but i still cannot install the rom. do you have a link for a rom that i can try if you think there is a problem with the rom i am using?

    Also, when i go to install the rom, it shows

    Finding update package...
    Opening update package...
    (and one more thing that is too fast to read)

    and goes back to clockworkmod recovery v2.6.0.1 without showing what it did
  11. MizzouBrent

    MizzouBrent Well-Known Member

    Is it different installing from the bootloader on the newer versions? Andy's method works.
  12. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Can he install it via adb?
  13. ogdoc

    ogdoc Member

    How do i do that? All i can see is the boot loader. From the bootloader i can fastboot, recovery, clear storage, and hboot usb. and i am in hoot.
    I have a mac, if that is important.
  14. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Click on this link..
    http://androidforums.com/evo-4g-all...-rooting-gingerbread-2-3-5-dummies-guide.html
    Click on the "show" button under HTCdev method and then click on "show" button under how to get recovery.
    There are some files you need to download to your computer that you will see above but I'm not sure if you need all those files.
    The android flasher method might be easiest.
    You need not do the HTCdev method, skip that. You just need recovery.
    Just read thru it, but I would like someone else to confirm my thoughts on installing recovery either thru adb, or android flasher method.:)
    AARONONE and ogdoc like this.
  15. ogdoc

    ogdoc Member

    Any chance you have a mac version of andriodflasher?
  16. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    mac? what's that? an apple product?:p
    Just kidding, no I don't. I know nothing about a mac. Sorry.:(
    There is a link somewhere about rooting with a mac, I know you are already rooted, but perhaps that link has something about flashing a recovery with a mac...I'll try to find it bro.

    Edit: this is the best I can do...tells how to set up adb on a mac...a little outdated but read thru it.
    http://forum.xda-developers.com/showthread.php?p=9842005
    AARONONE, ocnbrze and ogdoc like this.
  17. argedion

    argedion The TechnoFrog Moderator


    I still call it amon ra even though its smelkus but that's what I meant Yall should have known that. :p
    andygu3 likes this.
  18. ogdoc

    ogdoc Member

    Thanks so much. i will try that out and ill try out the windows version on my friends computer, but right now, when i tried installing PC36IMG.zip after toggling on signature verification and script asserts i got

    --Installing:SDCARD:pC36IMG.zip
    Finding update package...
    Opening update package...
    Verifying update package...
    E:signature verification failed
    Installation aborted.

    When i toggle off signature verification:
    Finding update package...
    Opening update package...
    (Something else that is too quick to read)

    back to the recovery page with no history of what just happened. any ideas?
  19. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Wait a sec, are you trying to flash the PC36IMG.zip thru recovery?
    That cannot be done.
    AARONONE and ocnbrze like this.
  20. ogdoc

    ogdoc Member

    I was just trying things out. Sorry. I am now using adb and fastboot on mac but every time i flash recovery.img i get a

    FAILED (remote: not allowed)

    in terminal.i could not even erase the old recovery because i get the same error.
  21. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Sorry, I cannot help you with mac related issues.
    I would try to get a recovery based off of windows if you can access a computer with windows. I think very few people here use a mac, not sure but that's what I gather.
    So, bottom line here is you are trying to change your recovery correct?
    And it's not working (the PC36IMG.zip file), thru your hboot, right?
    That's why I suggested installing with adb, or android flasher but I only know windows....sorry.
  22. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    i think mikey is on to something with your latest attempt. make sure that this is done thru the bootloader.

    what size card are you using?

    and the bad block error you had while trying to wipe dalvik cache is not a good sign. hopefully this is due to that fact that you have clockwork mod. lets try and get you a new recovery and see if that goes away.
    AARONONE and Mikestony like this.
  23. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    at what point to you get this message?
  24. ogdoc

    ogdoc Member

    Air-2:~ *****$ fastboot devices
    HT********* fastboot
    Air-2:~ *****$ fastboot flash recovery /Users/*****/Desktop/recovery.imgsending 'recovery' (3544 KB)...
    OKAY [ 1.129s]
    writing 'recovery'...
    FAILED (remote: not allowed)
    finished. total time: 1.130s
    Air-2:~ ******$ fastboot erase recovery
    erasing 'recovery'...
    FAILED (remote: not allowed)
    finished. total time: 0.000s
  25. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok make sure that you are in fastboot on your phone. go to the bootloader and select fastboot then enter the commands again.
    AARONONE likes this.

Share This Page