Please help me find stock firmware for 5800D on TelusSupport


  1. kortsen

    kortsen Member

    <tl;dr> Please help me find original firmware for my Samsung Galaxy Apollo GT-I5800D on Telus Mobility. I want to flash it back to stock. </tl;dr>

    Ever since the latest update to Smooth Calendar (coincidence?) my Apollo and my wife's GT-I5510M started popping up this error message.

    [​IMG]

    I tried everything I could think of and went as far as flashing the 551 back to stock. This solved the error on her phone. Finding firmware for the 551 was easy. I guess the 'Callisto' was a popular model. But I have spent days looking for stock firmware for my 5800D. It looks like I need to find I5800DTLKDA but all my Googling has led to broken links, deleted files, and sites that want me to register or install their download manager. I have also found lots of European firmwares and custom ROMs but I have been warned not to use European firmware on North American models.

    Any help would be appreciated.

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    Try Firmwares | SamMobile

    If it doesn't show there (I hit the page twice, so that may have messed it up for me), try SamMobile Firmwares put in i5800 and look down the list of firmware numbers on the right. The link is on the left. It's listed as unknown country/carrier, but it's the 5800DTLKDA firmware.

    You have to join (free, unless you want a faster download).
  3. kortsen

    kortsen Member

    Thanks for the tip but the download link is another dead end. The file has been deleted ?!?!
  4. kortsen

    kortsen Member

  5. kortsen

    kortsen Member

Share This Page