1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Please Help!!!!!! "Mobile Network State: Disconnected"


  1. TheMetalMaiden

    TheMetalMaiden New Member

    I just got a new Huawei Ascend Y for Straight Talk yesterday and already I'm having problems with it. I Noticed that none of my apps were working (Temple Run 2 and Netflix) and that I wasn't connecting to the internet unless there was WiFi nearby. this is really frustrating because I can't do anything except text and call when I'm away from a WiFi network and the whole reason for me getting the phone was for the apps. I also noticed that the little 3G symbol at the top of my screen was not showing and my sister told me that that was why my apps and internet weren't working. I looked at the settings on my phone and when I went into the 'About Phone' section and 'Status' section, I saw that my Mobile Network State was disconnected. I don't know what to do to get it reconnected and get my apps to work again. PLEASE HELP!!!!

    Advertisement
  2. olbriar

    olbriar Moderator Moderator

    Hello TheMetalMaiden. Welcome to Android Forums. I believe that this early in the game, I suggest you contact your carrier and make certain they have your phone ready for net service. You might also make certain that the phone is set in airplane mode which will stop your 3g abilities. As long as you are in an area where you are within the carrier footprint, you should have net access. Best of luck to you. Thanks for joining the community.
  3. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Hello Metal Maiden. Are you sure your device is activated with your carrier? Sometimes that important step will be skipped, and the excited buyer will take the device out of the box, put the battery and sd card and sim card in and power it up and start using it. Most often there is an activation menu regimen that interrupts use and walks the user through the activation procedure one step at a time, but not always.

    Those steps include setting up a Google/Gmail account, and sometimes a call to a special number is needed to allow for automatic activation.

    But if it is activated, my next suspicion would be proximity to a strong signal/tower. If a wifi network is the only way you can access the internet, and if the device is activated (perhaps done at the store, if that is where you purchased it), then either a setting in the network menu is not checked correctly or when you took the phone out of the store and went home or to work or where ever you left a viable carrier signal area.

    I'd start by carefully checking all settings in the menus to be sure your device is ready for carrier internet connection. Here is a pdf download for the Ascend Y:

    Huawei Ascend Y Manual / User Guide
  4. dallaspepper

    dallaspepper New Member

    I have had this issue before. Several times. Try this. 1. Click on SETTINGS. 2. Click on WIRELESS & NETWORK SETTINGS. 3. DISABLE Airplane Mode. 4. Turn OFF WI-FI. 5. Turn OFF Bluetooth. 6. Scroll to bottom & click on MOBILE NETWORKS. 7. CHECK Data Enabled. 8. NO CHECK by Data Roaming. 9. CHECK Enable Always-On Mobile Data. Internet should be back on. If not, you will have 2 call your carrier & get them to turn it back on. If you have StraightTalk, the number you need to call is (888) 251-8164. If you use StraightTalk. & you download a lot, they will turn your internet off until you pay your next bill. I know its "UNLIMITED WEB" but StraightTalk has a limit apparently. Crazy. I know. Hope thishelps. Have a great day! :)
    Liferules likes this.
  5. beardyian

    beardyian New Member


    New to mobile phones but having just bought the same phone - i was surprised when i found this had happened early on today.

    Thankfully i followed you instructions and its back on :)

    Many Thanks
  6. HammerWGM

    HammerWGM New Member

    Same problem. No data connection unless I am using my home wi-fi. It just bounces in and out of connection(goes from blue data connected bars to grey)
  7. skurk

    skurk New Member

    Hi to all, well this problem has bother me for some days aswell,
    purchised myself a huawei y220 Mobile phone and i could only make and receive calls and sms's, so the way i fixed internet on the phone so apps and net could work was to:

    before i continue, im from south africa and my carrier is CELLC
    So manually fill in your carriers wap settings, just replace your carriers wap settings with where i highlighted in red.


    1. On the device, press the Menu key.
    2. Select Settings > Wireless controls > Mobile networks > Access Point Names.
    3.Press the Menu key and select New APN.
    4. Select Name, enter CELLC and press OK.
    5. Select APN, enter internet and press OK.
    6. Select Proxy, enter 196.31.116.250 and press OK.
    7. Select Port, enter 8080 and press OK.
    8. Enter the user name and password listed below. If no value is listed, leave the field blank.
    User name:
    Password:
    9. Select APN type, select default and press OK.
    10. Press the Menu key and select Save.
    11. Press the radio button next to CellC to set the profile as default.


    thats it, you will see the 3g icon appear next to your signal bar at the top, internet should now work on your device.

    in closing you need to do this for each new different carrier sim you insert into your phone, and set it up accordingly. so the settings will get saved.

    if you go back to settings/about phone/status you should now see that your "Mobile Network State" shows connected,

    hope this helps someone who come accross this problem in future..
  8. Liferules

    Liferules Member

    Much thanks! This worked for me today. Great advice!

Share This Page