Please Help - No Sound - Galaxy s2General


Last Updated:

  1. bilko007

    bilko007 New Member

    My phone was fine until this morning, now ive noticed there's no sound at all, except when I use my head phones. I've checked all the settings and there all on, volume is turned up, but still no sound when phone is rung or when i receive a text or when I listen to music or play a game, nothing unless I plug my head phones in, then the sound is normal. What have I missed or is going wrong, please help.........:confused:

    Regards

    David....

    Advertisement
  2. steslatt

    steslatt Well-Known Member

    This happened on an old phone of mine and it was something to do with the jack port where you plug your headphones in. It was acting like the headphones were still in and no sound was coming from the speaker. All I did was plug and unplug the headphones a few times and it worked again.
  3. bilko007

    bilko007 New Member

    Thanks Steslatt, I tried that, but i still have no sound at all, I can't even hear the other person when I receive a call......please someone help me lol, this can't just be a one off can it?
  4. Gearu

    Gearu Well-Known Member

    So you've definately checked the 4-pack of volume settings in the Sound part of settings?
  5. bilko007

    bilko007 New Member

    Yes Gearu, one of the first things i checked....Ive done everything i can think of, still no luck, but thankyou for your suggestion...
  6. Gearu

    Gearu Well-Known Member

    Only thing you could try is opening the phone and checking the connection, from memory there are copper connectors that are simply copper spots that are pressed together due to the phone being screwed together, could be dirty/have dust.
    You need a credit card to prise between the shadow chrome and black plastic after you get your fingernail in, slow and easy does it.

    This is the most comprehensive teardown guide I've found:
    Samsung Galaxy S 2 Teardown - iFixit
  7. Mischaonline

    Mischaonline New Member

    Had the exact same problem.

    Do you run some customisation app like SPB shell 3D or something like that. I lost my sound and just powered my phone off/on and started it in the normal mode and then it worked fine. (luckily)
  8. nich0las

    nich0las New Member

    My Samsung Galaxy S2 also having this problem. I think we should ask Samsung Company to collect those Samsung Galaxy S2 from all the world. Im from Malaysia, i bought this phone about 1 week only.

    I think samsung no pro technician/engineer/manager. Is they hire all certificated student? lolx. Got bug why still sell to market? omg......

    We should return the phone back to Samsung company asap. No S2. it worst!

    Note : If you dont want to send it for Warranty. i have 1 solution. Plug in your 3.5mm Earphone into the phone halfway until you hear little "shorted", take the jack out and try until u have the sound. Samsung jack hole problem. so messy.
  9. atifjamshaid

    atifjamshaid New Member

    My phone was fine until this morning, now ive noticed there's no sound at all, except when I use my head phones. I've checked all the settings and there all on, volume is turned up, but still no sound when phone is rung or when i receive a text or when I listen to music or play a game, nothing unless I plug my head phones in, then the sound is normal. What have I missed or is going wrong, please help.........:confused:

    Regards

    Atif
  10. ShawnB

    ShawnB New Member

    I found that I lost my media sound through the speakers and the headphones. All volumes were turned up and no sound. Text sounds and ringers were working okay.
    My issue was to do with the clock...yes, the clock.
    Click on clock icon.
    Slide over to Desk Clock and click on it.
    Click on the "expansion" icon in the upper corner.
    You will see a sound icon there or possibly a vibrate icon. if it is on vibrate, that is your problem. Touch it and it will turn sound back on.
    Hope this fixes your trouble.
  11. danny6114

    danny6114 New Member

    If you have a bluetooth connect device it may be getting the audio signal instead of your speaker, I did this once after freaking out about no sound then it dawned on me to check it out and voila, problem solved.
  12. TigerRussell

    TigerRussell Guest

    I had a problem with media starting and stopping, and no sound from youtube, although I had sound from ringtones, so I knew the physical speaker worked. After some research, I did a factory reset. No luck. I uninstalled all apps. No luck. So I did a 5 minute battery pull. No luck. Finally, I did an overnight battery pull = remove battery for 8 hours. Woke up, and assembled the battery to phone. My homescreen had 2 old icons that were right on right before I deleted the apps the night before. Maybe there is a buffer stack overflow in the droid deletion routine? (question for the devs). And so to continue, I started up my tunein radio and the sound and program work perfectly! Long story short, just try taking the battery out for 8 hours to fix your phone! ;-)

Share This Page