PLEASE HELP! Phone Crashed, won't rebootSupport


  1. Droid_Rage

    Droid_Rage Active Member

    So just recently, my phone has started to freeze up while I'm looking at Facebook, or Flipbook, etc. At first it wasn't a big deal, it would freeze for a few seconds, then go back to normal. Then it started to freeze and then reboot itself. Finally, it began to freeze until I had to pull the battery. Just now, it froze, I pulled the battery, and when I hit the power button, it vibrates for a split second, flashes "Samsung", then goes to the Samsung Galaxy SIII screen, where it stays. I let it set for 5 minutes and it didn't/hasn't/won't move past this screen. :mad: WHAT'S GOING ON? I'm fully stock, never rooted. I need to get this fixed ASAP.

    Thanks in advance. I'm kind of freaking out here.

    Advertisement
  2. Phantogenic

    Phantogenic Well-Known Member

    Can you get into download mode? Vol Down + Home + Power? If so you can always have a look and find your firmware on Sam Mobile Firmware Page and flash it via odin. There are plenty of tutorials instructing you on the use of odin.

    I've used it to flash to JB and then back to my stock NZ rom.
  3. Droid_Rage

    Droid_Rage Active Member

    I got into download mode once, then I hit the up volume rocker, and it said it was going to try to install something, but I don't know what, as I hadn't downloaded anything and I wasn't connected to my computer via USB cable. I tried to reboot again, and now it's a complete brick. It won't power up at all. When I connect to my computer, I try to power it up, and the computer makes the noise like it detects something, but when I go into the devices and printers, it shows: QHSUSB_DLOAD but it says it doesn't recognize it.

    What is going on? Why would it do this? I haven't downloaded anything or tried to do anything other than keep this phone stock. PLEASE HELP!!!
  4. Droid_Rage

    Droid_Rage Active Member

    Not sure if this will help/matter, but I can get the red charging light to come on, but only when I completely remove the battery and plug the charger into the phone. It goes out shortly thereafter, but it's just weird. I'm so pissed right now... can't even explain how pissed.
  5. sleeco

    sleeco Well-Known Member

    Try pressing the power button for about 20 seconds, if that fails to rest it then go into recovery mode and do a factory reset.
  6. Droid_Rage

    Droid_Rage Active Member

    I held the power button down for 10, 20, 30, up to 90 seconds. It won't do anything. I've held down the power, home, and volume rocker buttons down for equal amounts of time, with the same results (Nothing happens). When I plug it in to the charger, no lights come on, the battery image doesn't come on, etc. The ONLY response I can get is when I plug it into my computer and press the power button, the computer makes the "a-ha" noise like it recognizes something, but that's as far as it goes. I go into devices, and the phone isn't recognized.

    Going to a Sprint store today when they open, hopefully they can figure out what's wrong and/or give me a replacement. I can't understand how the phone would just go off and do this when I haven't done anything to it to cause it (never tried to flash roms or root or anything. 100% stock).
  7. ken_kurien

    ken_kurien New Member

    Guys, I bought a SIII in July 2012 and my 16GB MicroSD died on me in October 2012... And on 30th Nov 2012, my phone died!! :mad: It was working fine till 3PM, then nothing............ It won't turn on! Tried everything. The battery is working fine.

    I should have listened to my friends... :(

    I have given the phone for warranty repairs, lets hope they figure out the problem and it never happens again!

Share This Page