1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Please help, Prevail stuck in airplane mode permanently.


  1. bbacc020

    bbacc020 Member

    My Samsung prevail is permanently stick in airplane mode.

    I've tried EE14, EJ06, and others flashing with odin. I've tried EFS Clear. I've tried flashing custom roms. Nothing works, the phone is literally stuck in airplane mode from the time it turns on permanently. Trying to turn it off just doesnt work. It just jumps right back into airplane mode instantly.

    Also, my phone crashes when I try to get into DIAG mode or view my "Status" from about phone in settings. Various other things that involve the wireless connectivity (other than wifi/bluetooth) will crash that app. Even system apps.

    Advertisement
    :
  2. johnny424

    johnny424 Well-Known Member

    are you currently running stock? are you rooted? if so are you using Cwm? and have a backup available ..from before airplane mode issue?
    have you done anyother mods? deleted any system apps by accident?
  3. bbacc020

    bbacc020 Member

    I've tried stock AND rooted of the following odin flashes: ED13, EE14, and EJ06. All are fuxx0red.

    I was messing with stl5 (CDMA Information) in /dev

    Last time my phone's radio worked I had successfully done an esn repair, but one of the numbers was off. IE the MEID didn't match the ESN because I made a typo when I was reversing the MEID in hex.....




    *bs(i supposed im legally inclined to include that my esn was all 000s and i only used the esn under my battery)
  4. new optimus

    new optimus Well-Known Member

    ok some questions for you, and first I dont care why just how
    You were able to access meid info how?
    what programs did you use, I have tried cdmaworkshop and QPST and there is not or very limited access.

    Also on a related though surprising note my phone just did that as well.:mad:

    it was connected to the computer just charging and all of a sudden It started flashing the battery full, funny thing though it was in a powered off state and that was not where I left it.
    when I turned it back on it said no service and baseband unknown
    I used odin to go back to stock, all versions an its just no baseband:mad:
    an add on I tried going to dm mode but after dialing the ##7678# in gingerbread and the ##8778# in froyo the msl screen comes up but after entering msl hit ok nothing happens for a few mins then it pops up a box says modem error modem exception occurs
  5. bbacc020

    bbacc020 Member

    (must have superuser or run from CWM recovery)
    to read--
    command prompt:
    adb shell
    dd if=/dev/stl5 of=/dev/cdma.rfs

    to write--
    adb shell
    dd if=/dev/cdma.rfs of=/dev/stl5


    Edit CDMA.rfs with hex editor. MEID/ESNs are reversed as always. Don't forget the ESN checksum too.
  6. new optimus

    new optimus Well-Known Member

    hmm thank you not the most elegant way to go about it but its better then what I found before. lol:p

    ok I just went into recovery to look at this and I after the first line, I copied and pasted to eliminate typo's

    D:\Android stuff\adb>adb shell
    ~ # dd if=/dev/stl5 of=/dev/cdma.rfs
    dd if=/dev/stl5 of=/dev/cdma.rfs
    dd: can't open '/dev/stl5': No such file or directory
    ~ #
  7. bbacc020

    bbacc020 Member

    sorry, from CWM its /dev/block/stl5

    and to set permissions on that file if you have any issues:

    adb.exe shell chmod 600 /dev/block/stl5
    adb.exe shell chown root:root /dev/block/stl5

    if you're handy with a hex editor you can do an esn repair just by changing stl5 (the nvdata, I assume, for the prevail) just hope you don't mess up like I did.

    EDIT: also, 000ing out the locations and trying to nvrequestitem write doesnt work. You have to find the reversed meid/esn, and input your meid/esn (reversed).
  8. new optimus

    new optimus Well-Known Member

    ok, I feel a bit slow today, probably because my phone did this out of the blue, but when you read it and it is in the cdma.rfs where exactly is that located?
  9. bbacc020

    bbacc020 Member

    I'm sorry dude if you can figure out where you copied the .rfs file to based on my shell commands you are not going to be able to mess with it..... best of luck to you though bro, but my prevail is still dead.

    HALP111!!!!

    Sent from my Motorola Droid 2 ApeX2.0RC3 using Tapatalk
  10. new optimus

    new optimus Well-Known Member

    Oh dont worry I will figure it out, I am fairly good at that mostly its just an exercise in this because I already have another phone on the way, have been planning on switching phones and ordered it couple days ago.
  11. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    this EXACT same thing JUST happened to my gf's phone... if you come across any solution please let me know. (i know for a FACT it is not related to anything she did, she didn't have the know-how to do anything):confused:
  12. new optimus

    new optimus Well-Known Member

    What about sound, does the phone play music or any sounds for that matter?
    does it reboot unexpectedly?
    if you go to menu/settings about phone and try to go into status does it freeze and then give a android F/C?

    What I think happened is it somehow corrupted the /dev/stl5 partition.

    I have attempted to check on that and it tells me I do not have that partition.
    I tried recreating it but it seems the partition table is corrupt
    I decided to call samsung they are paying for me to ship it to them they will reflash/replace so we will see how that goes.
    Lordvincent 90 and wyelkins like this.
  13. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    :confused::(:mad::confused:
    sounds, yes, at least notifications (have an unread voicemail, chimes when turned on)
    Random reboots, yes sir
    Fc's, absolutely :(
    Odin help? Not in the least
    Did you tell Samsung anything in particular about problem? (and i know, modding is like fight club, we don't talk about fight club, lol)
    It would be different if it was some how actually MY fault... But like you, it was on charger, and then BAM powered off, reboot, no service, airplane mode, random reboots, FC's, lag, ANGER DESPERATION DENIAL RESEARCH ACCEPTANCE/BEG FOR HELP
    Considered bricking with ROM manager out of anger, 'medicated', and still searching for a solution.
  14. wyelkins

    wyelkins Well-Known Member

    Since I had a bad experience with my first Prevail after taking it off charger, I try not to charge the battery in the phone. I have two batteries and an external charger.

    This is probably just voodoo superstition but it takes one less variable out of the list of possible nightmare scenarios that can happen to my baby. It costs a few bucks, but well worth it to me for the lack of power/heat related problems
    new optimus likes this.
  15. mac42

    mac42 Well-Known Member

    Voodoo? I'll give that a shot, hexes, voodoo, magic, programming? Lol I'll try anything :)

    Edit: this is lordVincent, didn't realize my rm logged on. Lol
  16. new optimus

    new optimus Well-Known Member

    lol ya, funny stuff voodoo
    actually the sound my have been my fault for all the crap I tried to do.

    I actually told the rep quite a lot, honestly there was no modding of my phone for weeks lol
    I told him it was connected to the computer just charging and then I noticed the battery full icon popped up, though the funny thing is I had the phone on and that icon is the phone off one. I powered the phone on and it just sat searching for service I went to menu/settings/about phone tried to go to status had F/C's and then noticed the baseband was unknown as well as hardware.
    Then I told him I tried calling boost and they had me open the dialer and enter ##and numbers and it just said modem error then I went to recovery and did a factory reset he said looks like you covered all the tests I would have you do we will email you a return label you send it to us we will reflash/replace it and send it back
    Lordvincent 90 likes this.
  17. bbacc020

    bbacc020 Member

    It seems like alot of people are having this problem..........
  18. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Update: now, addition to being stuck on airplane mode, it will now only boot into recovery and dl mode. If I try to power on normally, battery charging icon pops (NOT.plugged. in) for a second and goes away. It does it randomly every 3-5 min until I pull the battery. (I left it hoping it would miraculously come back to life, lol)
  19. new optimus

    new optimus Well-Known Member

    hold power for 15 seconds or so, mine also was doing that.
  20. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Thanks! That worked :) at least she use it as a wifi device ('tablet') until i can call Samsung on Monday :)
  21. new optimus

    new optimus Well-Known Member

    fairly sure they are there today:D
  22. Bloodawn

    Bloodawn Well-Known Member

    This hasn't happened to me but i typed "android stuck in airplane mode" in google and apparently other phones have had this problem too

    Couldn't find anything on what causes it or how to fix it tho
  23. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    That's what website said, but when i called this morning it said they were closed, tried again just now, got a person. Good2Go

    thanks
  24. new optimus

    new optimus Well-Known Member

    your welcome
  25. bbacc020

    bbacc020 Member

    I am officially starting the Samsung Prevail Airplane Club, theres just too many of us....
    Lordvincent 90 likes this.
Loading...

Share This Page