Please Help! Wifi connection after 2.2 updateSupport


Last Updated:

  1. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    Hey all,

    I can't for the life of me figure out why my wifi will not stay connected after the Froyo update 2.2. A few things (to get them out of the way): yes, I'm fully updated (all apps are 2.2 compatible), running FRG22D, Wifi is on, I've tried turning Airplane Mode off then on which doesnt' seem to improve anything either, and all router settings are pretty basic and thoroughly checked. Oh - on my other phone (HTC Incredible), the wifi will stay on consistently - both using the same network & settings, sitting next to each other 3 feet away from router.

    Attached are screenshots from Wifi Analyzer showing how frequently / consistently I drop my network connection. I particularly like the shots that look like combs! It should be a straight bar going across the screen... Sometimes when running apps, it's not noticeable. However, when running something like TV.com, YouTube, or even web browsing, I lose connection completely. Ugh...

    Any suggestions? I think I'm gonna hard reset the phone - any reason not to? I really hate resetting up my phone the way I like it. It's just tedious...

    Also, I'd like to mention that I didn't have this problem before the 2.2 update, which is the only thing that has changed when the problem began. So isn't this the problem??? Why do I have to figure out the resolution to Droid's problem?? (You don't need to really answer that last question! LOL)

    Thanks for your help...
     

    Attached Files:


    Advertisement
  2. Shadowtech

    Shadowtech Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    434
    Likes Received:
    36
    Do you have the wifi sleep policy disabled under advanced settings in Settings>Wifi? Maybe that is bugged or something and disabling wifi when it shouldn't be. I've always had mine set to never as I manually disable it anyway.
     
  3. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    I can't believe I failed to mention what phone I have, this is for a Moto Droid (first one). I can't find the Wifi Sleep Policy anywhere. Can you tell me more specifically where I can find it?

    Thx
     
  4. Shadowtech

    Shadowtech Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    434
    Likes Received:
    36
    Settings > Wireless + Networks > Wi-Fi Settings > Menu Key > Advanced
     
  5. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    Thanks Shadowtech - of all the settings I went through, I didn't know that was there. It was on SLEEP AFTER 15 MINUTES, so I changed it to NEVER, but alas - it made no difference in the connection.

    I'm just gonna reset the phone and see what problems that creates (hopefully - NONE!)

    Thanks again!
     
  6. skiahh

    skiahh Well-Known Member

    Joined:
    Mar 29, 2010
    Messages:
    125
    Likes Received:
    7
    I think the comb shape is due to the SSID being hidden. When I broadcast my SSID, my wifi analyzer changes from the spikes to a smooth signal. I've been having connection problems, too, and have come to think that the spiked pattern doesn't contribute to my issue. Yours may be different.
     
  7. allanlaw

    allanlaw Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    437
    Likes Received:
    31
    The sawtooth pattern seems to be a problem with the way the new version of wifi analyzer handles blocked SSID's. My connection seemed solid even though wifi analyzer was sawtoothing like crazy with SSID blocked, straight line when I reset to SSID broadcast.

    FOLLOWUP: On a SSID-blocked WPA(1)-PSK TKIP "g" network feeding a DSL connection, I see an amazing spiked pattern on wifi analyzer, and the Droid telling me I have a weak signal. HOWEVER, Speedtest.net shows a speed of 2.6mbps down, 801kbps up, which is hardly indicative of a bad connection. So, whatever is going on (all since the 2.2 update) is really really weird.
     
  8. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    I'll give it a try to see if it makes any difference, but in my neighborhood, I don't like to broadcast my SSID all over the place. Not willingly anyway.
     
  9. PirateToad

    PirateToad New Member

    Joined:
    Sep 14, 2010
    Messages:
    1
    Likes Received:
    0
    I too have this problem. If this is an old thread, and I've necro'd, I'm sorry :( I've looked around about this all over the web, and while this post does not solve my issue it DOES describe it perfectly.

    My Wifi will stay on, unless I try to use it. If I check my email, youtube, web, anything that would use the connection, it drops and reverts to 3G. After a couple seconds, wifi comes back on, and then it goes back off and back to 3G.

    This results in me unable to view any online content while using wifi. Router settings are fine (worked fine before 2.2), every other device I have can connect to it. It is broadcasting SSID, no encryption, no password, nothing.

    The phones wifi is set to NEVER sleep, airplane mode is off, etc. Nothing I've tried works, and I'm kind of desperate :/

    Phone: Motorola Droid (First one, "Milestone", I believe)
     
  10. allanlaw

    allanlaw Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    437
    Likes Received:
    31
    PirateToad, try turning off Network Notification in the Droid network setup. Manually connect your network, and then see if it sticks.
     
  11. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    Allanlaw - I'm not sure about this. Maybe though. On my HTC incredible, the connection is nothing like this - just a straight line (at about -65 dB), with a few drop outs. No big deal, and it has a really strong, consistent connection. No problems on the HTC Incredible. On the Moto Droid - sawtooth pattern as before. Resetting the phone did very little, if anything. I get the same results on Speedtest for HTC Incredible. I haven't thought of doing that on the Moto Droid, will try that tonight to compare.

    PirateToad - you stated my exact problem much better than I did. Thank you. I still have the same problem, although I am not broadcasting my SSID, and I do have a password. Any success with turning off the Network Notification???

    Thx
     
  12. allanlaw

    allanlaw Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    437
    Likes Received:
    31
    Another data point - using the network that I described above. I changed the router from using a fixed channel (6) to auto-select. With SSID off, and the router deciding to go to channel 1, the DROID would not connect, no matter how many times I tried to manually connect. Changed back to a fixed channel, and all was well. So, give that a try if you are on auto-select.
     
  13. Eusibius2

    Eusibius2 Well-Known Member This Topic's Starter

    Joined:
    May 24, 2010
    Messages:
    158
    Likes Received:
    13
    That's a good point, allan. I always used to be on a 'auto-select' and it would put me at channel 6. Looking at wifinder, I've noticed that ch6 is pretty crowded, and upper numbers were not. So I switched to a fixed ch11, and still seems to be the same, although just consistent now.

    Thx
     
  14. Jim Shaw

    Jim Shaw New Member

    Joined:
    Oct 19, 2010
    Messages:
    1
    Likes Received:
    0
    I had the same problem described on my Droix X running 2.2. Our router was configured to auto sellect the channel. I tried selecting channel 1, but the problem continued. Switching to Channel 6 seems to have solved the problem.
     
  15. skiahh

    skiahh Well-Known Member

    Joined:
    Mar 29, 2010
    Messages:
    125
    Likes Received:
    7
    Well, after 4 replacement D1s, I still couldn't get it to work and asked Verizon for a different phone. I tried my neighbor's D2 and DX and both connected right up and held the connection.

    I told the Verizon rep I just wanted a phone that did wifi; be it a D1 or something else. Finally got on the phone with a tech who understood what wifi is and is supposed to do and he finally agreed that none of the solutions would work on a system that I did not control (that is, the router side) so he agreed to a different device. Since I found I didn't use the physical keyboard, I opted for the DX and it's been great since I got it.

    Note: their basic CS reps have a new tactic on this issue; they say that they do not support secure wifi!!! They try to convince you that wifi is not a Verizon issue and therefore they do not have to warranty the device if wifi does not work. Despite my explaination that wifi is an international standard and that their product material specifically states that the device does wifi, the CS rep either didn't get it or was trained/instructed to take this approach. Getting to the tech support folks gets rid of this nonsense and you can get some troubleshooting and resolution accomplished.
     
  16. allanlaw

    allanlaw Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    437
    Likes Received:
    31
    :rolleyes: That's because secured wifi sites are SO unusual . . . (LMAO). I wonder if the clever folks at Google managed to program out the ability to operate on Channel 1 of the wifi G-band when they did 2.2 (based on the above comments and my own experience).
     

Share This Page

Loading...