please help with samsung galaxy s , auto rotation problem, someone must know how to fix this?!Support


Last Updated: 2012-10-25 12:13:10
  1. rye-bond-94

    rye-bond-94 Member

    Samsung Galaxy S problem
    Can anyone help me fix auto rotation on samsung galaxy s

    I recently updated to 2.2 and a couple weeks later my phone just crashed and now it is always on landscape, if I put auto rotate off it goes to normal screen but it wont auto rotate to landscape if I'm watching youtube.

    can anyone help p.s i have already factory reset.


    also i took it in tmobile and a women fixed it for me saying it was something to do with the call settings, but when someone called me a day after it didnt work again.

    someone must know.

    Advertisement
  2. akshayrajsingh

    akshayrajsingh Active Member

    I too m facing the same wierd situation...post 2.2..auto rotate's gone all haywire!!!...cmon guys...we gotta know something that can be done here to fix it..
  3. THE ANDROID

    THE ANDROID Well-Known Member

    Update to 2.2.1?
  4. rye-bond-94

    rye-bond-94 Member

    yes updated still broke :((
  5. PinkMirrorKirby

    PinkMirrorKirby Well-Known Member

    Go to Settings > Display > Horizontal Calibration, in there just calibrate your device.
  6. rye-bond-94

    rye-bond-94 Member

    nope still dont work :(
  7. PONR

    PONR Member

    Hmm i had this problem the other day when i too upgraded. I solved it by restoring the phone(factory reset). I removed external sd card and then calibrate, this sorted my rotation problem.
  8. ItsMido

    ItsMido New Member

    dude it's not a problem at all, go to settings, display, horizontal calibration, place the phone on a flat level surface and hit the calibrate button and it work like a charm :)
    Crack Fairy, vner06 and Chhunleng like this.
  9. lilmama69

    lilmama69 New Member

    :mad:In a space of 1 week , Ive had to return 3 Blackberry's due to system failures, so I went for the GS and was overjoyed , until the auto rotate refused to work ...Ive had it 3 days, ive factor set it 3 times, , pulled the battery, wiped the sd card, ....and done the calibration till im sick.....at the present thehome screen is stuck in portrait as is the application pages , but when i go into each individual app it will turn (at the min ) to landscape :eek: But sometimes the other way around... Anyone know how to fix this ? HELP !!!
    Tonedawg likes this.
  10. NZtechfreak

    NZtechfreak Well-Known Member

    Happened once to me, went into settings and noted that autorotation was turned off there, that seemed to dissociate it from the pulldown menu in the notification bar. Made sure that both were set to the same setting and no problems since (on 2.2.1).
    Sunshine1667 and LynneExley like this.
  11. Tonedawg

    Tonedawg New Member

    Try using the factory data reset star code go to the dialer like your gonna make a call and punch in *2767*3855# that should work if not let me know
  12. JiMMaR

    JiMMaR Well-Known Member

    first , test if the accelerometer is working or not
    go to the dialer and type *#0*# then go to sensor and check if the magnetic sensor and the accelerometer works or not [the magnetic should move when you move the phone and go to image test and turn the phone around , if the image didn't move then the problem is the accelerometer]

    if that's the case , then check those 2 threads
    [Q] Autorotate/Accelerometer not working - xda-developers

    [q] sgs automatic screen rotation is not working - xda-developers

    I had the same problem and solved it using those threads , just make sure you read everything in the 2nd thread [if the adb calibrating didn't work , then you probably need to root your device]
  13. akshayrajsingh

    akshayrajsingh Active Member

    I had a luk at the above 2 mentioned threads. great stuff!!..but one qstn..all of those solutins are pretty much for rooted devices. is there any solution for non-rooted ones??

    P.S. I did the test with *#0*# ...accelerometer didnt work :(
  14. Challenger01

    Challenger01 New Member

    Ok I'm a bit nervous this is my first time on here but I would like to help you guys coz we just had the same problem.

    The circumvention was to use an alternative browser by downloading Dolphin hope this helps.
  15. Challenger01

    Challenger01 New Member

    I would like to add that all other auto rotate functions were working apart from the internet...
  16. stranger123

    stranger123 New Member

    hello every1 my name is ali n i got my galaxy from dubai n yet same problem i just now went through all your comments and finally tried everything but atlast the only thing that really was helpfull was the calibration the display setting> horizontal calibration try leveling the mobile the way u dial the phone not straigh on a table like ive been trying n then caliber it n let the ball be up or where ever for me my auto rotation works splended now....thanks to every1s helpfull comments....:p
  17. rajeevan1326

    rajeevan1326 New Member

    Thanks dude! it has worked for me. Thanks again:p:p
  18. Jiten

    Jiten New Member

    Hi all,
    It's not a defect of the mobile at all. As already quoted by "ItsMido", you just need to go to Settings-->Display-->Horizontal Calibration
    Now place your mobile on a flat surface and click Calibrate.
    Your problem is solved!
  19. illused

    illused Member

    My problem is not fixed by re calibrating. Only the browser is quirked, it is always in landscape mode. There must be some answer other than get a new browser as memory us limited. Can I uninstall/re the standard browser?
  20. ffulcrum

    ffulcrum New Member

    Of course you can do a factory-reset, but the problem might be a lot easier to solve.
    Assuming auto-rotation works for other applications, but (only) not in the browser then do this:

    - Open the browser
    - Press the settings button
    - Click MORE
    - You get a list with more settings, maybe you have to scroll down
    - Select Settings
    - De-select the landscape view only option

    It is that simple ! :p
  21. jdmeth

    jdmeth New Member

    By horizontal they mean flat like a dinner plate. I calibrated mine on edge like a carpenter's level , wrong. Just lay it flat with the screen facing up and run the calibration utility.
  22. zeinia

    zeinia Member

    how long does it take to calibrate samsung galaxy s2 ? my auto rotate doesn't work either :(
  23. zeinia

    zeinia Member

    its been more then half an hour i started calibration.
  24. David Molina

    David Molina New Member

    Go to the Web icon on your phone. Not the google icon. Once this opens, hit the menu button on bottom left of your Samsung phone, scroll to ,,,more,,,settings,,, and remove check from landscape option, FIXED...
  25. zeinia

    zeinia Member

    umm it was unchecked already

Share This Page