Please insert sd card before using cameraSupport


Last Updated:

  1. ImCharming

    ImCharming Active Member

    Hello. I've run into a problem, a frustrating one at that. So about a few weeks ago I tried to take a picture, it said "Please insert an SD card before using the camera" Well I had one in there, I tried restarting the phone, that fixed it temporarily. Then it happened again, I figured I would just copy the data from the card and reformat it, I plug it into my computer in a micro sd to usb thing. It detected it maybe one out of five times, I would try to copy everything over to my computer, it would begin the transfer and a few seconds in it would stop working and the card was no longer recognized. I'm pissed. I find another sd card, start using that, well today the same thing happened, and the same thing with my computer, detects for only a few seconds until I try a data transfer. Any idea of what the problem may be?

    Could it possibly have to do with me pulling my battery out all the time? I don't think it would, but I listen to music and podcasts through my work day, I listen to the radio for the first 4 hours and my battery dies in that time so I have a spare at work, would replacing the battery every day cause this? Only a few times I've let it completely go dead, I usually turn off and replace at around 5%

    Any ideas would be greatly appreciated. Thank you!

    Advertisement
  2. melissapugs

    melissapugs Well-Known Member

    Sounds to me like your card is on its way to that great big sd card farm in the sky. I'd go ahead and get another. Hope you get it sorted out :)
  3. Bramsy

    Bramsy Well-Known Member

    Try
    Settings> sd & phone storage> unmount
    After it unmounts, re - mount it

    It's something some of us rooters have to do..
  4. KaraBuller

    KaraBuller New Member

    I had the same exact frustrating problem. I dismounted the sd card and restarted my phone. Problem solved. For now. I will reply back if this doesn't prove to be a lasting solution.

    By the way, I got ripped off by one of those independently operated Verizon stores. I had this problem so thought, let's get new SD card. Sold me a 4 gb card for $55! Problem came back! Bottomline: always google extensively for help before buying a "new" item meant to fix a problem.

    Thank you!!!
  5. Wolf123

    Wolf123 New Member

    Hi, I'm having exactly the same problem with an Android 2.2 device. The device is Qualcomm msm7227_ffa.

    1) Camera and some other applications say "Please insert an SD card.."
    2) I do unmount the card
    3) Unplug it
    3) Turn off the device
    4) Turn it back on
    5) Plug in the SD card
    6) Device mounts it back automatically to /mnt/sdcard2/ (seems /mnt/sdcard/ is reserved internally ?? ) and it reports the free space, shows the files inside, etc. (it recognizes it as it should)

    But the problem remains: the SD can not be used with the camera. Despite of that I do have files on my SD card that can be copied, pasted, deleted, etc. and I even install apps from there BUT I can not use it with the camera and some other devices.

    What should I do in this case? :confused:
  6. Eliteoomph

    Eliteoomph New Member

    Hey guys, I have a similar problem. Just got a replacement thunderbolt and now it is saying. "please insert SD card" when I try to take a picture. I have 2.5 GB of internal storage and I NEVER had an SD card in my old thunderbolt... What do I do?
  7. jiapei100

    jiapei100 Member

    I'm having the same issue as well.... I'm using Android 4.1 emulator, tested on Ubuntu 12.04. Does anybody have the solution please?


    Cheers
    Pei
    STtheGhost likes this.
  8. yhsreh08

    yhsreh08 New Member

    hey guys..same problem here... i got an htc incredible s few months ago..everything seems to be okay..until this morning..when i tried to take a pic, it says "please insert sd card".. i did not touch anything prior to the incident.. so i dont remember if i did something which causes this problem..so, i googled it and saw this thread.. then tried the settings>storage>unmount sd card..BUT the unmount sd card option is grayed out..i tried to reboot my phone..removed the card..plugged it back in..still the same...i also connected my phone into my pc BUT my pc is no longer detecting it..it only says "charge only".. so im really really worried..maybe i did something wrong but couldn't remember it..

    appeciate your help!!

    -she
  9. twall06

    twall06 Member

    i have had my thunderbolt since it came out and have had this problem since a month after getting it every time i take it to verizon the just restart the phone and it will work fine for a few hours but messes up again. but they do not seem to understand or care use to i loved their cutomer service now it has gone downhill and seems like thay no longer care if you phone work or not.
  10. mycrazydream

    mycrazydream New Member

    First, eject the mount through the GUI (if you are using one), and then disconnect the device from the physical USB connection. Now, make sure Applications->Development->USB Debugging is unchecked.

    Viola, the problem was fixed. I didn't even need to reboot. The original reason I was only messing around with all the Android files by hooking it up to my PC to free up space by removing all my old photos and putting them on my PC hard-drive. Bluetooth only works intermittently.

    This is with Android 2.3.4 ( Google bastards said they were going to upgrade my model but suddenly had a change of heart). Greed. Yes, I think that's what it was - their hearts turned to greed. :eviltongue:

    As a last resort, you COULD do a factory reset (make sure you're phone isn't rooted. Not sure what might happen. Mfr could have a bomb/burn out set to go off under just such a scenario. OK, so probably not; just reset and then install any extra programs you have purchased. Just make sure you have backed up all data to your computer. Still, what an enormous setback this would be. Android SDK has been an indispensable tool to have installed, regardless of whether you're trying to develop for Android or not.

    As far as the coolness fearlessness factor, I would say that NASA astronauts take the cake for willingly strapping oneself atop a rocket; a rocket filled with jet-fuel, and absolutely one of the biggest in existence. These brave humanitarians are one of the real men of genius. Or was it a real man with cajones grandes? /s

    Although I had poor grades in college I was able to get my art portfolio to the professor. Surreptitiously of course. His salary wasn't sh*t anyway.

    So while my prose is a bit rambling, the question posed is this. Do I need to get a new sim card for a brand new phone only months old, or do I need to suck it up and get a new phone?

    I'm gonna take it out now and put it in some dry-rice.
    ---
    DOT=>. SLASH=>/ got it?
    READ: imagine DOT gsfc DOT nasa.gov SLASH docs SLASH ask_astroSLASH answers/970509c.html

    ++ And yes I know that our Space Shuttle rockets are not running on Lithium, but Lithoim batteries are never "throw aways" or recycled. While some can be refurbished, most make it to the landfill where they make structures composed entirely of ping drum-playing
  11. Loekieloekie

    Loekieloekie New Member

    Its an old topic but since I first found this thread googeling this prob:

    This was my solution:

    Format the sd card using the option under storage settings.

    After that the message insert sd card was gone in the camera app and I can take and save fotos now.

    Hope this might help someone else, cheers.

Share This Page