Please someone help me!!!


  1. ThunderKat

    ThunderKat Member

    I got the Thunderbolt the day that it was released and played around with it for a month, then decided to root it, my buddy came over and helped me root it, only when he did that he really didn't explain things like he should have. So a few weeks after the root, I wanted to flash a new rom on it, so he again helped me, but without explaining everything. So then I read about the new Gingerbread Rom (BAMF 2.3) and decided that I played around with the phone enough that I would be fine to flash it myself... WRONG! I forgot to back everything up like an idiot and flashed away... When I got the Rom on there, it wasnt working right so I read some more forums and it said I needed a new radio, so I flashed the radio MR 2 (with GREAT success lol) and tried it again... So now it EVERYTHING else EXCEPT my service is working... Idk what to do. A few of my friends say that I'm screwed, then a few more says I just need to flash everything back over to Froyo, radio first. Question is... Do I take out my SIM card when I do all this?

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    sounds like you may have only flashed a single radio...

    in settings/about phone what is your baseband number?
    where did you get your radio download?
    how did you flash it?

    relax,its not broken permanently :)
    rexdog1888 likes this.
  3. Yeahha

    Yeahha Usually off topic VIP Member

    So you have the MR2 radio on there, be sure to check the MD5 sum of the zip file to verify it was not corrupted, if it matches then keep reading.

    The data you didn't back up is probably lost forever, unless you made a nandroid before flashing the rom, then you could restore the nandroid backup.

    The easiest solution would be to flash a new rom. You first boot into recovery, if you do it the manual way by going into hboot and choosing recovery make sure you remove the radio file (PG05IMG.zip) from the root of your SD card first.

    In recovery you will need to wipe cache, format data/factory reset, and then go to advanced and choose wipe dalvik cache, you can also choose to format system in the advanced menu but it is not necessary according to most people.

    Then you will want to flash the rom, choose install from SD card, choose rom from SD, then navigate to it and choose to flash it. Since you are on the MR2 radio it is fine to flash a GB rom. Then choose reboot once it is done flashing.

    After that you phone should be working, I would advise to confirm it is working then boot back into recovery and make a backup so if something like this happens again you can just restore the backup.
    rexdog1888 likes this.
  4. ThunderKat

    ThunderKat Member

    I got the radio from xda-developers and I put it on the root of my SD card and went into the recovery mode, and i think it flashed....
    my baseband number says unknown...
    and thank god because I obviously dont know wtf im doing
  5. Yeahha

    Yeahha Usually off topic VIP Member

    How did you get into recovery? If you flashed the radio in clockwork that wasn't right, if you went to hboot (got 3 androids skateboarding on the bottom of the screen) it should have been flashed right.
    rexdog1888 likes this.
  6. ThunderKat

    ThunderKat Member

    ok... the radios dont match.. off by one number 25.6 vs 26 (what its supposed to be)
    and should i take out my SIM card before i go flashing away again?
    and should I go ahead and flash a different radio on there since im going back to froyo?
  7. ThunderKat

    ThunderKat Member

    I flashed it by shutting my phone off and pushing the power+volume down button
  8. scotty85

    scotty85 Guides Guide

    no,you dont need to remove your symcard. you need to make sure youre using a radio download that includes LTE and cdma radios(just telling us you got it on xda doesnt help) well need a link to the exact post and directions on how to tell wich download you used.

    then you need to flash that radio download in hboot. follow directions "how to flash in hboot" here: http://androidforums.com/thunderbolt-all-things-root/353591-how-some-root-terminology.html

    if you indeed flashed in hboot allready,again,it sounds like you only flashed a download containing a single radio.

    get the radios working and youll be fine :)
    rexdog1888 likes this.
  9. ThunderKat

    ThunderKat Member

    THANK YOU GUYS SOOOOOO MUCH... I'm gonna attempt this and will brb to let you know how it goes... I will love you BOTH for ever if this works.. cause I f-ing LOVE my phone!!!!
  10. Yeahha

    Yeahha Usually off topic VIP Member

    You flashed the radio right. I am not sure what you meant by "ok... the radios dont match.. off by one number 25.6 vs 26 (what its supposed to be)" I would suggest checking the MD5 sum, google it if you dont know what it is and download the program to make sure the file is correct.

    I would suggest getting the radio from a link here and getting the MD5 sum before flashing again, flash in hboot.

    If you are still having problems after that flash then download a newer rom or even the latest OTA rom from the same post and flashing in clockwork mod recovery, again be sure to wipe before flashing a rom because if you don't it will cause problems for you.
    rexdog1888 likes this.
  11. WormDoes

    WormDoes Well-Known Member

    Moved to the All Things Root section. I hope your problem gets resolved. Let me know if there's anything I can do to help
    rexdog1888 likes this.
  12. scotty85

    scotty85 Guides Guide

    any progress? if not,provide:

    -link to the exact radio thread you used
    -description of how you tried to flash this radio and what exactly happend when you did it.
    -please verify that your white hboot screen says "s-off" up at the top line

    also a couple terms for you to understand that will help us help you:
    hboot-this is the first screen you see when you power on holding volume down. its white with colored writing

    recovery is "clockwork mod recovery" and is a black screen with orange letters.

    i believe that earlier you were refering to hboot as "recovery mode". in order to get the correct idea of what has happened we all need to be on the same page :)

    as for froyo,i would not neccessarily reccomend you flashing a different rom right now(you have bamf 2.3 on now,correct?),youre likely to just get even more confused. lets get radios working with what you have and then well go from there.
    rexdog1888 likes this.
  13. Yeahha

    Yeahha Usually off topic VIP Member

    If you still don't have it working tomorrow morning please post I should be on here reasonably early

    If a clean install of the radio doesn't work I think a clean rom install will
    rexdog1888 likes this.
  14. TxGoat

    TxGoat Guest

    My data stopped working earlier today, actually 10-ish PM on Friday. I called Verizon and they weren't any help, "Well I don't know if our towers are down in your area" so I've tried messing with an updated ROM and some updated radios (going to see if an updated Gingerbread ROM/Radio update will fix my phone's issue). Let us know if you got it up and running. I haven't seen any threads about data being down and I trust this site more than I trust Verizon's Tech Support.
  15. scotty85

    scotty85 Guides Guide

    happend to me as well a couple weeks ago. get the lte switch if you dont have it,and set it on cdma only. doing this i was able to get 1x :eek: better than nothing.

    mine started working again the next day,after they sent out a replacement phone. it kept working,so i ended up returning the replacement instead of my original. i never did figure out what the prollem was,tho i like to believe it was verizons fault ;) with a tower being maintenanced,or something. :confused:

    maybe yours will start working again in a day or so as well. and then you can blame verizon too :D
  16. TxGoat

    TxGoat Guest


    So while you're here, what baseband number should we look for? I'm showing 1.46.00.0704w_2 and 010.76.0703_2r I'm guessing I didn't download both radios needed. I use CDMA Auto for the most part since I don't get a good 4G connection at the house and just toggle 4G when I'm in a good area.


    Oh and I just toggle LTE and CDMA via the #*#* technique, but CDMA only wasn't even getting me 1X connectivity. I had to get an old phone to verify data and sure enough, I get 3G connectivity on it.
  17. scotty85

    scotty85 Guides Guide

    thaT IS the radio from the newest OTA,and should be fine for mr2,and all the GB roms.

    sounds exactly like my prollem. set it on cdma only and see if 1x doesnt pop up in a few minutes... it may not be instant. its better than nothing :eek:
  18. TxGoat

    TxGoat Guest



    I didn't even get 1X when in CDMA auto. Is this a problem you're experiencing now or back when you had problems with your data? So I don't have to download any other radio other than the one below?
  19. scotty85

    scotty85 Guides Guide

    That's the prollem I had back when I had no data. I got nothing in Cdma auto or Cdma auto/EvDo+ LTE. Only way I could get anything was to leave it on Cdma ONLY.

    No,I'm sure your radio is fine. When I had trouble I tried numerous working backups and a couple different radios and none of it had any affect. Only way to get anything was by leaving it set on Cdma only
  20. TxGoat

    TxGoat Guest



    What prompted you to try CDMA Only? I've kept CDMA Auto on for the majority of the time that I've had my 2nd Thunderbolt. Kind of sad that I can't get 4G at home consistent enough to actually have 4G on. My first phone would go from 4G to 3G, then drop down to 1X and then no data. I was told by the Verizon store to get it swapped out. So I had it swapped out, then did that funky update from a few months ago and started getting reboots, so I finally decided to root it. Now it's giving me different issues from black screen to no data connection. I'm currently using my very ancient Touch Pro 2 right now.
  21. Yeahha

    Yeahha Usually off topic VIP Member

    Did you disconnect the service from the bolt? If so then I don't think the SIM card can be reactivated and you would need to go to VZW to get another one to activate the phone again
  22. scotty85

    scotty85 Guides Guide

    Pure and simple desperation. ;)

    You can call them,and they likely will send you a refurb. Or you can wait a day or 2 and see if it starts working again,its up to you.

    Mine started on a frday morning,didn't work all day,I even flashed he leaked mr2 in hboot,and it wasn't working still(with exception of 1x in Cdma only) when I went to bed Friday. Sat I got up and it was fine.

    They were allready sending me a new phone,so I kept using it,and eventually decided to keep the old and return the replacement. It has been fine since.

    I believe selecting Cdma only gives you 1x,because its "old school" cell signal data used by other "nonsmart phones". It was slower than snot. But like I said,better than nothing.
  23. scotty85

    scotty85 Guides Guide

    Thunderkat any progress?
  24. TxGoat

    TxGoat Guest



    That's a funny story....well not really.... The Tier 2 rep that I was speaking with actually told me that I could deactivate the TB while I tried to restore it (screen was also acting buggy and I needed a working phone) so she told me that she could activate my TP2 and once I've got my TB back up and running that she could reactivate it without a new SIM card. I guess I should've followed my instinct because she didn't sound very knowledgeable, but I went ahead and activated my 2nd phone, so now I have to go out to the Verizon store after my restore was complete and try to see if that fixes my data.

Share This Page