Polaroid PMID701C


  1. PRBMAINT

    PRBMAINT Member

    I have ordered a Sony 10A1-04106 Audio/Video cable to try the TV connection. There is a lot of work going on at freaktab.com on the Polaroid PMID701C. I have signed up there and I am seeing a lot of development from the forum members try to build the ideal ROM and see what this unit is really capable of doing. If you look closely to your unit it does not have the official Google Market, now Google Play, installed. I didn’t try to install the market without rooting, but I think you need to be fully rooted to do this correctly. You can stay stock and buy from the Amazon App Store (installed) or get apps from other trustworthy places on the web. You may be limited in you app selection without the market. Mainly, without rooting, your device will pretty much be as it is out of the box, excluding the apps you install. There are a lot of cool things you can do to improve the stock state and you can get apps that require root access for more uses and applications designed for root. If you want to learn more about modifying your Polaroid check out Freaktab.com. I have also ordered an adapter for the USB to use a full size, standard USB connection, not sure if this will work on a Polaroid but some tablets will allow external keyboards. Good luck
  2. dchamilton

    dchamilton Well-Known Member

    Someone else may confirm, but I think this might be limited by the OS. If they are making an ICS rom, then this should be available.
  3. tube517

    tube517 Well-Known Member Contributor

    Not a bad looking tablet for the price. May have to look into this for my son
  4. mechanics200

    mechanics200 New Member

  5. djotherguy

    djotherguy New Member

    I just picked this tablet up and am trying to use the step above with Superclick. When I click check drivers, i get the missing drive popup. I say yes and get "no signature was present in the subject." Any ideas?
  6. PRBMAINT

    PRBMAINT Member

    djotherguy,
    Did you have USB Debugging turned on or off? That could have made the difference...
    djotherguy likes this.
  7. PRBMAINT

    PRBMAINT Member

    mechanics200,

    My market works okay , but I cannot "see" all of the apps in the store. I have a droid phone so I can easily check for apps there as well, besides using the PC to search. I am wondering why I can't "see" the same apps. I have explored with editing the prop file but that has not worked so far. I have also changed display settings. From what I gather from Antiluddite's comment above, this area my be unwanted in this forum... I am looking on other forums and following their expertise and testing as well. I may factory reset mine to try all of this again to find a cure and learn from the entire process. Any ideas or pointers would be appreciated- PRB
  8. wetbiker7

    wetbiker7 Well-Known Member Contributor


    There is a market unlocker that you can download and I've only used it once or twice . Maybe someone that has used it more can give you a little more info on it .
  9. djotherguy

    djotherguy New Member

    It is turned on.

    Thanks!

    kevin
  10. jwh42000

    jwh42000 Well-Known Member

    This is a super excellent thread. My wife and mom just got these tablets they are soooo similar to the prevail I was thinking root and roms as soon as I saw them. Good job!!

    We did successfully add the play store, the Google services framework was already installed so you only need the vending apk
  11. dpierce15

    dpierce15 New Member

    I just got a Polaroid PMID701C today. I cannot connect to the internet. Any suggestions?
    I have gone to the wi-fi settings and see my connection, typed in the correct password and keep getting the message "Scanning, connecting, disconnected".
  12. jwh42000

    jwh42000 Well-Known Member


    What's your setup for Wi-Fi? Do you have your own router or you trying to hop on other people's hotspots?
  13. jwh42000

    jwh42000 Well-Known Member


    The way I understand it, the market filters results for what's compatible with your OS and device.
    Redlaser works with the prevail but market swears it doesn't. Google can provide a lot of compatibility info
  14. kolosus

    kolosus Well-Known Member

    I do not have the device so I'm just throwing out a generic solution to the issue that I've noticed on Android.

    Try doing a factory data reset.
  15. jwh42000

    jwh42000 Well-Known Member

    Depending on your router, if its dlink type 192.168.0.1
    Netgear is either 192.168.1.1
    Or http://router login.net
    Admin
    Password blank or password
    Verify correct security key in wireless settings

    You can also add your device here.

    If none of that works hard reset your router
    Hold in the reset for 5 sec then pull power cord
    Continue holding reset for 10 sec and release
    Plug power cord in

    You will have to set your router back up but its pretty straight forward
  16. UncleBud

    UncleBud Well-Known Member

    I see this a lot lately with tablets and smartphones of all flavors. Sometimes it's
    just a matter of backing out of wireless settings then go back in and presto! connected.

    Failing that, try long pressing on your wireless network ssid and select 'forget'
    then try to reconnect and pay extra special attention when typing in the
    security key. Very easy to fat finger on these touch keyboards and accidentally
    type the wrong character. Rather then tell you it failed, it'll just keep trying to
    obtain an ip.

    Oh yeah at risk of stating the obvious, your key is case sensitive.
  17. djotherguy

    djotherguy New Member

    I got this to work! I was trying it on a XP computer. I connected to a Windows 7 computer and it worked! We still can't download Pandora but I haven't got to play with it in a couple days.

    Thanks!!
  18. Antiluddite

    Antiluddite Active Member

    I had this exact same problem with my third tablet. Spent the better part of a day troubleshooting to no effect. Finally returned it and the replacement hasn't given me a wifi headache since.
  19. Magnapro

    Magnapro New Member

    Has anyone gotten the voice command and voice search to work on this. I have not yet rooted mine, just picked up yesterday. So far I have been able to load all the apk's I was interested in. Got swipe working, but voice search crashes and closes. Maybe I am missing some support files for it.
  20. Magnapro

    Magnapro New Member

    I have attempted the full root of this device on 2 different computers and can not get SuperOneClick to recognize the device, it sees it, but does not install driver. I did download and install Android SDK | Android Developers. Made no difference. SuperOneClickv2.3.3.0 offers to force driver, but when I click yes, it says no signature was present in subject and fails to install driver. I have tried to point device to drivers in the SuperOneClick folder, it says no driver that matches, or however its worded. I downloaded the RK29 drivers they also do not work for Polaroid PMID701C.
  21. Magnapro

    Magnapro New Member

    I think the problem with superoneclick is as djotherguy mentioned. It will not work on XP or Vista. I have tried 5 computers and the closest I get is SuperOneClick recognizing device, but when you click on yes to force install of drivers it errors with "no signature was present in the subject" or "unable to load difxapi.dll" I have tried downloading and manually registering this dll but still get errors forget exact error, something about entry line. Anyone know if this dll is unique to Win 7 or part of latest version of framework not available in other versions of windows? has anyone got SuperOneClick to work in Vista or XP? I have rooted dozens of mobile phones and never had a problem with other methods on XP or Vista. I have updated operating systems and installed latest version of Framework. Also tried installing Android SDK. I have 6 or 7 computers available to me, but none with Win 7. I have been hesitant to manually change system folder to RW since much info on this device shows that is not a persistent state, changes back on power off and can brick device. Any ideas or suggestions?
    Thanks Everyone for all the great information on this device.
  22. unotlikeme

    unotlikeme Well-Known Member

    i just picked up this tablet and my model number is diff PMID701i and it is running android 4.0.
  23. UncleBud

    UncleBud Well-Known Member

    Anybody figure out what that video port does? Any way to hook this puppy up to a tv?
  24. gknight1975

    gknight1975 New Member

    does anyone know where to get a replacement screen for the PMID701c tablet.
  25. kolosus

    kolosus Well-Known Member

    Crap. You already broke it? Google my man!

    BTW. If anyone cares to get in touch with an admin/moderator they'll very easily create a section in the forum for this tablet instead of it hiding in the Prevail's subforum.
Loading...
Similar Threads
  1. WaxyChicken
    Replies:
    5
    Views:
    3,246
  2. ejl2010
    Replies:
    20
    Views:
    13,101

Share This Page