possible battery manager fixTips


Last Updated:

  1. jacko1

    jacko1 Well-Known Member This Topic's Starter

    Joined:
    Apr 19, 2010
    Messages:
    284
    Likes Received:
    14
    the ongoing issue with battery manager force closing
    my fix is that i go into application/running services/ clear data
    and problem is corrected havent had an issue in 2 days
    hopes this helps you guys
     

    Advertisement
  2. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Nothing seems to work for me, outside of using it for awhile throughout the day. Then it seems to magically work again.
     
  3. mxsjw

    mxsjw Well-Known Member

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    Same, it seems to be completely random for me. It works fine 90% of the time, but when it starts FCing, nothing seems to fix it but time.
     
  4. eulerphi8

    eulerphi8 Well-Known Member

    Joined:
    Jul 21, 2010
    Messages:
    132
    Likes Received:
    21
    I don't know why, but this has always worked for me. After a force close I just need to plug it into a wall outlet. I suppose the batter log resets itself or something because it works fine afterwords no matter if it is plugged in or not. After rebooting the phone, I also need to plug it in at least once before the battery manager will work.
     
  5. mike145

    mike145 Well-Known Member

    Joined:
    Aug 21, 2010
    Messages:
    117
    Likes Received:
    11
    Nothing is helping my battery problem, and I have an extended battery.
     
  6. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    Clearing the data has never worked for me.
     
  7. jacko1

    jacko1 Well-Known Member This Topic's Starter

    Joined:
    Apr 19, 2010
    Messages:
    284
    Likes Received:
    14
    on my 3rd still no issue
     
  8. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    I did another factory reset Friday night. Its still happening, but it does seem hit and miss as to when it works.

    I did notice that it started happening AFTER I installed LP though. Can't say for certain if this is causing the problem however. I've also not reinstalled WL until Kevin updates it.
     
  9. iresq

    iresq Active Member

    Joined:
    Aug 17, 2010
    Messages:
    32
    Likes Received:
    1
    Did you do the clean reset?
     
  10. jacko1

    jacko1 Well-Known Member This Topic's Starter

    Joined:
    Apr 19, 2010
    Messages:
    284
    Likes Received:
    14
    i clear the battery manager at the applications settings
     
  11. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Yes sir I did.
     
  12. igotgame

    igotgame Well-Known Member

    Joined:
    Sep 18, 2010
    Messages:
    123
    Likes Received:
    8
    When mine does that I use "Clear Cache" app on my rooted phone....seems to work everytime.
     
  13. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
  14. queenrocks77

    queenrocks77 Well-Known Member

    Joined:
    Sep 12, 2010
    Messages:
    147
    Likes Received:
    7
    Haven't tried clearing the data. I'll try it and see if it works.
     
  15. amoeller

    amoeller Member

    Joined:
    Jul 20, 2010
    Messages:
    19
    Likes Received:
    18
    I think I may have found something. Since I upgraded to Froyo with the leaks and now to OTA I have never got the battery manager to work. 100% failure. I tried something that fixed it for me. In Clockwork recovery I went to advanced then reset battery stats. Then I cleared cache partition. For the clear cache I don't think this matters but who knows. I restarted my phone and dam, it works now. I did cold restarts to the phone and so far no force close.

    Hope it helps.
     
    Exiled and Trooper like this.
  16. SFWB

    SFWB Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    427
    Likes Received:
    27
    This worked for me. I was just able to go into battery manager and look at the usage statistics for the first time without a FC. Nice find.
     
  17. ekyle

    ekyle Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    One thing that I noticed was after I did a cache clear to fix my MP3 issue my battery manager broke. Force closes every time I would try to open it. Then I did another cache wipe, and both of them worked. Something is definitely a little off with 2.2 but all my problems have been fixed by cache wipes so far.
     
  18. 2horses

    2horses Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    583
    Likes Received:
    47
    Okay, I'm seeing the fc issue for the first time, and want to try this fix but don't see the option to clear the data under running services. Is it specific to the battery manager? Because I don't have that as a running service either.
     
  19. jacko1

    jacko1 Well-Known Member This Topic's Starter

    Joined:
    Apr 19, 2010
    Messages:
    284
    Likes Received:
    14
    Under running services go to battery manager then go to clear data
     
  20. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Can I do this via Droid X Bootstrapper?

    Do I choose Bootstrap recovery or reboot recovery?

    Thanks!
     
  21. 2horses

    2horses Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    583
    Likes Received:
    47
    It's not listed under my running services. But my battery ran down to zero last night and the phone died, I plugged it in and then powered it back on once it picked up some charge, and so far no more fc.

    Wait. Got it. It's not under Application Settings/Running Services, it's under Application Settings/Manage Applications/ Running (tab). Evidently two different lists, has a bunch more under the latter than the former.

    eta - Well crap! It worked fine while it was plugged in, but unplug it and it fc's. Tried clearing the data (now that I found it) and that didn't work either. Oh well. I don't spend a lot of time checking that anyway, just check the charge level on BatteryLife. Hate it when something doesn't work right though, makes me wonder what else isn't working correctly either.
     
  22. Lars

    Lars Well-Known Member

    Joined:
    Mar 24, 2010
    Messages:
    1,439
    Likes Received:
    210
    Maybe has to do with what is running. You can also dial *#*#4636#*#* and get detailed battery, gps, network etc usage. Certain threads will force close it too when you go to look at the details of which thread is connected to which application.
     
  23. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Just tried this as well and so far so good! Thanks man! :)
     
  24. Exiled

    Exiled Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    327
    Likes Received:
    19
    I can't believe it, but this actually WORKED!!! Thank you!! I can't even remember the last time I saw the battery manager work. Must have tried almost 100 times on various versions of 2.2 leak and ota and never got it to work. awesome :)
     
  25. avlfive

    avlfive Member

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    0
    Anyone that's tried the Battery Stats clear from ClockWorkMod Recovery, has it came back? Every "fix" that I've used has ended up working for a little bit and then I'd start getting the FCs again. I'm definitely gonna give this a shot though.
     

Share This Page

Loading...