Post Update WiFi on Up Time = Awake Time


Last Updated:

  1. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Having wifi on when you're near a router is supposed to save battery since the router is close and the phone doesn't have to search for a 3g signal.

    After the OTA update my phone no longer sleeps when I have wifi enabled. So now I'm killing my battery by using my home/work wifi routers instead of taxing sprints network connecting to 3g.:confused:

    Is my phone the only one doing this? I haven't read any other reports.
     

    Advertisement
  2. emericaonline

    emericaonline Member

    Joined:
    Jun 30, 2010
    Messages:
    5
    Likes Received:
    0
    I am also having this problem.

    I had just gotten comfortable leaving wifi on. Now the battery drains much faster :[ with it on.
     
  3. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Yes. Exactly. Very counter productive.

    I'm glad I'm not the only one. It took me a while to figure out what changed since I hadn't DLd any new apps the last couple days. Spare parts also wasn't giving any indication as to what was keeping the phone awake.
     
  4. emericaonline

    emericaonline Member

    Joined:
    Jun 30, 2010
    Messages:
    5
    Likes Received:
    0
    I'm wondering if anyone else is having this problem except maybe they haven't noticed it yet.
     
  5. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    That's what I'm thinking. Everyone has their phone finally dialed in and haven't checked Up vs. Awake in the last couple days.

    That's why I started a new thread so it gets some attention instead of not getting read in the other bug thread. This is more of a problem then just cosmetic wallpaper issues or re-adding widgets.
     
  6. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    I leave my wifi on constantly, both pre and post update. I have seen no difference and always get better life with wifi v. 3G. I did turn it off at the office today, because my signal there is weak so I don't use it. I saw no difference in battery life with it off.
     
  7. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    So you leave it on constantly but turn it off at the office. What is your up vs awake time with it on? I think it's an agreed upon fact that wifi uses less juice then mobile networking. I guarantee that if your phone is not sleeping then it is using more battery then if it was.
     
  8. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    I turned it off today, which was the first time I had done so, for 2 weeks I have been running wifi and gps all the time. I just happened to turn it off today to see if I would get an increase in battery life. I did not.

    And my up/awake time ratio is about the same, 3 to 1. Currently I'm at 22:52:32 up and 7:02:10 awake.

    All three EVOs in the family are set this way. I leave mine unplugged at night once I hit 100% and lose between 1 and 5% a night. It's sleeping.
     
  9. Wifi-Naught Odin

    Wifi-Naught Odin Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    74
    Likes Received:
    21
    I constantly turn wifi on and off thruought the day (habit) and constantly hop on diff wifi networks.

    That's why i use a wifi widget on my homepage (instead of the tools burried in the settings)

    I use 'Wifi Manager'
    WiFi Manager | AndroidApplications.com

    If you're going to use any third party wifi app, do this first to avoid authentication conflicts.

    Go into htc's wifi settings and delete or 'forget' all preexisting networks your phone's remembered or stored.

    Then turn and or leave wifi 'on' with the official htc wifi setting. (consider that like the master circuit)

    Then use your third party wifi manager/widget/toggle on-off/app (hence 'Wifi Manager') to turn wifi on or off or select and connect to networks.

    Just make sure your htc wifi memorie's wiped first and that the htc wifi is 'on'.
     
  10. RoboMonkey

    RoboMonkey Well-Known Member

    Joined:
    May 12, 2010
    Messages:
    1,194
    Likes Received:
    114
    When you say "it's up" do you mean the screen is on?
    If not, then I don't see the issue. If the screen is off and you're not pushing data wifi wont kill your battery faster than 3g. I had my wifi to never sleep and could go 1d + on a charge (not using the phone much). Over night was never an issue.
     
  11. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Robo, your post is the only place I see the term "it's up" so I'm not exactly sure what you're referring too.

    The screen is not on but the phone does not enter standby/sleep in any way. When near a wireless network at home or work I have and always have enabled wifi on the phone and it's always set to 'never sleep' but now, after the update, the phone stays awake when wifi is enabled. Up time is equal to awake time. The phone is awake 100% of the time if wifi is turned on. If the phone is always awake it has to be draining the battery faster.
     
  12. RoboMonkey

    RoboMonkey Well-Known Member

    Joined:
    May 12, 2010
    Messages:
    1,194
    Likes Received:
    114
    I'm sure it is draining the battery faster, but that's a relative term. You can have it on all day on WiFi "like I do" and it wont kill your phone in a day.

    I think it's really a non issue. If you're getting at least 3-4 hours of Display Up Time the phone well with in it's normal operating range.
     
  13. ss220

    ss220 Member

    Joined:
    Jun 6, 2010
    Messages:
    19
    Likes Received:
    2
    Where are you seeing that the phone is not sleeping? Since the update, I've kept wi-fi and gps on constantly. My phone shows 34 hrs up time and only 3 hours awake time. It was on all day yesterday (light use) and after 14 hrs I still had all bars but 1 showing. I'm seeing no impact having wi-fi on at all.
     
  14. kamikazekyle

    kamikazekyle Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    96
    Likes Received:
    16
    I noticed that when my phone is plugged in and 97%+ charged, my CPU use spikes to 100% and stays there until I unplug the phone. At that point it then reverts back to normal. Aside from that (which I think is related to a live wallpaper anyway), my battery drain while idle is less than 1% an hour according to System Monitor. I don't have my phone handy to check my awake vice up-time.

    For reference, I connect back and forth to N and G routers (have two in my house, so I swap between them), and haven't noticed the problem on either one.
     
  15. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Under the settings, about phone, battery menu.

    I guess it's just me and the one person above that is having this problem. Strange. Looks like a hard reset is in my future. Not fun.

    3 1/2 hours since unplug today and battery down to 63% already with no usage except push gmail. That's ~twice as fast as before the update.
     
  16. archercc

    archercc Well-Known Member

    Joined:
    Jun 12, 2010
    Messages:
    432
    Likes Received:
    68
    My phone is showing 94% utilization since the update and instead of getting a day out of the battery I am getting two. I think that battery list thing is misreporting since the update.
     
  17. emericaonline

    emericaonline Member

    Joined:
    Jun 30, 2010
    Messages:
    5
    Likes Received:
    0
    Hey mabster I think I found a fix.

    I changed wifi networks to my other router and it seems to be normal now.
    I recommend forgetting the wifi network in your phone's settings and then setting it up again. Hopefully it should fix.
     
  18. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    I tried resetting the router and forgetting/resetting my phone settings with no luck. On a whim, I tried changing router channel and encryption settings, no luck.

    Thanks for trying to help but I'm 45% battery left with only 34 minutes of Display Up Time. It is an issue and not within normal operation range.

    So many views to this thread and only one other confirmation that the problem exists or existed means I'm pretty alone on this one. Sucks for me.
     
  19. RickJ

    RickJ Well-Known Member

    Joined:
    Nov 19, 2009
    Messages:
    258
    Likes Received:
    64
    Am I correct to assume that this problem goes away when you turn off the wireless network?
     
  20. emericaonline

    emericaonline Member

    Joined:
    Jun 30, 2010
    Messages:
    5
    Likes Received:
    0
    Ah. I forgot to mention one other thing I did but you maybe have already tried it but who knows.
    Hopefully this one fixes it for you and if not i'm sorry :/

    On the wifi settings screen press menu and go to the advance settings.

    Using the wifi sleep policy set it to after 15 mins.
    At this point it was fixed for but afterwards after testing to make sure it worked I changed it back to never and the awake=sleep was still gone.

    Good luck :/
     
  21. RickJ

    RickJ Well-Known Member

    Joined:
    Nov 19, 2009
    Messages:
    258
    Likes Received:
    64
    I know it probably isnt much help to you, however I have had the exact opposite happen. Prior to the update my phone would not sleep after 2 or 3 days, even with all syncs turned off except gmail and no d/l apps. battery life was just as yours. In addition the phone would reboot nearly every time I started navigator.

    So far after the update the phone sleeps well and no reboots. Hope you can track it down I know how frustrating it is because I felt all alone on my thread as well.
     
    Mabster likes this.
  22. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Correct, that's how I was able to pin point what was keeping the phone awake.
     
  23. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    I'll give this a go. Maybe switching it around will fix/reset something.
     
  24. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    No luck with toggling the sleep option. Hard reset later when I get a chance.
     
  25. Mabster

    Mabster Well-Known Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    467
    Likes Received:
    127
    Factory reset didn't fix the problem either. Looks like the update screwed my phone after all. Off to BB to get a replacement I guess. Sucks cause I don't have any of the other issues (light leakage, screen separation...)
     

Share This Page

Loading...