1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Power Button Failure?Support


  1. parksoft

    parksoft Member

    Here's the deal...

    I have successfully rooted this phone (thanks to the "Rooting For Dummies" thread) and it solved a handful of issues. HOWEVER, the power button won't put the phone into sleep mode, get it out of sleep mode, bring up the options menu to turn the phone off/reboot/etc. AND when I yank the battery (leave it out) and put it back in, the phone powers up automatically without any prompting. The only way to get the phone out of sleep mode is to plug in the charger/usb (or unplug it if it's already connected).

    Also, when I take the battery out - the power button does work for access to the recovery menus etc. (partition, reboot, boot zip from the SD card, etc.)

    I've cleaned the guts and contacts - no dice. The phone has never been dunked or damaged.

    Hardware failure on the power button (it feels fine)? Or is there something else that will take me the last step toward fixing this last issue?

    Advertisement
    :
  2. cwhatever

    cwhatever Life Goes On Guide

    Did this happen after rooting? If any what rom are you using or just rooted stock? Funny how bower button works for a few things and not others?
  3. parksoft

    parksoft Member

    No, the power button was behaving the same before the root.

    Yes, the fact is weird that I can use it to bring up the menus (power button, up vol)(power button, down vol, cam) but not to get in/out of sleep or turn the phone off/on.
  4. vce2005

    vce2005 Well-Known Member

    Guess it's time to put on a stock Rom ANDDDDDDDDDDDDDDDDD :

    Samsung Tech. Support / Phone Repair
    Samsung
    888-987-4357
  5. parksoft

    parksoft Member

    The problem existed BEFORE the root as well as after. The root actually fixed a few problems but this one is still lingering.
  6. vce2005

    vce2005 Well-Known Member

    Well, if the problem was already there BEFORE you rooted and now is still there ( even if routing fixe some ), than my guess would be there is something wrong with the hardware....

    Best bet, my last post !
  7. parksoft

    parksoft Member

    Ok, the stock rom was a no go. Back to the rooting.

    If it were hardware, it would seem that the power button wouldn't work, period. But it DOES work for certain functions - getting to the menus on boot-up.
  8. vce2005

    vce2005 Well-Known Member

    I just suggested to put it back to stock and unroot it, so you can send it to Samsung for warranty !!!

    But since it is ( in your opinion ) not a hardware issue, I hope you can fix it !!
  9. parksoft

    parksoft Member

    It is out of warranty.

    I was laid off a few months back and can't afford the repairs, to be without the phone while I look for work, or a new one.

    And by the looks of a Google search, this is not an uncommon problem.
  10. vce2005

    vce2005 Well-Known Member

    Well, it's hard to argue what the problem is. You mentioned that you can wake it up when you do something with the charger or if it's connected via the cable....... Heck, maybe there's a connection betweent the power button and the USB port..... Maybe it's a issue with the USB port, someone here, I think LV said something about a special cleaning procedure and what he does, but I don't know if this is related to it.....

    BUT....... something is wrong with the phone..... and sorry you're out of warranty, it was just a suggestion, but if a phone is bad or getting bad, than you might have to get a new phone !!! I mean, no one here can fix a hardware failure via the internet !!

    Maybe there are a few more things you can try, but since you tried already a custom ROM, stock, etc...... and especially since it was happen before you started rooting, believe Me ( or not ) it is a hardware issue which needs fixing !!!

    That's all I can say to this issue..... Maybe someone else has better idea !!!

    Amen ! ;)
  11. wetbiker7

    wetbiker7 Well-Known Member Contributor

    Hmmmmm, looks like it's time for a new phone. Sure sounds like it's hardware failure. I would deal with it as long as I could then get a new 1. The good thing is if you want another Prevail, you can find them pretty darn cheap. I've just come back from pricing used phones on Ebay and Craigs List. There are all kinds of used Boost phones out there that are priced right. If you do decide to upgrade, I recommend the Marquee. It's a great phone and our development is coming right along. I'm running AOKP/CM9 right now and loving it! You can get a used Marquee for less than $100 if you look around.

    The new line up of Boost phones look nice too. The Venice, that was just released, is looking good. Don't know how the new Warp is doing but it's rated at 1.4GHz. Not bad.

    Good luck with your phone and I hope you can get it fixed.
  12. w3wiLLPr3vAiL

    w3wiLLPr3vAiL Active Member

    Hey Fellas I just had a similar problem. My powerbutton lost all function after updating to CTMod3.75 I hailed Odin and went stock then re rooted the phone to 3.75 and it fixed the issue no idea why... as another note when i went stock it didnt fix it only after i reflashed to 3.75 and i could only get out of sleep mode by unplugging or plugging in the USB cord to charger or in my case laptop...
Loading...
Similar Threads
  1. Droiddude24
    Replies:
    16
    Views:
    953
  2. kyleglomb1
    Replies:
    6
    Views:
    405
  3. Bond J
    Replies:
    15
    Views:
    814

Share This Page