Power Jack/Plug issuesSupport


  1. jrsummersill1

    jrsummersill1 Well-Known Member

    Has anyone else been experiencing any issues when charging your the a100? I have noted that everytime I plug it in to charge while I am still using it, I have to hold it very still or it will go from charging to not charging to charging, etc.--like the connection is not tight. I haven't dropped it or anything, so the power jack shouldn't be loose. I just bought it back in December so perhaps I should send it in to be repaired??? Thanks!

    Advertisement
    :
  2. Mrhelper

    Mrhelper Well-Known Member

    The connection should not be that loose. It could be a broken wire in the charger cable, or a damaged jack. It seems reasonable to try having it repaired under warranty.

    This may seem obvious, but I will mention it just in case. The tablet will charge with the plug inserted only half way into the jack, but will act as you describe when moved. When plugged in completely the plug locks into the jack firmly, and when you look at the jack from the side, the black plastic of the plug should be nearly flush with the tablet. Removing the plug requires a fair amount of pressure to release the lock -- i.e., it won't fall out without being firmly pulled.
  3. JLtech

    JLtech Member

    I think you need to try using a new charger. The charger you have is messed up. As described the plug should fit in fairly tight and stay charging the whole time it is connected. Also just to ensure the charger is bad try plugging it into different outlets and see if you get the same results. Anything is possible.
Loading...

Share This Page