Pre-steps for pushing PRL onto CM7


  1. don0017

    don0017 Member

    Lets start with the usual tidbits; i'm not responsible for anything that happens to any of your devices during this process, can't guaranteed it will work for everyone, etc. I'm also going to assume you have atleast some knowledge of your Computer OS, operating system and bit.

    Consider this method as a last prayer resort if the ports won't show up (even in recovery mode with usb mounted, thanx shinyside) and you're getting 5 sets of Android Mobile Adapter in your device manager.

    Using CM7.2 09132011 and PRL 3024
    As of this write up, PRL was pushed the day before, thus far, phone runs fine and everything has gone smoothly;
    please be careful, despite what may look like good results, can turn bad once you push the PRL if this process is screwed up. (CAN turn bad, I wouldnt know, i'm not gonna experiment with a screwed up step, then try to push the PRL, only to find i permanently screwed up my phone.)

    So, I wasn't in the mood to flash down, push the PRL, then flash back up again. But for those who have tried have probably (despite how much you setup the drivers over and over again) get this in their device manager:
    [​IMG]
    Note: These will appear when your phone is plugged in to the PC (via USB of course), so plug it in :)

    This occurs because the hardware ID doesnt match the IDs inside the huawei drivers. This is probably because (I'm guessing now) the hardware ID within the device is possibly the remnant of the original phone in which the Android 2.3.5 was taken from. With mismatching IDs, our computer's are not even aware it is a Huawei Device. So we're going to force the drivers in. And this is where it can go dangerous; forcing the drivers will cause the driver to install regardless, but if the wrong one is pushed in, who knows what could happen when you push the PRL next.

    So boot your phone normally and plug in your phone to the USB and here we go:
    1. Double click on one of those lovely "Android Mobile Adapter"; I do recommend starting at the top and working your way down.

    2. Click on the "Details" tab; Change the Property to "Hardware IDs"; and make note of the last 2 digits on the first value:
    [​IMG]
    In this case last 2 digits is 04.
    Side note: You will find each of the Android Mobile Adapter Hardware IDs to have different final 2 digits (00, 01, 03, 04, 05)(there is NO 02)

    3. Lets go back "General" tab; then hit "Update Driver"

    4. Follow the Pics:
    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    5. Now upon clicking on "Have Disk", hit browse and move yourself onto the Ascend_usb_drivers (or whatever you named it or wherever you saved it), but don't click open yet, lets go deeper.

    6. Once inside, go into another folder "usb_drivers"; inside you will find more folders corresponding to your OS. Please pick the proper OS (mine is Win764, in other words windows 7 64-bit)

    7. Choose any of the 4 INF, (it'll open all of them anyways), Click open, then Click OK

    And behold, this will show up:
    [​IMG]

    Now choose Manufacturer and Model in accordance with that value from earlier cross referencing with this info:
    Value Manufacturer Model
    00 Huawei Incorporated Android Adapter Modem
    01 Huawei Incorporated Android Adapter PCUI
    03 Google, Inc Adapter ADB Interface
    04 Huawei Incorporated DBAdapter Reserved Interface
    05 Huawei Incorporated DBConsole Reserved Interface

    Repeat, until you've done all 5
    Side note: Maybe not all 5 is necessary, but I did anyways, you'll have extra com ports showing up, but just follow the QPST posted by Rokyn: http://androidforums.com/huawei-asc...end-prl-3020-update-tutorial.html#post3117288

    Oh yes, once done, unplug the USB, and replug again (probably not necessary)

    Last (maybe) side note: When you replug your phone, please replug into the same USB port, otherwise you'll be doing this all over again, and will probably get a different COM port.
    Also, in addition to the QPST intructions, I like to click "Read from Phone" first..then browse for PRL, then finally "Write to Phone"

    Advertisement
    Scur, Kuzco and Scorpion7867 like this.
  2. Martin714

    Martin714 Well-Known Member

    im having trouble on this i dont have tht first part when i plug in my phone it doesnt say android mobile adapter at all nd im running cm7.2
  3. don0017

    don0017 Member

    Shot on the dark guess...was the phone plugged in to the computer?

    Also in the usb driver folder..somewhere there is a driversetup.exe and driversetup64.exe, run whichever is appropriate for your OS
  4. Martin714

    Martin714 Well-Known Member

    yea nvm im good dude it actually worked u saved me a lot of time dude +100000000 lol =]
  5. Scorpion7867

    Scorpion7867 Well-Known Member

    Win7 does not show the " manufacturer " when I get to that screen. All it lists are the 3 android ADB adapters interfaces. Does not show Google or Huawei at all. Any ideas?

    I have been trying to get this to work for weeks. I'm starting to think I may have a hardware issue. Other than this the phone runs fine on CM7.



    Thanks
  6. don0017

    don0017 Member

    Hmm...thats a tough one. First thing that came to mind is that it's a different set of drivers (which I doubt myself, but who knows) I should ask first on where you got your drivers from? As mine came from a link at the 3020 tutorial thread: ascend usb drivers.rar

    Another idea would be that you're in a slightly different screen than I had intended, (missed a step perhaps) my apologies, don't mean to insult you, just shooting ideas.

    If anything, despite this is a bit troublesome, but if it works that means you wont have to do it again; separate the INFs from each other. Its possible your system is reading 1 INF at a time, which it shouldn't.

    One way to get the computer to see a specific INF is by renaming the extension of the other INF files. Basically take the words INF, and rename to something odd like INO or something; leaving only a single INF. Computer would see that INF and install whatever's in there, or give you choices of what's available from that INF.

    Value - INF File to use - Model (if given a choice)
    00 - smhwmdm.inf - Android Adapter Modem
    01 - smhwser.inf - Android Adapter PCUI
    03 - smhwadb.inf - Android Adapter ADB Interface
    04 - smhwser.inf - DBAdapter Reserved Interface
    05 - smhwser.inf - DBConsole Reserved Interface

    Note: I know there are 4 INFs...but only 3 are actually used according to the table. the 4th INF "smhwdev.inf" should be renamed as well to make sure its out of the way.

    Try that and let me know.
    Scorpion7867 likes this.
  7. swtnss

    swtnss Well-Known Member

    Is there some way that i can do this on windows xp. Thats what I have. Are there any drivers for xp. the file i have only have drivers for vista and windows 7
  8. don0017

    don0017 Member

    Unfortunately I do not know. I have never plugged in the Ascend to Windows XP nor do I know what drivers they.
  9. AwesomePie85

    AwesomePie85 Well-Known Member

    It seems that for allthe huawei drivers installed it didn't seem to install correctly. It has all the "android adapter pcui" and all that installed but when it finished it said it wasn't installed correctly. Also do I need to be connected to the internet on my computer to do this?
  10. mteezey

    mteezey Well-Known Member

    IMO the best way to do it is to mount usb storage. then run the pcoptions.exe which is in the zip for the ascend drivers. Now reboot into recovery go to mounts and storage and mount usb. You then should be able to go to device managers and the ports will show up. In qpst make sure to uncheck the box that says show only universal ******* ***** the post should show and you should be able to add it now. As for as being connected to the internet. No. And like don said since the computer doesnt recognize the phone as the ascend anymore im pretty sure your not gonna ever get the drivers to say they are installed properly. I could not get it to work without being in recovery. On windows seven pc or windows xp. but windows xp worked like a charm. On windows64 in some cases your ports may be under modems.
    AwesomePie85 likes this.
  11. AwesomePie85

    AwesomePie85 Well-Known Member

    Thanks I got it. I just needed to install he USB mobile drivers. After trying for a half hour do I only realize I had installed the drivers in my other computer but not this one. :-/
  12. BlastGT1

    BlastGT1 Well-Known Member

    Massive props to don0017 for this guide! For the first time ever, I was able to get my phone connected to QPST.
  13. Scur

    Scur Well-Known Member

    It's always nice to see a guide where someone went to a lot of extra trouble to make it as clear as humanly possible.
  14. mteezey

    mteezey Well-Known Member

    Need help finding a qpst download that fully works. When I start service programming all the tabs aren't there mip ppp ect ect, and I need to program data so kinda stuck. Someone that knows a fix or has a good dl please lmk. Or PM me thanks in advance
  15. nuttmeg

    nuttmeg Well-Known Member

  16. mteezey

    mteezey Well-Known Member


    How did I know I would get a response from you nuttmeg. Your always there for me. Much appreciated. I ended up getting a full version that worked off 4shared. Took me forever to find one that was from a few days ago and it worked fine. One more evo on metro now. But as yiu can see I have to rely on my fellow acsenders.
    Just to add to this as an fyi. No matter what qpst you download you can use it to write prls. Its programming data like the mobile IP tabs that do not show on the bad ones. So for everyone that's just trying to get 3g and force a new prl any of the links found here will work.
    nuttmeg likes this.
  17. nuttmeg

    nuttmeg Well-Known Member

    i love to help everyone...;) but i cant let my ascenders down.:D
  18. ryaanx3

    ryaanx3 New Member

    uhm... for the first one, i hit google instead of huawei. how can i change it back or uninstall it or whatever?

    edit: nevermind i figured it out

Share This Page