Primary Contact Method


Last Updated: 2010-09-07 10:20:16
  1. AndrewTighe

    AndrewTighe Member

    Hi, just like to say thanks for all the help people have given me in the past, this forum has been great. My Desire is fantastic, does some odd things now and then but essential it is ok (like once the camera wouldn't work but the camcorder would? then it just started working again, the weather widget pops up quite a bit as does the desktop clock but I can just cancel them so no real big deal).

    Anyway, what I would like to know is when I pull up my contacts in the phonebook, there is a primary method of contact associated with some of them. I take it that this is automatically assigned the first time I contact that person. Does anyone know how I can change the primary method of contact?

    Thanks

    Advertisement
  2. lekky

    lekky Lover VIP Member

    its assinged to the first number that was given to a contact. To change do the following:

    people > click on person > long press on number you want to make primary > click 'set as primary number'
  3. broono83

    broono83 New Member

    Hi, I have a related (i think!) problem to this. When I send an sms message to a group of friends, half of the contacts I add are added as mobile numbers and half are e mails. I want all phone number for an SMS.

    After looking at the contacts screen, the guys who were added as e mail all have an e mail address stored (grabbed from facebook via the htc app) and it is marked as "Primary" as is the phone number for calls. The phone number for sms is not marked as "primary". Is there a way to swap this primary from e mail to SMS or another way to fix my probblem?

    Thanks

    Chris


    edit: to add that I tried long clicking on both e mail and SMS but was not offered the choice to make either primary
  4. miasma

    miasma Member

    This has been bugging the hell out of me as well.

    I transferred approx 400 contacts from a Sony Ericsson C902 via Bluetooth. Most of these contacts have multiple numbers, and the default number was set up correctly on all of them on the C902. Given that we are now well into the 21st century, this was the mobile number for most of the contacts.

    When importing into Android the other day, it seems to have unilaterally decided that where someone has, for example, a home and a mobile number listed, the home should be the default. I really cannot be bothered to go through 400 contacts one at a time and change it manually, so my question is is there any way to batch convert all default numbers to mobile where the contact has a mobile number listed?
  5. broono83

    broono83 New Member

    bump*
  6. DaveO

    DaveO New Member

    Just joined the firm and found this topic via a search.

    Has anyone resolved the problem of how to set a number as primary for SMS?

    I have several contacts where having sync'ed with my Google contacts I have ended up with two numbers for messaging and neither is designated primary so the first one is chosen by default. That is usually a land line so doesn't work for SMS (nor would I want to message to that number if it did).

    Pressing and holding the message entry in the people deatail screen does not change anything.

    Phone is a HTC Wildfire running 2.1
  7. hussar10a

    hussar10a Active Member

    Similar sort of thing here although I have a lot less than 400 contacts so defaulted them manually and individually.

    Do wish there was some way to be able to remove the "send message" tag from a landline number and only allow the mobile number to be listed - fat thumb syndrome means I have sent many texts to peoples landlines rather than mobiles !
  8. Tunga

    Tunga Well-Known Member

    Lekky already answered that question. Go into the Contacts app (HTC call it "People" I think), open the relevant contact, long-press the number, and choose the Set As Default option or similar. Does that not work for you?
  9. DaveO

    DaveO New Member

    No it doesn't work. It will work for "call" entries i.e. call mobile, call home etc but the long press does not work on any of the "send" entries for the contact.

    I have two "send message" entries for the contact and neither is designated primary and the long press won't change that.

    If I could delete the land line entry from the contact under the "send message" category that would do but I suspect the next time a sync contacts with Google it would reappear.

Share This Page