PRL Update Messed Up - Searching for ServiceSupport

Last Updated:

  1. CTE777

    CTE777 Member

    Hello there -- I'm hoping someone can help. I seem to be having a lot of bad luck with this phone. Today, I tried to Update PRL and it appeared to complete the process, but now I have an X next to the signal bars on the status bar, next to the battery icon. And the phone says, "Searching for Service." I went to a Boost Mobile store to see if they could help me, and the guy was on the phone with multiple technicians who could never get the phone working again. Supposedly someone's supposed to call me back on my landline within 48 hours, but I wanted to post here and see if anyone has any suggestions on how to revive this phone. I'm not rooted, and would prefer not to if possible. Anyone out there have any ideas or suggestions? Seems like a software glitch must have happened during the Update PRL. Let me know; and thank you.

  2. JRBig

    JRBig New Member

    I had the same problem. It took six days for Boost to tell me what I already new that it was a phone problem and I had to send it to LG for repair. I was without service for 19 days. Hopefully it won't be that long for you.
  3. CTE777

    CTE777 Member

    Hi, JRBig -- Well, it looks like I got lucky. I just did some searching here on the forum, and found a thread on how to update the PRL manually. And believe it or not, it actually worked! I used a Boost Mobile PRL that I found in this thread, and went through the instructions to manually update the PRL. When I rebooted my phone, the antenna kicked in, and the phone updated the PRL with the one that the Service Tech tried sending earlier today. I was in the Boost Store for at least an hour, and was shocked that they didn't have any method for doing this themselves in-store. It was clearly a corrupt file causing my phone to not connect. I'm just glad I didn't have to send it in like you did (I'm sorry.) Anyway, just wanted to post this in case someone else needs the info. I may never update my PRL ever again... and IF this DOES happen again... at least I now know what to do. All the best to you and everyone here. Take care.:)
  4. JRBig

    JRBig New Member

    Glad it worked for you. I was going to give you the 800 number to LG and tell you to check your voicemail from an other phone because Boost called my cell and left messages without calling my landline.
  5. kisses932

    kisses932 New Member

    I just got this same phone with Boost on Friday. I am having the same issue and was told it could take up to 72 hours for someone to call me. Well it has been over 72 hours with NO CALL. I am desperate for a phone that works. I have been without since I got the damn thing in the mail on Friday. This has been a nightmare for me!!!!!!!
  6. VyCariously

    VyCariously New Member

    I just got the phone a bit over a month ago, and have loved it...until a day and a half ago. I haven't had service since then. I've been through these issues with Boost's "service techs" before. It has taken me many calls before I got one that actually knew what they were doing with a previous issue, and I never did get a return call from them that time, either. I'm glad I found this thread, since "searching for service" is driving me crazy. At least I know another option to try to fix it before ranting at Boost yet again.
  7. lamarr87

    lamarr87 New Member

  8. lMonsterl

    lMonsterl Well-Known Member

Share This Page