Problem connecting Galaxy S to computerSupport


Last Updated: 2011-06-26 19:28:40
  1. skippergeoff

    skippergeoff Member

    When I first got my Galaxy-S I successfully connected it to Windows XP computer by USB. I was able to use Kies and also mass-storage mode. Then it wouldn't connect anymore - USB recognises phone but Kies just says it's connecting. Also, in mass storage mode computer still detects the 2 drives ok (phone and external SD card) but when I try to access them it says "install a memory card in the drive".
    My first version of Kies would not let me use the bluetooth connection.
    I have now upgraded to the latest version of Kies (15 October version) with exactly the same results on USB. The new version of Kies will however allow me to pair the computer & phone on bluetooth connection but if I try to connect by bluetooth I get a message on the PC "device denied the request for connection"
    I have a bluetooth handsfree kit in the car and that works perfectly, so the phone's bluetooth interface must be ok.
    I have the same result on two different PCs (both Windows XP), and as far as the mass storage mode is concerned also on another PC.
    I have tried selecting (on the phone USB settings) Kies mode, PC mode and "ask" but none of them work.
    I am tearing my hair out here! :mad:
    Any advice would be much appreciated

    Advertisement
  2. DroidRick

    DroidRick Well-Known Member

    skippergeoff likes this.
  3. skippergeoff

    skippergeoff Member

    Many thanks for the link. I can now access the phone's memory cards using usb BUT keis will still not connect via usb (just installed the .102 version). I just get the "connecting" message for ever.

    I can connect to the pc via bluetooth outside of keis but the phone thinks my computer is a headset!
    (My old Nokia connects to the pc via bluetooth without any trouble)

    In keis, if I search for bluetooth devices my phone is discovered but when I click "connect" it says the device has refused the connection - even though the pc is clearly shown as a paired device in the phone's bluetooth list.
  4. Jukov

    Jukov Member

    First of all try changing the usb ports. I have this weird issue at work where I can not connect by using the front facing usb ports, but if I dive under the table and connect to the rear ones (that doesn't sound good LOL), everything works perfectly

    Second try this:
    1. Install the Windows Mobile Device Centre (or Micrsoft Activesync if you are using XP). Kies is missing a vital driver which can be obtained through WMDC.
    2. Turn off your wifi and bluetooth before plugging in your phone in.

    If it doesn't help, and while you figuring this out, try connecting your phone via Wifi by using Droid PhoneControl Lite:

    [​IMG]
    skippergeoff likes this.
  5. skippergeoff

    skippergeoff Member

    Thanks for your tips too, Jukov....
    BUT: A major breakthrough! I have found that if I unmount my external SD card (16GB) which has all my music files on it, THE PHONE WILL CONNECT TO KIES!

    So at last I can upgrade my firmware, & do my backups.

    So now I can
    (1) access the external SD card by connecting to the PC in mass-storage mode, and
    (2) access the rest of the phone by unmounting the SD card and connecting to the PC via Kies

    This is messy and irritating but achieves the desired result. Whoopee!

    I hope this may help others with the same problem.
  6. nudger66

    nudger66 New Member

    I have also just purchased a SGS I have spent 2 infuriating days trying to get kies to connect my phone.:mad: Customer support is rubbish so forget that. I have read every forum comment and tried everything everyone suggested. eg. turned off WiFi, tried mass storage mode, unmounted the sd cards, uninstalled and re installed Kies, all to no avail, then I notice a small link in another post mentioning Sony Ericssons "My phone Explorer" which is compatible with Android phones. So in desperation I uninstalled Kies for the 6th time and downloaded My phone explorer and hey presto its worked like a dream.:D
    Just put your phone into debugging mode and use as a mass storage device and you will be fine it was very quick and easy to use. I am one very happy bunny. Samsung should be ashamed of themselves, a fantastic phone badly let down by dreadful software. Kies is not compatible with SGS!
  7. nudger66

    nudger66 New Member

    I have also just purchased a SGS I have spent 2 infuriating days trying to get kies to connect my phone.:mad: Customer support is rubbish so forget that. I have read every forum comment and tried everything everyone suggested. eg. turned off WiFi, tried mass storage mode, unmounted the sd cards, uninstalled and re installed Kies, all to no avail, then I notice a small link in another post mentioning Sony Ericssons "My phone Explorer" which is compatible with Android phones. So in desperation I uninstalled Kies for the 6th time and downloaded My phone explorer and hey presto its worked like a dream.:D
    Just put your phone into debugging mode and use as a mass storage device and you will be fine it was very quick and easy to use. I am one very happy bunny. Samsung should be ashamed of themselves, a fantastic phone badly let down by dreadful software. Kies is not compatible with SGS!
  8. skippergeoff

    skippergeoff Member

    As a post-script to my woes above: Now that I have managed to upgrade the Galaxy S to Android 2.2, Keis connects properly with the SD card mounted and everything apppears to work ok. (But you know how far that goes! rofl)

    I have not retried Bluetooth connection, because to be honest if USB works I'm happy.

    Wish list:
    I wish that, if there is a pending message or notification, there was some indication without having to wake the screen up...such as a very brief intermittent flash of the options button and/or the back button. My wife's Nokia flashes a blue LED when there is a text message waiting - very useful
  9. jrsams

    jrsams New Member

    out of curiosity, are you using Launcher Pro?
  10. janosik

    janosik New Member

    try app called NoLED, does exactly what you want
    cheers, j
  11. skippergeoff

    skippergeoff Member

    No, not using Launcher Pro jrsams.
  12. skippergeoff

    skippergeoff Member

    Thanks Janosik, I'll have a look at noLED :)
  13. andy-roid

    andy-roid Well-Known Member

    Kies 2 is now out of beta and released by samsung
  14. jts123

    jts123 New Member



    The first part of this poste was a HUGE help. Thanks. It really does make a difference if you can try reconnection via an alternative USB port on your pc/laptop. It certainly held me. :)

Share This Page