1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

problem downloading apps from android marketSupport


Last Updated:

  1. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    well I saw similar thread after typing the title ...but my prob is quite different...

    I have downloaded many apps and games before....


    now its showing " couldn't install app on external storage or memory card " after full download and its happening only when the app shows "install" instead of "download " beside the apps. I don't know what's the diffetence between install and download. download is working while install isn't.


    ???????????? :((
     

    Advertisement
  2. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    Well ,
    Download => Copying the file from the google servers

    Installing => Doing required things to Place the downloaded stuff in proper place !

    have you applied the mod for changing the default install location to SD-Card ?
    states that either ur SD-card is not mounted or the app you are trying to install is not Supported to be installed on the sd !
     
  3. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
  4. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    There is a button for it ,
    Btw the link u mentioned completely out of topic ....
     
  5. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    if ur saying this..sorry to say u haven't read my post properly. its just an example nothing to do with the app. o):((o
     
  6. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    OOps !

    Sorry :p
     
  7. tanj2011

    tanj2011 Well-Known Member

    Joined:
    Nov 28, 2011
    Messages:
    331
    Likes Received:
    8
    @ninad do u use root explorer??
     
  8. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
  9. tanj2011

    tanj2011 Well-Known Member

    Joined:
    Nov 28, 2011
    Messages:
    331
    Likes Received:
    8
    Coz when dis problem happened with me..i checked root explorer n in it the sd card was somehow changed to read only so i had to make it read and write by clickin that button in the top n den i could install apps 2 my sd..
     
  10. gargrishab

    gargrishab Member

    Joined:
    Dec 24, 2011
    Messages:
    21
    Likes Received:
    1
    Hey I was having the same problem just backup ur sd card content and then format it ,Your problem will be solved
     
    Idk5 likes this.
  11. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    Glad :)
    But the thing is , I am facing the issue :D
     
  12. akshaybz

    akshaybz Well-Known Member

    Joined:
    Aug 28, 2011
    Messages:
    481
    Likes Received:
    78
    Couldn't get what your post means.
     
  13. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    Read the reply from Tan !
    who asked me if i have Root explorer !
    the problem is with the Original poster :p
     
  14. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    hmmm. I'm upset cause I can't play my favorite game cause I can't reinstall/update the game for this particular reason.

    maybe the above mentioned apps are not compatible for a70. can anyone try the picsart app. good photo editing app from top developers . try and post ..its being installed or not. I have posted the link before.
     
  15. akshaybz

    akshaybz Well-Known Member

    Joined:
    Aug 28, 2011
    Messages:
    481
    Likes Received:
    78
    Actually it's not that it isn't compatible..
    It's a bug in A70.
    I never mentioned it but facing this issue since LeandrOS 1.
    Till now, only able to solve by re-flashing the ROM.
    Or, you can set the default storage to internal and it will install ;)
     
  16. mastermind1024

    mastermind1024 Well-Known Member

    Joined:
    Oct 13, 2011
    Messages:
    994
    Likes Received:
    410
    But bro u said "I m facing the issue" instead of I m NOT facing the issue...that's y akshay said so.
     
  17. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    Lol this is getting funnier :p

    I think, we must stop it :D
     
  18. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    maybe noob question but how to do it.
    cause I have never set that SD card as default and have enough internal memory. when I download any app from market its being downloaded in internal memory not in SD card so its ...
     
  19. JulyDerek

    JulyDerek Well-Known Member

    Joined:
    Dec 14, 2010
    Messages:
    102
    Likes Received:
    12
    There are many App to SD apps in the Play store. Download the most popular one, it will do it for you if you don't want to manually do each one.
     
  20. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    my phone isn't rooted. :(


    @all I think its getting diverted cause I have 60mb internal storage and these apps need 28mb ...so nothing to do with "apps to SD type" things ........
     
  21. akshaybz

    akshaybz Well-Known Member

    Joined:
    Aug 28, 2011
    Messages:
    481
    Likes Received:
    78
    Connect your phone to PC and then use following commands in terminal:
    Code (Text):
    1. adb shell pm getInstallLocation
    That should give you your current install location. (Should be 0 [auto] by default)

    Then run this:
    Code (Text):
    1. adb shell pm setInstallLocation 1
    This will set to internal.
    Try and post back ;)
     
    ninadchaudhari likes this.
  22. Idk5

    Idk5 Member This Topic's Starter

    Joined:
    Oct 7, 2011
    Messages:
    23
    Likes Received:
    0
    ^^ cool, but i didnt try your method cuz.....

    omg I was so desperate that i hit restore factory setting but problem remained then finally i formatted my sd card and its back to normal now. Now i can play my favorite 3D mmorpg game.

    Thanks aksh, you treated it like a professional expert would do. Thanks nand for your continued interest and special thanks to garg. Who actually solved my problem.

    Thanks android forums.

    Lol lol lol, its getting funnier
     
  23. abyjain007

    abyjain007 Active Member

    Joined:
    Oct 6, 2011
    Messages:
    28
    Likes Received:
    7
    Using root explorer just delete the file in the following dir:
    mnt/secure/asec/smdl2tmp1.asec

    Ur problem will be solved..


    Hit thanks if it helped...!!
     
    akshaybz likes this.
  24. akshaybz

    akshaybz Well-Known Member

    Joined:
    Aug 28, 2011
    Messages:
    481
    Likes Received:
    78
    That certainly helped!
    Mind explaining the reason why that happens?
     
  25. ninadchaudhari

    ninadchaudhari What's up !

    Joined:
    Nov 17, 2011
    Messages:
    1,800
    Likes Received:
    526
    Well ,
    Let me explain :)
    I do not know If the poster does actually knows this !
    this solution was placed in HTC desire thread , which simply instructed to do the same :p
    but with no additional info :D

    If you study droid , When droid places app to sd card , it actually encrypts the app and places it in the .android_secure folder ...
    This folder is mounted at the system start in "secure"
    I.e, now /sdcard/.android_secure = /mnt/secure

    .asec is a kind of encrypted file that Android creates! this can only be decoded by the same Device :p
    not even another device can decode it ! that is the best part :)
    btw it stands for [ android secure ]

    This file , i mean "smdl2tmp1" is a temporary file created which follows the above principals !!
    and as the name suggests its a Temporary file ! hence can be deleted as per u wish !!

    infact another way to do the same stuff is like ,

    remove the same file from /sdcard/.android_secure folder !!
     

Share This Page

Loading...