Problem installing CWM/Error booting into recovery


  1. IronKielbasa

    IronKielbasa Member

    Hi Hi Everyone,

    I have a Asus TF700 (running the latest Asus firmware) the, warranty just ran out so I figured it was time to unlock and play with some custom roms.

    I got it unlocked using the Asus bootloader tool, I went to install CWM using fastboot and it seemed to go OK but then when I went to reboot the bootloader it failed giving me a write failure. Now when I try to boot up recovery it briefly shows the android guy in working mode then goes to the error with the android laying on his back.

    Here is my commands with fastboot:

    C:\adb>adb reboot bootloader


    C:\adb>fastboot flash recovery recovery.img
    sending 'recovery' (6688 KB)...
    OKAY [ 2.483s]
    writing 'recovery'...
    OKAY [ 2.409s]
    finished. total time: 4.893s

    C:\adb>fastboot reboot-bootloader
    rebooting into bootloader...
    FAILED (command write failed (Unknown error))
    finished. total time: 0.636s

    C:\adb>adb reboot bootloader
    error: device not found

    And that's it, I'm a bit stumped not sure how to fix it so I can move onto installing the roms, any help would be greatly appreciated.

    Advertisement
  2. scary alien

    scary alien not really so scary Moderator

    Welcome to our AndroidForums, IronKielbasa!

    I don't have this device, but your fastboot errors seem familiar...would you happen to be using a USB 3.0 port?

    If so, try switching to a 2.0 port and see if that fixes your write errors with fastboot.

    If that's not it, hopefully others will chime-in with something that will help.

    Cheers!
    IronKielbasa likes this.
  3. IronKielbasa

    IronKielbasa Member

    Hi Scary Alien, thanks for the reply!

    So that fixed the write error but still cannot start the recovery, it still gives me the error screen.

    Edit: Scratch that, I thought it fixed it as it worked when I tried it but then I thought I would re-flash the recovery to see if that worked and I got the same error when I tried to reboot.

    Edit 2; New issue, now fastboot reboot won't even try, it just sits there saying "waiting for device" but adb reboot works fine. Still can't boot recovery.

    I tried installing mod manager but it says there is no version of CWM for this device (even though there is).
  4. IronKielbasa

    IronKielbasa Member

    Ok so I've finally made progress and I think it's OK now.

    After messing with it all morning I gave up with CWM, for some reason it was messing everything up I even had to re-install adb/fastboot to get it to recognize the device again.

    I installed the latest version of twrp and it seems to be working a-ok.

    Thanks again Scary Alien, appreciate you taking the time to help.
    scary alien likes this.
  5. scary alien

    scary alien not really so scary Moderator

    ^^^ :thumbup: :) :) :)
  6. IronKielbasa

    IronKielbasa Member

    Another note, I'm sure I'm one of the last few still using the TF700/300 but if you have the latest version of the Asus firmware installed (4.2.1) make sure you get the Hairy Beans version for TF300 and the Open Recovery version for TF700 of TWRP. It seems the official version does not support the 4.2.1 boot loader (as I found out the hard way).
    scary alien likes this.

Share This Page