1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Problem installing my first custom ROM


  1. wayrad

    wayrad Well-Known Member

    Well, after a few weeks of being rooted, getting rid of bloatware, etc., I decided to give Virtuous 3.1 a try, and downloaded it to my SD card using ROM Manager. I backed up all data in apps that had their own backup utilities and made a Titanium backup and then a nandroid in clockworkmod. After reading a number of threads, I figured ROM Manager should be OK for installing Virtuous, so I selected "install from SD", navigated to the correct file, and checked the backup and wipe options (I already had a nandroid, but figured another backup couldn't hurt). Anyway, for about 10 minutes, all I saw was a mildly disgruntled-looking android figure and a triangle with an exclamation point, which from my reading isn't what is supposed to happen.

    I finally pressed the power button and it went into ClockworkMod Recovery with the following message (below the menu):

    ClockworkMod Recovery v2.5.0.5
    Finding update package...
    Opening update package...
    Verifying update package...
    E:failed to seek in /cache/update.zip (Invalid argument)
    E:signature verification failed
    Installation aborted

    I used ClockworkMod Recovery to reboot, and everything seems normal, no data lost or anything - but what did I do wrong?

    Advertisement
    :
  2. NoShftShck16

    NoShftShck16 Well-Known Member

    Where did you place the .zip for Virtuous? unless it was named update.zip and placed at the root of the zip card, it wouldnt have found it (from what the error says).

    Since you have backups you cant really go wrong anyway.

    Use ROM Manager to boot into recovery, in recovery go to install zip from sd card, navigate to the right one and do it that way. You shouldn't have a problem.
    wayrad likes this.
  3. wayrad

    wayrad Well-Known Member

    Aha, I see, I had read somewhere that you didn't need to rename it, and thought ROM Manager would recognize it since it had downloaded it itself... Does it need to be renamed if doing it the way you suggest? I just tried it without renaming and get the following:

    --Installing:SDCARD:clockworkmod/download/files.virtuousrom.com/virtuous-inc_froyo_rom-v3.1.0.zip
    Finding update package...
    Opening update package...
    Verifying update package...
    E:signature verification failed
    Installation aborted

    I also no longer have a reboot option in the menu, so I'm wondering how to get out of this...battery pull and boot into clockworkmod recovery to restore from the nandroid, I guess?
  4. NoShftShck16

    NoShftShck16 Well-Known Member

    well before you do that, try redownloading the zip. maybe theres an error. like i said, you have a backup that you will restore, why not try a few more things?

    are you able to send me a screenshot of your software information (from within settings >> about) maybe hboot/radio need to be updated
  5. wayrad

    wayrad Well-Known Member

    OK, I pressed power again and got back to the first menu with the reboot option (whew! I thought maybe everything had been wiped, that's why I asked about restoring).

    I haven't really investigated how to do screenies yet, but here's the info:

    Android version:
    2.2

    Baseband version
    2.15.00.07.28

    Kernel version
    2.6.32.15-gb7b01d1
    htc-kernel@and18-2 #1

    Build number
    3.21.605.1 CL231334 release-keys

    Software number
    3.21.605.1

    Browser version
    WebKit 3.1

    PRI Version
    1.28_002

    PRL Version
    52011

    ERI Version
    5

    I'll try downloading again as you suggest. Thanks for your help and patience!
  6. NoShftShck16

    NoShftShck16 Well-Known Member

    drocap2 for root users - Android app on AppBrain

    ^drocap2 for screenshots, turn on and shake for screenshot^

    everything looks good in there. when you are about to reflash again power off and do Vol + Pwer to get to bootloader.

    Check what version of HBoot you have, some ROMs need 92 min, some need 79+

    You can find it at the very top of the screen in bootloader
  7. wayrad

    wayrad Well-Known Member

    OK, redownloaded (on the PC this time), checked md5 (looks fine), copied the zip over the previous copy. HBOOT is 92, is that OK?

    Got drocap, looks useful, thanks!

    Edited to add: Doing it straight from clockworkmod this time (w/o RM), things are happening...no error messages yet...fingers crossed!
  8. NoShftShck16

    NoShftShck16 Well-Known Member

    Good! Looks like you are doing everything correct. If you do get issues, the last thing I suggest is to do a wipe of everything.

    Here is my pre-flash wipedown steps (all from recovery)
    -wipe date/factory reset
    -wipe cache partition
    (from mounts/storage)
    -wipe system
    -wipe data
    -wipe cache
    (from advanced)
    -wipe dalvik cache

    Good luck! Let me know how it goes
  9. wayrad

    wayrad Well-Known Member

    Oops - ClockworkMod recovery said the install was completed, but when I reboot it freezes on the droid eye after the boot animation. Should I try a data wipe?

    Edited to add: Cross-posted. looks like I jumped some steps; I'll go back and do it like you just said.
  10. NoShftShck16

    NoShftShck16 Well-Known Member

    yeah probably, try what i listed. some call it redundant, i call it thorough :cool:
  11. wayrad

    wayrad Well-Known Member

    Oh heck. I did data/factory reset, wiped cache partition, wiped Dalvik (message:
    formatting CACHE...
    cache wipe complete.
    E: Can't mount /dev/block/mmcblk1p2 (File exists)
    Dalvik cache wiped.

    There was no wipe system option in my Clockworkmod version.

    Tried the install then and selected the file with the most recent date from the list, but I just get the message "No files found". Help!

    PS. I bet when I do it this way it does want the zip in the root directory...? ANyway, I'm going to try restoring from backup. My, this is an adventure.:eek:
  12. NoShftShck16

    NoShftShck16 Well-Known Member

    nah, never put my stuff on root. i have a i have a folder called "Incredible" and in there are folders called, ADDONS, APP, ROMs, KERNELS, etc and i flash from there.

    this is an adventure haha
  13. wayrad

    wayrad Well-Known Member

    Did the restore, rebooted. Still freezes on droid eye. This does not seem good.

    Oops, I just didn't wait long enough! Whew. My data is there, even!

    Maybe Virtuous would've booted if I'd just waited longer. But I think I need a rest before I try this again...
  14. dscribe

    dscribe Well-Known Member

    Always be aware that the the first boot after installing a rom is going to take a long time, you have to be patient.
    wayrad likes this.
  15. NoShftShck16

    NoShftShck16 Well-Known Member

    yeah i'm addicted. been through those problems too. one time i messed up, did a battery pull during what i thought was a bootloop and damaged my SD, losing all ways of backup my phone. that was a fun experience
  16. wayrad

    wayrad Well-Known Member

    NoShftShck16 likes this.
  17. wayrad

    wayrad Well-Known Member

    Bingo, got it (after soothing my nerves with chocolate and caffeine and then giving it another try). Still got the same error message when I tried from RomManager, but it worked from Clockworkmod Recovery - no wipe, I just waited longer for the reboot.

    Gmail and Voice Search are FCing on me, any ideas? Probably easy to fix but my brain's a bit fried. (edited to add: Oh yes, need to wipe and do Titanium restore I bet?)
  18. NoShftShck16

    NoShftShck16 Well-Known Member

    go to the market and update both. what ROM did you choose?

    personally, id head to XDA and read over the ROM there (instead of in the ROMs section here). there are far more communication about issues with the ROM and fixes.
  19. wayrad

    wayrad Well-Known Member

    yup, just did it, restoring missing apps+data now.

    I used Virtuous 3.1. Seemed like it would be stable and easy to install (hah!)
  20. NoShftShck16

    NoShftShck16 Well-Known Member

    stop!

    Dont restore data! Especially with titanium!

    EDIT: wanted to get that in ASAP, but you want to restore APP ONLY if you are doing it with titanium. it tends to carry over corrupt data that wil f with your ROM.
  21. wayrad

    wayrad Well-Known Member

    I didn't back up data for system apps except for those Titanium said it was safe to, is it still a problem?
  22. NoShftShck16

    NoShftShck16 Well-Known Member

    devs (especially today for some reason) have said AppBrain is better as a "backup" for apps because it just reinstalls them from the market. I still use titanium however after several issues leading to reflashes, i've avoided restoring any type of data.
  23. wayrad

    wayrad Well-Known Member

    Well, things seem to be working OK, except it looks like I need to set up my screens and widgets again, no big deal. And I had to reimport my contacts from the card (I don't sync them with Google), and my calendar entries seem to have disappeared for the moment (nope, they just came back courtesy of Google). But otherwise everything I've tried seems fine.
  24. NoShftShck16

    NoShftShck16 Well-Known Member

    in that case, awesome! congrats on successfully, if not painfully, getting through it!
  25. wayrad

    wayrad Well-Known Member

    Thanks very much for your help!

    Hmm, looks like all the bloatware is back, but Virtuous supposedly makes it easy to remove. A job for tomorrow.
Loading...

Share This Page