Problem with activating MetroPCS.Support


Last Updated:

  1. vyncentcarver

    vyncentcarver Member

    Hello everyone. I'm very new to this android modding thing, in fact, I obtained my first droid phone, the Huawei Ascend, yesterday.

    I've had a weird string of events occur. I used to use a Samsung Code, and a friend spilled soda all over it. He gave me his old Ascend to repay me, and I instantly took it home to start modding it, as I do with most devices.

    I installed cm7 and all of the gapps and everything, and it worked fine with Wi-Fi and everything. I took it to the metro store to have them activate it, and he said that he couldn't input a certain key in order to activate the phone on my account because it was modded. The key was to be input on the dial screen as ##626*, and a message would pop up on 2.2

    I followed a thread here where someone said to call *228 and have it activated, but he scanned my serial at the store, so the phone is already activated on my account. I called support, and she had me input the same code to no avail.

    I've been looking into flashing back to 2.2 or 2.1 just to have them activate my phone, and then I'll immediately update back to cm7.

    Every attempt at flashing to the stock version has been a failure. I followed this thread, how-flash-huawei-ascend-stock, and still I cannot do it. When I try to do the StockRecover with scripts, the phone won't update. it sits on waiting for device, and I have it sitting on the Huawei loading screen plugged into the USB right now.

    I even tried loading someone else's backup, and it still wouldn't work.

    I'm wondering if there's a way to either a) input a different code to activate my service, or b) a for sure way to flash my phone back to original settings.

    Thank you!

    Advertisement
  2. Kuzco

    Kuzco Well-Known Member

    Damn that sucks, you should have made a back up of the stock, I know I did that. I knew that they can't activate it when its modded. Hopefully, you can find a solution.
  3. ShinySide

    ShinySide Disabled

    Its because debugging isnt on or isnt working is why.
  4. swtnss

    swtnss Well-Known Member

    Install the usb drivers then try to flash back to stock again. Check the usb wire. you may have to change it. Thats what i had to do. I was able to flash back to stock after that.
  5. capfl2k5

    capfl2k5 Active Member

    You could do *228 and swap phones to another one. then wait a bit and swap it back to the ascend the same way. no trip to the store or anything. or if it is already active just put the programming info in manually with qpst or some other program.
  6. nuttmeg

    nuttmeg Well-Known Member

    reverting back to stock, ok power down the phone and download and extract this to your desktop MetroStockRecovery-SCRIPTS.zip after you done that press and hold vol down, end key and tap power, your phone should be on the white huawei screen and it should stay there plug your phone to the computer via usb cable, now open the folder that you extracted and run both of these file, first run fastboot-windows you will see a black box come and leave quick, next run metroPCSStock-windows.bat than another black box will pop up and it will do its thing, once it finishes the phone will automatic reboot itself.
  7. luilu

    luilu New Member

    sweet!!!
    Thanks this worked for me

Share This Page