problem with battery coverSupport


Last Updated:

  1. zafonic

    zafonic Well-Known Member This Topic's Starter

    Joined:
    Mar 31, 2010
    Messages:
    552
    Likes Received:
    18
    I have just noticed over the last few days that when I change my battery and put my battery cover back on that the left side in the middle is slightly raised. I have made sure that I have pushed down enough but no good. I have even bought a new battery cover but still the same problem.

    Can anyone tell me why this maybe happening and what I can do?? Has anyone else had a similar problem?
     

    Advertisement
  2. Trito

    Trito Well-Known Member

    Joined:
    Oct 17, 2010
    Messages:
    91
    Likes Received:
    0
    Jup I do jave similar problem, still dont know why.
     
  3. LECTER

    LECTER Well-Known Member

    Joined:
    Jul 27, 2010
    Messages:
    1,546
    Likes Received:
    233
    Always start from the bottom up, should click right into place.
     
  4. Trito

    Trito Well-Known Member

    Joined:
    Oct 17, 2010
    Messages:
    91
    Likes Received:
    0
    still it's a bit off in left up corner.
     
  5. Rastaman-FB

    Rastaman-FB Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,113
    Likes Received:
    1,010
    one of the clips has probably bent or snapped

    check that all clips are intact.
    you can buy new back covers for
     
  6. Trito

    Trito Well-Known Member

    Joined:
    Oct 17, 2010
    Messages:
    91
    Likes Received:
    0
    well that's the strange thing all clips are ok.
     

Share This Page

Loading...