Problem with dropped data connection after CM6 root (GBD)


Last Updated: 2010-10-11 15:39:11
  1. i2004tor

    i2004tor Member

    Hi there,

    I just rooted my post-911 update Rogers Magic a couple of days ago, using GBD's latest script method. Thanks and kudos to GBD's work, by the way. Just fantastic work, and made it easy for a newbie like me to root the phone.

    The only issue that's come up since I rooted the phone is that about twice a day, the data connection just stops working. All of a sudden I'll stop being able to connect to the internet. The 3G indicator in the status bar would show the UP arrow, but not the DOWN arrow, and then after a minute or so, the 3G indicator will disappear altogether. The only way to get the connection back is to either reboot the phone, or toggle the airplane mode on and then off.

    Any idea what might be causing this, and how to fix it? And remember -- I'm a complete newbie here who only succeeded in rooting the phone by following GBD's instructions letter by letter, and typing in commands about which I knew nothing :).

    Thanks in advance for any insight to this problem.

    Advertisement
    jeifei72 likes this.
  2. thor124

    thor124 Well-Known Member

    I'm 95% sure that this is a bug with the E911 radio from the HTC Dream. This radio is installed on HTC Magics when rooting and installing CM.

    See this post here

    For my phones I know that effects my ability to make or receive phone calls or text messages as well.

    To fix your phone must be rebooted or put in then out of airport mode. This forces the phone to establish a fresh connection the the network.
  3. GreatBigDog

    GreatBigDog Well-Known Member

    I've noticed this myself, but only since the stable release. I'm wondering if it has something to do with the ebi1 port, I'm going to try flashing a slightly older nightly to see if that fixes it.
  4. vikingisson

    vikingisson Well-Known Member

    I haven't seen this issue. I'm running the FroyoRedux mod and the only important difference might be the kernel (port) and since we're running the "approved" radio version this could be why mine doesn't drop. Most of the international users are running a slightly different radio. This is on my Magic, not a Dream. (If you're running the new radio then you have other problems such as a non working camera)

    In this shot I don't have a SIM card installed but it has worked fine since CM6 stable.

    [​IMG]
  5. i2004tor

    i2004tor Member

    Thanks for the input so far, guys.

    I should add that earlier today, after seeing similar issues posted on GBD's site, I called Rogers and had them refresh my network. I was hopeful that it would stop this issue from happening, but it just happened again.

    Any other ideas?

    Thanks.
  6. cezegg

    cezegg Active Member

    vikingsson, i actually had a problem with that rom today... i couldn't make/receive calls, and my texts came an hour later than they had sent.

    could the OP's problem be APNs? just a shot in the dark... i don't know enough to have a big hand in helping, as i'm still learning... and i just had APN troubles myself, and when i had the wrong APN settings on, i'd have a gsm connection, but no 3g/edge data connection.
  7. Silvertag

    Silvertag Well-Known Member

    I had the same issue on my Magic when i crossed from the CM-6 Nightly to 6.0 stable. I had to use airplane mode to force it back on the network. I did not do any other special tricks to it but after 1 week it stabilised itself and never had to play around with it.

    Hboot 1.33.2010
    Radio 3.22.23.18
  8. vikingisson

    vikingisson Well-Known Member

    I don't know enough either except that it doesn't happen to mine. Are you sure that you have the 3.22.26.17 radio? The only difference on mine is that I've switched between the old and new radios a few times and got used to doing that quickly from fastboot, maybe reflash the radio?
  9. GreatBigDog

    GreatBigDog Well-Known Member

    Here are a couple of different APN settings you can try.

    1st. uses the 2 separate APN's that came with CM6

    In Rogers APN, change the type from <not set> to "default, supl" without the quotes
    In Rogers MMS APN change the type from <not set> to "mms" without the quotes

    2nd uses one APN setting only

    Name - Rogers
    APN - rogers-core-appl1.apn
    MMSC http://mms.gprs.rogers.com
    MMS proxy - 10.128.1.69
    MMS port - 80
    MCC - 302
    MNC 720

    everything else left blank or <not set>
  10. cezegg

    cezegg Active Member

    yup i'm on that radio.
    but i'd like to refrain from hijacking this thread. haha
  11. thor124

    thor124 Well-Known Member

    It is a bug with the Dream radio, I've observed it on my stock-post-E911-HTC Dream, and my Magic never had a problem until I rooted it and put CM5.0.7 on it with that radio. Then when i revereted to stock on the magic it went away. Then when i re-rooted the Magic for CM6, it came back. Its the bloody radio.
  12. tsouthen

    tsouthen Active Member

    I too have experienced this with CM 6 stable, hopefully we'll be able to get a new radio from the 2.1 update when it comes.
  13. GreatBigDog

    GreatBigDog Well-Known Member

    That will be a 1.76.x radio, it's not compatible with CM. If you want to use that radio, you'll have to look around for a ROM that is compatible with that radio.

    gbd
  14. tsouthen

    tsouthen Active Member

    Ah, I had no idea thanks for the information. I'm pretty darn happy with CM6, don't think I'll be changing to anything else. :)
  15. va3jlf

    va3jlf Member

    I've had this problem too from the start when I rooted to CM5.0.7 so I agree it appears like a bug introduced following the root process. In my case as well, it is not only my data connection that dies, also the voice phone sometimes drops as well. It wouldn't be such a problem if it were only the data because it is easy to notice that, but voice could be cut off without realizing unless you tried to make a call. Someone calling you would presumably go to voicemail. I have found that even toggling data enabled will sometimes fix it.

    Will there ever be a fix for this?

    I really like CM particularly CM6 aside from this particular issue.

    My phone is the HTC Magic running CM6 stable.

  16. i2004tor

    i2004tor Member

    Thanks for the suggestions, guys.

    With the new 2.1 Rogers update out -- has someone found a way to apply a more up-to-date radio for someone like me with CM6? Maybe that would solve this problem.

    Worst comes to worst, if I keep dropping data connection like this -- what would be the procedure for me to load the Rogers 2.1 update that just came out? I can't do the OTA update in the way that Rogers released it, I gather because I'm rooted......
  17. thor124

    thor124 Well-Known Member

    If/When CM is updated for a newer radio.

    And yes, incoming calls go to voice mail. This issue caused some stress between me and my fiancee (she thought I was mad at here and putting it straight to VM)
  18. Forts

    Forts Well-Known Member

    I have been experiencing the same problem since rooting my phone as well. Had it with CM5 and 6. So today I thought I would be clever and load the new stock Rogers 2.1 release and see if it fixed things... well, the update failed and now my phone is stuck in the RUU boot screen and I have no idea how to proceed... but I'll start a new thread for that.
  19. markW

    markW Member

    I have the same issue after flashing CM6 stable. Can anyone else confirm that the radio stabilizes after a week?

    Thanks,
    Mark
  20. vikingisson

    vikingisson Well-Known Member

    Radio 3.22.23.18?? Have you tried the "official" radio 3.22.26.17? I haven't had issues with that one.
  21. va3jlf

    va3jlf Member

    My radio is 3.22.26.17 and HBoot 1.33.2005. My phone has not stabilized at all. It loses connectivity several times a day.

    Does anyone have a procedure for going back to Rogers stock radio?

  22. thor124

    thor124 Well-Known Member

    My magic has the same radio and spl... no stabilization after a week. Also as I've mentioned before, my dream has the same issue both with CM6 and stock rogers 1.5(post E911)
  23. GreatBigDog

    GreatBigDog Well-Known Member

    va3jlf likes this.
  24. va3jlf

    va3jlf Member

  25. GreatBigDog

    GreatBigDog Well-Known Member

    No the 911 problem was related to the rom not the radio. Yes you'll have to fill out the waiver on Rogers site or your data will get cut.

    Sorry but I don't have a link to the waiver page.

    gbd

Share This Page