Problem with my Incredible


  1. shinedown_323

    shinedown_323 New Member

    I recently switched back to my Incredible after fixing a battery issue. When I started it up, random apps weren't working. I would try to click on Play Store and it wouldn't open. Sometimes it wouldn't even show up on the Apps list. I would set widgets and when i restarted, there would be a "Problem Loading Widget" box. It also asks me to re-login to my Google account for the phone. Almost like the phone resets with each restart.

    I tried to hard reset, but when i turn the phone back on, apps still show up. Is there any way to reset it to be like out of the box new? Just wanting help. Would really not like to go back to my Blackberry Storm. :(

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Not a good sign... I've seen quite a few people with similar symptoms. It usually means the storage/partitions on the phone have become corrupted. Things may only get progressively worse.

    Things you can try are running a factory image, or rooting and hoping you can get a custom rom to run a little smoother. Rooting is a little riskier just because of the amount of steps that are required now, and involves flashing the phone a few times.

    And honestly, in the cases we have seen here, no one has been able to fix it.

    Let me know if you would like more info on flashing a factory image or rooting :)
  3. shinedown_323

    shinedown_323 New Member

    Meh, im going to be getting a Galaxy SIII soon, so i will just deal with the annoying stuff for now. Maybe make the SIII look even better once i get it. lol. Thanks
  4. today

    today Well-Known Member

    Could it be a problem with your memory card?

Share This Page