Problem with updating su binary


Last Updated:

  1. Forte201092

    Forte201092 New Member

    After updating the SuperUser, I've been notified that my su binary need updating. Then, I tried to update it, and this is the message I got:

    Code (Text):
    1. Downloading manifest... [COLOR=Lime]okay![/COLOR]
    2. Parsing manifest... [COLOR=Lime]okay![/COLOR]
    3. Latest version = [COLOR=Lime]3.1.1[/COLOR]
    4. Checking installed version = [COLOR=Red]2.3.2-efgh[/COLOR]
    5. Fixing database... [COLOR=Lime]okay![/COLOR]
    6. Unpacking sutools... [COLOR=Lime]okay![/COLOR]
    7. Checking current install path... [COLOR=Lime]/system/bin/su[/COLOR]
    8. Downloading new binary... [COLOR=Lime]okay![/COLOR]
    9. Gaining root access... [COLOR=Lime]okay![/COLOR]
    10. Remounting /system as rw... [COLOR=Lime]okay![/COLOR]
    11. Copying su to /system... [COLOR=Red]fail![/COLOR]
    I've rooted my phone and installed BusyBox Free. So, if anyone knows how to fix this error, please help me. Thank you so much!

    Advertisement
  2. iowabowtech

    iowabowtech root@android:/ #

    Hmm. Maybe try the SuperSU app instead? Superuser has been a little flakey for me lately too. I jumped ship to SuperSU.
  3. onelovetsr

    onelovetsr Member

    Wow you are awesome thank you so much for the fix it worked after a mllion other attemps wish i would have seen yours first but saved the best for last thanks again :)♥
  4. ajbhat1990

    ajbhat1990 New Member

    I cannot update the binaries as well , it stuck at gaining root access . When I try to use link2sd , it wants superuser permissions , but superuser is not working . It forces me to close superuser . Also su command is not working at the terminal emulator , I mean the $ does not turn to # , when i type the su command it just leaves a blank line and I can type anything after that . I reflashed the rom again to check , but its the same thing again . Suggestions?
  5. CafeKampuchia

    CafeKampuchia Well-Known Member

    Are you using the SuperUser or SuperSU app? Have you tried both?
  6. gopiprasad

    gopiprasad New Member

    i am using samsung tab 2, to intall ubutnu on it , hen i am trying su command it is giving erorr /system/bin/sh: su: not found plese hell me
  7. gopiprasad

    gopiprasad New Member

    /system/bin/sh: su: not found i am getting when i am trying to install ubuntu on samsung tab 2
  8. niteshnite

    niteshnite New Member

    Downloading manifest... okay! Parsing manifest... okay! Latest version = 3.1.1 Checking installed version = 2.3.2-efgh Fixing database... okay! Unpacking sutools... okay! Checking current install path... /system/bin/su Downloading new binary... Fail
  9. niteshnite

    niteshnite New Member

    plz help me fast.

Share This Page