Problem with Weatherbug Elite

Last Updated:


    UrsusVIIILXXXVII Well-Known Member

    I'm using version 2.5.288 and I can no longer see a map with the radar. Everything else works fine but I can only see a white grid instead of a map of any kind. I've uninstalled/reinstalled a few times with no results. Has anyone else had this problem?

    Is there any other app that's as comprehensive as weatherbug elite in the U.S.?

  2. Crimzon

    Crimzon New Member

    I am having the same problem .. tried everything but to no avail ... installed the free version and worx fine ... anyone have any ideas why this is happening ... thanx
  3. itsallgood

    itsallgood Well-Known Member

    I experienced this same problem with the doppler radar widget, on my Motorola Backflip. Sometimes I removed the widgets from the home screen and placed them back on the home screen again to fix the problem. I have an Atrix now, and haven't had the problem.
  4. lunatic59

    lunatic59 Moderati ergo sum Moderator

    If it appears to be a common problem with the app across multiple phones, you may want to contact the developer.
  5. Crimzon

    Crimzon New Member

    I have read some others posts on different sites and it seems that its due to an update .. not really sure

    is there any other weather app with decent radar?

    UrsusVIIILXXXVII Well-Known Member

    I now have version 2.5.358 and no longer have issues. Looks like the problem has been fixed.

    I actually forgot I had made the original post here. I had been using Mycast weather and it was...adequate. All I really wanted was animated radar but now since the newer version of weather bug is working, I deleted mycast.
  7. pmforester

    pmforester Active Member

    I have the most recent version and do not have a problem with the radar. However I have a problem in that the app will not update my location. Yes I have all the correct settings selected, I think, at least I have not changed anything since I installed many months ago. I can turn off and back on the enable my location selection and it will update but that is the only time.

    Any ideas? This sucks!!
  8. itsallgood

    itsallgood Well-Known Member

    Make sure you have the update rate set right.

Share This Page