Problem with WiFi connectionSupport


  1. antsh

    antsh Member

    Hi,

    Very often I can't connect my HTC Magic to WiFi ruuter, although my MacBook connects to WiFi without any problems.

    In WI-FI networks I see:
    "Connection unsuccessful, select to try again"

    How can I debug this problem, there should be logs stored somewhere.

    Advertisement
  2. Edamame Guy

    Edamame Guy Member

    You can try hopping onto your router to see if its even hitting the router, maybe you have to allow the IP?
  3. antsh

    antsh Member

    already checked that, the MAC of HTC Magic is allowed + it sometimes does connect to the router, but most often doesn't.
  4. sixpack

    sixpack Active Member

    Had this same problem with my wireless router and HTC Magic. I found that for some reason the MAC filtering setting in the router was not allowing the phone to connect, even tho I had entered the MAC address into the router settings. The error in the router log was somthing like; "Device unable to connect, details are beyond the scope of this log".

    Disabling the MAC filter option in the router was the only thing that worked for me. Post back if you find a solution as I would sure like to keep the MAC filtering on!
  5. antsh

    antsh Member

    Turend off MAC-Filtering and also DHCP Reservation by MAC address and seems this helps, at least I am able to connect to the Internet without any problems. Thx for the tip ;)
  6. Kill-K

    Kill-K Member

    What router are you using?
  7. Britman

    Britman New Member

    Hey guys,
    I have the a similar problem, the just doesn't connect straight way, always get the same message as antsh. but if I go to setting and click my network to connect, 80% of the time it will connect, the rest of the time I reboot fixes it, but not the connecting automatically.
    Even a recent factory reset didn't solve it. I guess it could be my router which is a Linksys WRT54GR and I don't have MAC filtering enabled

    My phone is on Vodafone UK and has firmware 1.6

Share This Page